Subject: [Dime] WGLC starting for draft-ietf-dime-realm-based-redirect

From: jouni korhonen <[email-masked]>
Date: Mon, 2 Aug 2010 13:26:00 +0300

A two weeks WGLC for Realm-Based Redirection In Diameter (draft-ietf-dime-realm-based-redirect-03) starts as of today 2-Aug-2010 and ends on Monday 16-Aug-2010 23:59 (CEST+1).

We _require_ at least three reviews from people who are not authors of the document. In case of an inadequate review success, we'll just keep the document in the WG and go for another WGLC later (that will again need a new set of three reviews ;). So lobby people to review!

- Jouni & Lionel

---

From: "Glen Zorn" <[email-masked]>
Date: Mon, 2 Aug 2010 17:48:50 +0200

Looks fine to me; the only thing that I might add would be a more direct
pointer to the "normal discovery procedures" mentioned in Section 3.1.2.

Hope this helps.

 ~gwz

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> jouni korhonen
> Sent: Monday, August 02, 2010 12:26 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: [Dime] WGLC starting for draft-ietf-dime-realm-based-redirect
> 
> A two weeks WGLC for Realm-Based Redirection In Diameter (draft-ietf-
> dime-realm-based-redirect-03) starts as of today 2-Aug-2010 and ends on
> Monday 16-Aug-2010 23:59 (CEST+1).
> 
> We _require_ at least three reviews from people who are not authors of
> the document. In case of an inadequate review success, we'll just keep
> the document in the WG and go for another WGLC later (that will again
> need a new set of three reviews ;). So lobby people to review!
> 
> - Jouni & Lionel
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: Avi Lior <[email-masked]>
Date: Wed, 11 Aug 2010 16:28:43 -0400

Hi,

I have reviewed draft-ietf-dime-realm-based-redirect-03 document -- or I should say i started but I had to stop because there are serious fundamental issues with this draft.

I should start with the fact that i think the problem statement raised by the draft is valid. Also, I think that Diameter base 3588 should have supported Realm based redirection as well as host based redirection. Actually Realm-based redirection are probably more useful.

However, the problem I am having is that the draft is changing the semantics of a Redirect Agent as defined by base and I dont think that we should be allowed to do that.

I get that the draft got around backwards capability issue surrounding the new AVPs be introduced by asserting that only new applications will support the attributes.

But in order to deliver this feature in 3588 the behavior of the Redirect Agent had to change.

This new redirect agent has to differentiate between applications that do support realm base redirection vs non-realmbased redirection.

This is new base behavior and thus should be done in Diameter V2

There is an alternative - which i thought was the approach taken when i started to read the draft and that is:

-let the Application itself perform the redirection.  To use the example provided, if the operator does not want to host the application anymore, it can let the Application respond back with the realm and/host redirection attributes.

On 02-08-2010, at 10:11 , Tina TSOU wrote:

Hi Avi, would u like to review it? 3 reviews at least are requested. Wish u in purple:)

B. R.
Tina
http://tinatsou.weebly.com/index.html
/div>

Begin forwarded message:

From: jouni korhonen <[email-masked]<mailto:[email-masked]>>
Date: August 2, 2010 12:26:00 PM GMT+02:00
To: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: WGLC starting for draft-ietf-dime-realm-based-redirect

- Jouni & Lionel

Avi Lior
[email-masked]<mailto:[email-masked]>
office: +1 613-591-9104x6417
    cell: +1 613-796-4183

---

From: "Glen Zorn" <[email-masked]>
Date: Mon, 16 Aug 2010 16:13:27 +0700

Avi Lior [mailto://[email-masked]]
<mailto:[mailto://[email-masked]%5d>  writes:

Hi,

I have reviewed draft-ietf-dime-realm-based-redirect-03 document -- or I
should say i started but I had to stop because there are serious fundamental
issues with this draft.

I should start with the fact that i think the problem statement raised by
the draft is valid. Also, I think that Diameter base 3588 should have
supported Realm based redirection as well as host based redirection.
Actually Realm-based redirection are probably more useful.

However, the problem I am having is that the draft is changing the semantics
of a Redirect Agent as defined by base and I dont think that we should be
allowed to do that.

If the change in behavior is backward-compatible, why not?

I get that the draft got around backwards capability issue surrounding the
new AVPs be introduced by asserting that only new applications will support
the attributes.

But in order to deliver this feature in 3588 the behavior of the Redirect
Agent had to change.

This new redirect agent has to differentiate between applications that do
support realm base redirection vs non-realmbased redirection.

There is an alternative - which i thought was the approach taken when i
started to read the draft and that is:

-let the Application itself perform the redirection.  To use the example
provided, if the operator does not want to host the application anymore, it
can let the Application respond back with the realm and/host redirection
attributes.

---

From: Avi Lior <[email-masked]>
Date: Mon, 16 Aug 2010 17:12:13 -0400

On 16-08-2010, at 05:13 , Glen Zorn wrote:

Its not just sufficient to know that an added feature is backwards compatible.

The "approach" taken in Diameter design is that the one entity knows the behavior/capability of a particular another entity.  If you simply add functionality to something how would I know that the new features that i want to use are supported.

Specifically, how do I know that when I forward a message to a Redirect Agent that I would be able to get realm-redirections.  If I have two relay agents how would I know which one to use.

We have to decide that we are okay with building functionality into entities without having the ability to know whether those entities support those features.  And if we are okay with that then that is great.

 The draft solves the problem one way -- it allows the Redirect Agent know whether an Application can handle the new redirect attributes.  How about the other way as well?

Avi Lior

---

From: <[email-masked]>
Date: Tue, 17 Aug 2010 12:42:40 +0200

Hi Avi,
 
If I'm correct, you are not sending a request TO a Redirect Agent but you are receiving an answer FROM a Redirect Agent.
Before receiving the answer with the Result-Code set to DIAMETER_REDIRECT_INDICATION, the Diameter agent only knows that it is sending the request to a Diameter agent advertizing the Relay application, which could be a Relay or a Redirect agent.
 
Why should the request originator have to know the redirection mechanism (host-based or Realm-based) supported by a possible redirect agent in the path?
Does it not have to rely only on the redirection information provided in the answer to know where to resend the request?
And if the request is for the Diameter X appl that supports the Realm-based redirection, it will be able to handle the specific realm-based info sent back by the Redirect Agent.
 
Regards,
 
Lionel

________________________________

	De : Avi Lior [mailto:[email-masked]] 
	Envoyé : lundi 16 août 2010 23:12
	À : Glen Zorn
	Cc : [email-masked]; [email-masked]; [email-masked]
	Objet : Re: [Dime] Review of draft-ietf-dime-realm-based-redirect-03

		

	
	
	Avi Lior
	[email-masked]
	office: +1 613-591-9104x6417
	    cell: +1 613-796-4183