Subject: [Dime] Comments on draft-ietf-dime-ikev2-psk-diameter-02

From: Sebastien Decugis <[email-masked]>
Date: Thu, 05 Aug 2010 17:20:51 +0900

Here are my comments on this document. They are only cosmetics. I think the document is ready to be moved forward.

1) What is the purpose of including the Auth-Request-Type AVP in the IKEv2-PSK-Request, since its value is constrained?

2) Security section: This section refers to Master-Security-Association AVP, which is not defined (I believe Key AVP is intended).
I also believe the second paragraph does not belong to this specification, but rather to 
I-D.ietf-dime-local-keytran. However, it does not harm as a reminder.

3) The reference section points to I-D.ietf-dime-local-keytran in version -01 
but the -06 is the latest, maybe an update would be useful.

That's all I have.

Best regards,
Sebastien.

-- 
Sebastien Decugis
Research fellow
Network Architecture Group
NICT (nict.go.jp)

---

From: "Cakulev, Violeta (Violeta)" <[email-masked]>
Date: Tue, 24 Aug 2010 12:22:31 -0500

Sebastien,
Thanks for your comments.
Please see the responses inline.

-Violeta

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sebastien Decugis
Sent: Thursday, August 05, 2010 4:21 AM
To: [email-masked]
Subject: [Dime] Comments on draft-ietf-dime-ikev2-psk-diameter-02

>>VC: I agree, today this value is constrained and probably not necessary, but it may change tomorrow. In addition, it is better to be explicit then implicit. So I propose to leave it as it is.

>>VC: Fixed.
I also believe the second paragraph does not belong to this specification, but rather to I-D.ietf-dime-local-keytran. However, it does not harm as a reminder.
>>VC: I agree with both of your points. It probably does not belong here, but it also does not harm, therefore I did not make any change.

3) The reference section points to I-D.ietf-dime-local-keytran in version -01 but the -06 is the latest, maybe an update would be useful.
>>VC: Yes, we need to upload a new version.

That's all I have.

Best regards,
Sebastien.

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime