Subject: [Dime] draft-ietf-dime-nat-control pool usage clarification

From: LUIS ENRIQUE IZAGUIRRE GAMIR <[email-masked]>
Date: Thu, 07 Oct 2010 17:17:52 +0200

Hello all,

I have the following question on “draft-ietf-dime-nat-control”:

DCNA defines the external address pool(s) to be used for allocating an external IP address per subscriber/endpoint, either pre-assigned with a NAT-Control-Binding-Rule AVP, or specified-within-a-request with a NAT-Control-Definition AVP. However, we don’t see clear in the draft whether it is possible to provide the same address pool within different requests for several subscribers/endpoints; this pool would be used by the NAT without overlapping the use of IP/port between these users.

What do you think? Would it be worth adding an explanation how the NAT device manages this situation, including the possible shortage of IP/port tuples?

On the other hand, does anybody know if there is a similar approach to this draft based on RADIUS?

Thanks!
Enrique Izaguirre.
Telefónica I+D.

---

From: "Shwetha Bhandari (shwethab)" <[email-masked]>
Date: Thu, 14 Oct 2010 15:35:00 +0530

Hi Enrique,
 
Thanks for the comment. We will add a line to explicitly state reuse of pool and external address for multiple subscribers.
 
We are not aware of a similar approach to this draft based on Radius. 
You can look at http://tools.ietf.org/html/draft-brockners-nat-control-protocols-review-00 , where we tried to compare this with other approaches available.
 
Thanks,
Shwetha

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of LUIS ENRIQUE IZAGUIRRE GAMIR
Sent: Thursday, October 07, 2010 8:48 PM
To: [email-masked]
Subject: [Dime] draft-ietf-dime-nat-control pool usage clarification

Hello all,

I have the following question on "draft-ietf-dime-nat-control":

DCNA defines the external address pool(s) to be used for allocating an external IP address per subscriber/endpoint, either pre-assigned with a NAT-Control-Binding-Rule AVP, or specified-within-a-request with a NAT-Control-Definition AVP. However, we don't see clear in the draft whether it is possible to provide the same address pool within different requests for several subscribers/endpoints; this pool would be used by the NAT without overlapping the use of IP/port between these users.

Thanks!

Enrique Izaguirre.

Telefónica I+D.