Subject: [Dime] [Technical Errata Reported] RFC6733 (6832)

From: RFC Errata System <[email-masked]>
Date: Thu, 3 Feb 2022 06:32:59 -0800 (PST)

The following errata report has been submitted for RFC6733,
"Diameter Base Protocol".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6832

--------------------------------------
Type: Technical
Reported by: Kshitij Dutt <[email-masked]>

Section: 7.1.4

Original Text
-------------
DIAMETER_OUT_OF_SPACE 4002

      A Diameter node received the accounting request but was unable to
      commit it to stable storage due to a temporary lack of space.

Corrected Text
--------------
DIAMETER_OUT_OF_SPACE 4002

      A Diameter node received the request but was unable to
      commit it to stable storage due to a temporary lack of space.

Notes
-----
Original text signifies accounting application explicitly. It can be any of Accounting or Authorization.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6733 (draft-ietf-dime-rfc3588bis-33)
--------------------------------------
Title               : Diameter Base Protocol
Publication Date    : October 2012
Author(s)           : V. Fajardo, Ed., J. Arkko, J. Loughney, G. Zorn, Ed.
Category            : PROPOSED STANDARD
Source              : Diameter Maintenance and Extensions
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Glen Zorn <[email-masked]>
Date: Thu, 3 Feb 2022 13:52:58 -0800

I think that this change needs a little more justification to be accepted.
For example, under what circumstances would a Diameter auth server be
writing to stable storage? IIRC, Diameter auth was designed to be
stateless...