Subject: Re: Editorial comments about DISMAN-EVENT-MIB

From: Randy Presuhn <[email-masked]>
Date: Thu, 6 Jan 2000 17:04:26 -0800 (PST)

Hi -

> Message-Id: <[email-masked]>
> Date: Thu, 06 Jan 2000 13:51:46 -0800
> To: Alan Luchuk <[email-masked]>, [email-masked]
> From: Ramanathan Kavasseri <[email-masked]>
> Subject: Re:  Editorial comments about DISMAN-EVENT-MIB
> Cc: [email-masked], [email-masked]
> In-Reply-To: <[email-masked]>
...
> >The mteTriggerExistenceTest object is defined (on page 24) as follows:
> >
> >   mteTriggerExistenceTest OBJECT-TYPE
> >       SYNTAX      BITS { present(0), absent(1), changed(2) }
> >       MAX-ACCESS  read-write
> >       STATUS      current
> >       DESCRIPTION
> >        "The type of existence test to perform.  The trigger fires
> >        when the object at mteTriggerValueID is seen to go from
> >        present to absent, from absent to present, or to have it's
> >        value changed, depending on which tests are selected.
> 
> Hmm, the above "have it's value changed" text seems to be in error.
> I'd like to see it removed, but it presents a significant operational
> change...Comments from the chair?

It looks like there was an inconsistancy.  It appears that
most of the text took the approach that state changes could be
considered for existence tests.  This may be a resaonable thing
to do, since there are MIBs in which setting an attribute to
"deleted" does not necessarily result in the disappearance
of the row in question.

> I don't think an "existence check" should have anything to do with
> testing values...
...

If this weren't SNMP, I'd be inclined to agree.  :-)
But hey, we do creation and deletion as side-effects
of SetRequest, so caution is in order.

Given that the weight of the text appears to support
including tests for value changes, and given that some
MIB objects don't immediately dissappear when "deleted",
let's leave the "value changed" text in there.

(By the way, the possessive pronoun is spelled "its", not
"it's".  It's the same pattern as for "hers", "yours", and
"ours" but not "mine". :-)

 ------------------------------------------------------------------------
 Randy Presuhn           [email-masked]       http://www.bmc.com/
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141  2141 N. First Street
 Fax:   +1 408 965-0359  San Jose, California 95131  USA
 ------------------------------------------------------------------------
 Any relationship between my opinions and BMC's should be coincidental.
 ------------------------------------------------------------------------

---

From: Ramanathan Kavasseri <[email-masked]>
Date: Thu, 06 Jan 2000 18:28:29 -0800

>of SetRequest, so caution is in order.

I feel like there are other triggers that we can define to watch for
the explicit value of an object instance, and "existence" should not
be the place for it. But I see your point about attributes being "marked"
as deleted, but not being removed. I can live with the existing text,
and if it becomes an issue, I'll raise it during implementation feedback...

>let's leave the "value changed" text in there.

ok.

>"ours" but not "mine". :-)

Yep...Typo'd.
:-)

Ram