Subject: Re: Remote Performance Management

From: Andy Bierman <[email-masked]>
Date: Mon, 13 Mar 2000 07:51:29 -0800

> Russell Dietz wrote:
> 
> Hello Folks!
> 
> I believe that it has been clear that many people are interested in both the passive monitoring and active performance testing.  I feel that our charter must address both of these areas.  However, active testing is a major configuration issue, if we all don't agree on some way to eliminate some of the typically configurable features of active agents.
> 
> I feel that we should have a specific discussion in Adelaide on this area.  Would any of the individuals that are interested care to make a 15 minute presentation on the requirements?  Please let the chair know ASAP!

The RMONMIB WG did not drop the Ping MIB because it was active vs. passive.
I remember there were people who wanted the MIB to support (almost) every
echo test ever conceived of, for any kind of network. Rather than visit
that rathole, we punted the whole MIB. It was an SNMPv1-only world back then,
and security concerns were also a factor. (There were those who wanted to
supply the agent with entire raw packet payloads for the agent to send!)

The RMONMIB APM charter is very clear. Configuration of active tests
is out of scope. The DISMAN RemOps MIB already has good Ping MIB 
support, so the RMONMIB WG doesn't need to duplicate that effort anyway.

There will be an entire meeting slot devoted to RMONMIB APM issues
(Th: 1300-1500), and 'control MIB linkage mechanisms' will be 
discussed during this meeting. But no 15 min. presentations, sorry).

> 
> See you all down under...
> 
> Russ
> 

Andy

> -----Original Message-----
> From: Carl W. Kalbfleisch [mailto:[email-masked]]
> Sent: Sunday, March 12, 2000 1:07 PM
> To: Dan Romascanu; 'Cole, Robert G (Bob), ALSVC'; disman-wg-ietf
> Cc: [email-masked]
> Subject: RE: Remote Performance Management
> 
> I indicated an interest in such work privately to Bob. I will mention on the
> list that I am interested so that the WG chair has a feeling that there are
> additional people interested in defining such things.
> 
> Carl
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Dan Romascanu
> > Sent: Sunday, March 12, 2000 9:13 AM
> > To: 'Cole, Robert G (Bob), ALSVC'; disman-wg-ietf
> > Cc: [email-masked]'
> > Subject: RE: Remote Performance Management
> >
> >
> >
> > Bob,
> >
> > Thanks, I understand now better what you are after. I agree that the place
> > to raise the issue might be DISMAN. In fact, the set of tools
> > that a network
> > manager would use for remote monitoring and managing his domain would be a
> > combination of 'passive' and 'active' tools. Some of the probes
> > and devices
> > in the network might also have the capability to perform in both
> > paradigms.
> > I would like to see some architectural correlation between the
> > two methods -
> > this may be a subject of an Informational RFC.
> >
> > As a historical note, 'Ping MIB' was once in the past on the RMON MIB WG
> > table, but it was taken out because the RMON group decided to deal
> > exclusively with the 'passive' approach. It landed eventually in the
> > remops-disman work.
> >
> > I am not sure about the status of the future work in DISMAN. If I am not
> > mistaken, the WG does not meet in Adelaide. I would be interested to
> > contribute to such a work, if it starts to be developed.
> >
> > Regards,
> >
> > Dan
> >
> >
> >
> >
> > > -----Original Message-----
> > > From:       Cole, Robert G (Bob), ALSVC [SMTP:[email-masked]]
> > > Sent:       Thu March 09 2000 20:29
> > > To: Dan Romascanu; disman-wg-ietf
> > > Cc: [email-masked]'
> > > Subject:    RE: Remote Performance Management
> > >
> > >
> > > Dan,
> > >
> > > Thanks for the note.  I have looked at the dsmon-mib
> > > that Andy posted.  As well, I attended the last rmonmib WG
> > > meeting in DC, the interim meeting in Boston and
> > > have been following the rmonmib WG mailing list and reading
> > > through their various dratfs.  It is my current
> > > understanding that the rmonmib working group is
> > > focusing on defining monitors that sit passively on the wire.
> > > Is this your understanding?
> > >
> > > What I am interested in seeing discussed is a capability
> > > to remotely generate the performance management traffic
> > > from a remote device to another remote device (like the
> > > Remote ping MIB allows one to generate a ping or set of pings
> > > from a remote device to another remote device).
> > >
> > > In fact, it was Andy that turned me onto the activities of the
> > > disman WG.
> > >
> > > Regarding the notion of seeing if the author(s) of the enterprise
> > > MIBs are interested in bringing them forward as a draft, I think
> > > that is an excellent idea (and I'll talk with them).
> > >
> > > Thanks,
> > > Bob
> > > > -----Original Message-----
> > > > From:     Dan Romascanu [SMTP:[email-masked]]
> > > > Sent:     Thursday, March 09, 2000 10:16 AM
> > > > To:       Cole, Robert G (Bob), ALSVC; disman-wg-ietf
> > > > Cc:       [email-masked]'
> > > > Subject:  RE: Remote Performance Management
> > > >
> > > >
> > > > Bob,
> > > >
> > > > There is a DiffServ Monitoring MIB - extension to the RMON MIB. The
> > > > document
> > > > is draft-bierman-dsmon-mib-02.txt, authored by Andy Bierman.
> > It recently
> > > > became an official work item in the rmonmib WG, part of the
> > new Charter
> > > of
> > > > this WG. If you know any enterprise MIBs that are relevant to this
> > > > subject,
> > > > I would suggest that you encourage their authors to bring them to the
> > > > attention of the RMON MIB WG. The discussion list of this group is
> > > > [email-masked].
> > > >
> > > > Regards,
> > > >
> > > > Dan
> > > >
> > > >
> > > >
> > > > > -----Original Message-----
> > > > > From:   Cole, Robert G (Bob), ALSVC [SMTP:[email-masked]]
> > > > > Sent:   Thu March 09 2000 16:27
> > > > > To:     disman-wg-ietf
> > > > > Subject:        Remote Performance Management
> > > > >
> > > > >
> > > > > To all,
> > > > >
> > > > > I am curious if the WG is/has/or will
> > > > > discuss remote performance management
> > > > > capabilities?
> > > > >
> > > > > I did a random sampling of the WG's archives
> > > > > and did not find any discussions around this
> > > > > topic.  It is also not explicitly discussed in
> > > > > your charter (or any other WG's charter that I
> > > > > have looked through).
> > > > >
> > > > > I have been working with some enterprise MIBs
> > > > > in this area and have found them extremely
> > > > > useful in our work.  I would think that this WG is
> > > > > in a good position to extend the work it has
> > > > > performed so far on the Remote ping MIB and the
> > > > > Scheduling of Managed Objects MIB into this area.
> > > > > This would be an opportunity to leverage the work of
> > > > > the IPPM WG and some of the recent application
> > > > > monitoring activities of the RMON WG, into a
> > > > > general tool for providing remote performance
> > > > > monitoring capabilities.
> > > > >
> > > > > Thanks,
> > > > > Bob
> > > > >
> > > > > _____________
> > > > > Robert G. Cole
> > > > > AT&T Labs, Network Design and Performance Analysis Dept.
> > > > > Tel: (410) 939-8732     FAX: (410) 939-8732
> > > > > Pager: (888) 858-PAGE, pin 127113
> > > > > email: [email-masked]   URL: http://chapman.mt.att.com/
> > > > >
> > > > > 330 Saint Johns St., 2nd Floor
> > > > > Havre de Grace, MD  21078
> > > > >                 USA
> > > > >
> > > > >

---

From: Steve Waldbusser <[email-masked]>
Date: Tue, 14 Mar 2000 16:08:45 -0800

Andy Bierman wrote:

> is out of scope.

Just to be clear, configuration of passive tests is also out of scope.

Regarding doing active tests in RMON, some exist in the Token Ring RMON MIB already. Many vendors who implement RMON also perform active tests as part of that implementation - this is why we've attempted (unsucessfully) to standardize that in the past. And we've agreed that the current APM charter will support APM measurements from active sources.

I think we could revisit more active testing in the future, sometime after we are done with our existing charter.

BTW, my memory of why the ping stuff failed in the RMON group has more to do with it being the "stepchild" of the RMON2 work we were doing at the time. It just didn't get much attention because there was much more interesting work to do.

Steve