Subject: Remote Performance Management

From: "Cole, Robert G (Bob), ALSVC" <[email-masked]>
Date: Thu, 9 Mar 2000 09:27:03 -0500

To all,

I am curious if the WG is/has/or will
discuss remote performance management 
capabilities?  

I did a random sampling of the WG's archives
and did not find any discussions around this 
topic.  It is also not explicitly discussed in
your charter (or any other WG's charter that I
have looked through).

I have been working with some enterprise MIBs
in this area and have found them extremely
useful in our work.  I would think that this WG is
in a good position to extend the work it has
performed so far on the Remote ping MIB and the
Scheduling of Managed Objects MIB into this area.
This would be an opportunity to leverage the work of
the IPPM WG and some of the recent application
monitoring activities of the RMON WG, into a
general tool for providing remote performance
monitoring capabilities.

Thanks,
Bob

_____________
Robert G. Cole
AT&T Labs, Network Design and Performance Analysis Dept.
Tel: (410) 939-8732 	FAX: (410) 939-8732 
Pager: (888) 858-PAGE, pin 127113
email: [email-masked]	URL: http://chapman.mt.att.com/

330 Saint Johns St., 2nd Floor
Havre de Grace, MD  21078
		USA

---

From: Dan Romascanu <[email-masked]>
Date: Thu, 9 Mar 2000 17:16:22 +0200

Bob,

There is a DiffServ Monitoring MIB - extension to the RMON MIB. The document
is draft-bierman-dsmon-mib-02.txt, authored by Andy Bierman. It recently
became an official work item in the rmonmib WG, part of the new Charter of
this WG. If you know any enterprise MIBs that are relevant to this subject,
I would suggest that you encourage their authors to bring them to the
attention of the RMON MIB WG. The discussion list of this group is
[email-masked].

Regards,

Dan

> -----Original Message-----
> From:	Cole, Robert G (Bob), ALSVC [SMTP:[email-masked]]
> Sent:	Thu March 09 2000 16:27
> To:	disman-wg-ietf
> Subject:	Remote Performance Management
> 
> 
> To all,
>

---

From: "Cole, Robert G (Bob), ALSVC" <[email-masked]>
Date: Thu, 9 Mar 2000 13:28:38 -0500

Dan,

Thanks for the note.  I have looked at the dsmon-mib
that Andy posted.  As well, I attended the last rmonmib WG
meeting in DC, the interim meeting in Boston and
have been following the rmonmib WG mailing list and reading
through their various dratfs.  It is my current
understanding that the rmonmib working group is
focusing on defining monitors that sit passively on the wire.
Is this your understanding?

What I am interested in seeing discussed is a capability
to remotely generate the performance management traffic
from a remote device to another remote device (like the
Remote ping MIB allows one to generate a ping or set of pings
from a remote device to another remote device).  

In fact, it was Andy that turned me onto the activities of the
disman WG.

Regarding the notion of seeing if the author(s) of the enterprise
MIBs are interested in bringing them forward as a draft, I think
that is an excellent idea (and I'll talk with them).

Thanks,
Bob
> From:	Dan Romascanu [SMTP:[email-masked]]
> Sent:	Thursday, March 09, 2000 10:16 AM
> To:	Cole, Robert G (Bob), ALSVC; disman-wg-ietf
> Cc:	[email-masked]'
> Subject:	RE: Remote Performance Management
> 
> 
> Bob,
>

---

From: Randy Presuhn <[email-masked]>
Date: Sun, 12 Mar 2000 21:05:48 -0800 (PST)

Hi -

A post from a non-subscriber address, forwarded to the disman list.
I've added this address to the disman "posters" list.

 ------------------------------------------------------------------------
 Randy Presuhn           [email-masked]       http://www.bmc.com/
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141  2141 N. First Street
 Fax:   +1 408 965-0359  San Jose, California 95131  USA
 ------------------------------------------------------------------------
 Any relationship between my opinions and BMC's should be coincidental.
 ------------------------------------------------------------------------

> Received: from tangelo.bmc.com (root@tangelo [172.17.7.166])
> 	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id SAA23248
> 	for <[email-masked]>; Sun, 12 Mar 2000 18:51:33 -0800 (PST)
> Received: from fw-us-hou1.bmc.com (fw-us-hou1.bmc.com [172.17.0.250])
> 	by tangelo.bmc.com (8.8.6 (PHNE_17135)/8.8.6) with SMTP id UAA22687
> 	for <[email-masked]>; Sun, 12 Mar 2000 20:52:09 -0600 (CST)
> Received: from us-exch2-210.apptitude.com (us-exch2-210.apptitude.com [192.190.175.202])
> 	by natadm.apptitude.com (8.9.3/8.9.3) with ESMTP id SAA06497;
> 	Sun, 12 Mar 2000 18:52:06 -0800
> Received: by us-exch2-210.apptitude.com with Internet Mail Service (5.5.2448.0)
> 	id <T7SLC3W5>; Sun, 12 Mar 2000 18:51:35 -0800
> Message-ID: <[email-masked]>
> From: Russell Dietz <[email-masked]>
> To: "'rmonmib-wg-ietf'" <[email-masked]>
> Cc: disman-wg-ietf <[email-masked]>
> Date: Sun, 12 Mar 2000 18:51:34 -0800
> MIME-Version: 1.0
> X-Mailer: Internet Mail Service (5.5.2448.0)
> Content-Type: multipart/alternative;
> 	boundary="----_=_NextPart_001_01BF8C97.0B6281FE"
> 
> This message is in MIME format. Since your mail reader does not understand
> this format, some or all of this message may not be legible.
> 
> ------_=_NextPart_001_01BF8C97.0B6281FE
> Content-Type: text/plain;
> 	charset="iso-8859-8"
> 
> Hello Folks!
> 
> I believe that it has been clear that many people are interested in both the
> passive monitoring and active performance testing.  I feel that our charter
> must address both of these areas.  However, active testing is a major
> configuration issue, if we all don't agree on some way to eliminate some of
> the typically configurable features of active agents.
> 
> I feel that we should have a specific discussion in Adelaide on this area.
> Would any of the individuals that are interested care to make a 15 minute
> presentation on the requirements?  Please let the chair know ASAP!
> 
> See you all down under...
> 
> Russ
> 
> From: Carl W. Kalbfleisch [mailto:[email-masked]]
> Sent: Sunday, March 12, 2000 1:07 PM
> To: Dan Romascanu; 'Cole, Robert G (Bob), ALSVC'; disman-wg-ietf
> Cc: [email-masked]
> I indicated an interest in such work privately to Bob. I will mention on the
> list that I am interested so that the WG chair has a feeling that there are
> additional people interested in defining such things.
> 
> Carl
> 
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Dan Romascanu
> > Sent: Sunday, March 12, 2000 9:13 AM
> > To: 'Cole, Robert G (Bob), ALSVC'; disman-wg-ietf
> > Cc: [email-masked]'
> > Thanks, I understand now better what you are after. I agree that the place
> > to raise the issue might be DISMAN. In fact, the set of tools
> > that a network
> > manager would use for remote monitoring and managing his domain would be a
> > combination of 'passive' and 'active' tools. Some of the probes
> > and devices
> > in the network might also have the capability to perform in both
> > paradigms.
> > I would like to see some architectural correlation between the
> > two methods -
> > this may be a subject of an Informational RFC.
> >
> > As a historical note, 'Ping MIB' was once in the past on the RMON MIB WG
> > table, but it was taken out because the RMON group decided to deal
> > exclusively with the 'passive' approach. It landed eventually in the
> > remops-disman work.
> >
> > I am not sure about the status of the future work in DISMAN. If I am not
> > mistaken, the WG does not meet in Adelaide. I would be interested to
> > contribute to such a work, if it starts to be developed.
> >
> > Regards,
> >
> > Dan
> >
> >
> >
> >
> > > Sent:	Thu March 09 2000 20:29
> > > To:	Dan Romascanu; disman-wg-ietf
> > > Cc:	[email-masked]'
> > > > became an official work item in the rmonmib WG, part of the
> > new Charter
> > > of
> ------_=_NextPart_001_01BF8C97.0B6281FE
> Content-Type: text/html;
> 	charset="iso-8859-8"
> Content-Transfer-Encoding: quoted-printable
> 
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
> <HTML>
> <HEAD>
> <META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
> charset=3Diso-8859-8">
> <META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
> 5.5.2448.0">
> <TITLE>RE: Remote Performance Management</TITLE>
> </HEAD>
> <BODY>
> 
> <P><FONT SIZE=3D2>Hello Folks!</FONT>
> </P>
> 
> <P><FONT SIZE=3D2>I believe that it has been clear that many people are =
> interested in both the passive monitoring and active performance =
> testing.&nbsp; I feel that our charter must address both of these =
> areas.&nbsp; However, active testing is a major configuration issue, if =
> we all don't agree on some way to eliminate some of the typically =
> configurable features of active agents.</FONT></P>
> 
> <P><FONT SIZE=3D2>I feel that we should have a specific discussion in =
> Adelaide on this area.&nbsp; Would any of the individuals that are =
> interested care to make a 15 minute presentation on the =
> requirements?&nbsp; Please let the chair know ASAP!</FONT></P>
> 
> <P><FONT SIZE=3D2>See you all down under...</FONT>
> </P>
> 
> <P><FONT SIZE=3D2>Russ</FONT>
> </P>
> 
> <P><FONT SIZE=3D2>-----Original Message-----</FONT>
> <BR><FONT SIZE=3D2>From: Carl W. Kalbfleisch [<A =
> HREF=3D"mailto:[email-masked]">mailto:[email-masked]</A>]</FONT>
> <BR><FONT SIZE=3D2>Sent: Sunday, March 12, 2000 1:07 PM</FONT>
> <BR><FONT SIZE=3D2>To: Dan Romascanu; 'Cole, Robert G (Bob), ALSVC'; =
> disman-wg-ietf</FONT>
> <BR><FONT SIZE=3D2>Cc: [email-masked]</FONT>
> <BR><FONT SIZE=3D2>Subject: RE: Remote Performance Management</FONT>
> </P>
> <BR>
> <BR>
> <BR>
> 
> <P><FONT SIZE=3D2>I indicated an interest in such work privately to =
> Bob. I will mention on the</FONT>
> <BR><FONT SIZE=3D2>list that I am interested so that the WG chair has a =
> feeling that there are</FONT>
> <BR><FONT SIZE=3D2>additional people interested in defining such =
> things.</FONT>
> </P>
> 
> <P><FONT SIZE=3D2>Carl</FONT>
> </P>
> 
> <P><FONT SIZE=3D2>&gt; -----Original Message-----</FONT>
> <BR><FONT SIZE=3D2>&gt; From: [email-masked]</FONT>
> <BR><FONT SIZE=3D2>&gt; [<A =
> HREF=3D"mailto:[email-masked]">mailto:owner-disman@doroth=
> y.peer.com</A>]On Behalf Of Dan Romascanu</FONT>
> <BR><FONT SIZE=3D2>&gt; Sent: Sunday, March 12, 2000 9:13 AM</FONT>
> <BR><FONT SIZE=3D2>&gt; To: 'Cole, Robert G (Bob), ALSVC'; =
> disman-wg-ietf</FONT>
> <BR><FONT SIZE=3D2>&gt; Cc: [email-masked]'</FONT>
> <BR><FONT SIZE=3D2>&gt; Subject: RE: Remote Performance =
> Management</FONT>
> <BR><FONT SIZE=3D2>&gt;</FONT>
> <BR><FONT SIZE=3D2>&gt;</FONT>
> <BR><FONT SIZE=3D2>&gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; Bob,</FONT>
> <BR><FONT SIZE=3D2>&gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; Thanks, I understand now better what you are =
> after. I agree that the place</FONT>
> <BR><FONT SIZE=3D2>&gt; to raise the issue might be DISMAN. In fact, =
> the set of tools</FONT>
> <BR><FONT SIZE=3D2>&gt; that a network</FONT>
> <BR><FONT SIZE=3D2>&gt; manager would use for remote monitoring and =
> managing his domain would be a</FONT>
> <BR><FONT SIZE=3D2>&gt; combination of 'passive' and 'active' tools. =
> Some of the probes</FONT>
> <BR><FONT SIZE=3D2>&gt; and devices</FONT>
> <BR><FONT SIZE=3D2>&gt; in the network might also have the capability =
> to perform in both</FONT>
> <BR><FONT SIZE=3D2>&gt; paradigms.</FONT>
> <BR><FONT SIZE=3D2>&gt; I would like to see some architectural =
> correlation between the</FONT>
> <BR><FONT SIZE=3D2>&gt; two methods -</FONT>
> <BR><FONT SIZE=3D2>&gt; this may be a subject of an Informational =
> RFC.</FONT>
> <BR><FONT SIZE=3D2>&gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; As a historical note, 'Ping MIB' was once in =
> the past on the RMON MIB WG</FONT>
> <BR><FONT SIZE=3D2>&gt; table, but it was taken out because the RMON =
> group decided to deal</FONT>
> <BR><FONT SIZE=3D2>&gt; exclusively with the 'passive' approach. It =
> landed eventually in the</FONT>
> <BR><FONT SIZE=3D2>&gt; remops-disman work.</FONT>
> <BR><FONT SIZE=3D2>&gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; I am not sure about the status of the future =
> work in DISMAN. If I am not</FONT>
> <BR><FONT SIZE=3D2>&gt; mistaken, the WG does not meet in Adelaide. I =
> would be interested to</FONT>
> <BR><FONT SIZE=3D2>&gt; contribute to such a work, if it starts to be =
> developed.</FONT>
> <BR><FONT SIZE=3D2>&gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; Regards,</FONT>
> <BR><FONT SIZE=3D2>&gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; Dan</FONT>
> <BR><FONT SIZE=3D2>&gt;</FONT>
> <BR><FONT SIZE=3D2>&gt;</FONT>
> <BR><FONT SIZE=3D2>&gt;</FONT>
> <BR><FONT SIZE=3D2>&gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; -----Original Message-----</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; From:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
> Cole, Robert G (Bob), ALSVC [SMTP:[email-masked]]</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Sent:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
> Thu March 09 2000 20:29</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; To: Dan Romascanu; disman-wg-ietf</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Cc: [email-masked]'</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Subject:&nbsp;&nbsp;&nbsp; RE: Remote =
> Performance Management</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Dan,</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Thanks for the note.&nbsp; I have looked =
> at the dsmon-mib</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; that Andy posted.&nbsp; As well, I =
> attended the last rmonmib WG</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; meeting in DC, the interim meeting in =
> Boston and</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; have been following the rmonmib WG mailing =
> list and reading</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; through their various dratfs.&nbsp; It is =
> my current</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; understanding that the rmonmib working =
> group is</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; focusing on defining monitors that sit =
> passively on the wire.</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Is this your understanding?</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; What I am interested in seeing discussed =
> is a capability</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; to remotely generate the performance =
> management traffic</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; from a remote device to another remote =
> device (like the</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Remote ping MIB allows one to generate a =
> ping or set of pings</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; from a remote device to another remote =
> device).</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; In fact, it was Andy that turned me onto =
> the activities of the</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; disman WG.</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Regarding the notion of seeing if the =
> author(s) of the enterprise</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; MIBs are interested in bringing them =
> forward as a draft, I think</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; that is an excellent idea (and I'll talk =
> with them).</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Thanks,</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Bob</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; -----Original Message-----</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; From:&nbsp;&nbsp;&nbsp;&nbsp; Dan =
> Romascanu [SMTP:[email-masked]]</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; Sent:&nbsp;&nbsp;&nbsp;&nbsp; =
> Thursday, March 09, 2000 10:16 AM</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; =
> To:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Cole, Robert G (Bob), ALSVC; =
> disman-wg-ietf</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; =
> Cc:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; [email-masked]'</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; Subject:&nbsp; RE: Remote Performance =
> Management</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; Bob,</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; There is a DiffServ Monitoring MIB - =
> extension to the RMON MIB. The</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; document</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; is draft-bierman-dsmon-mib-02.txt, =
> authored by Andy Bierman.</FONT>
> <BR><FONT SIZE=3D2>&gt; It recently</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; became an official work item in the =
> rmonmib WG, part of the</FONT>
> <BR><FONT SIZE=3D2>&gt; new Charter</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; of</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; this WG. If you know any enterprise =
> MIBs that are relevant to this</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; subject,</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; I would suggest that you encourage =
> their authors to bring them to the</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; attention of the RMON MIB WG. The =
> discussion list of this group is</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; [email-masked].</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; Regards,</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; Dan</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; -----Original =
> Message-----</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; From:&nbsp;&nbsp; Cole, Robert G =
> (Bob), ALSVC [SMTP:[email-masked]]</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; Sent:&nbsp;&nbsp; Thu March 09 =
> 2000 16:27</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; To:&nbsp;&nbsp;&nbsp;&nbsp; =
> disman-wg-ietf</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; =
> Subject:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Remote Performance =
> Management</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; To all,</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; I am curious if the WG is/has/or =
> will</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; discuss remote performance =
> management</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; capabilities?</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; I did a random sampling of the =
> WG's archives</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; and did not find any discussions =
> around this</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; topic.&nbsp; It is also not =
> explicitly discussed in</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; your charter (or any other WG's =
> charter that I</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; have looked through).</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; I have been working with some =
> enterprise MIBs</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; in this area and have found them =
> extremely</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; useful in our work.&nbsp; I =
> would think that this WG is</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; in a good position to extend the =
> work it has</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; performed so far on the Remote =
> ping MIB and the</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; Scheduling of Managed Objects =
> MIB into this area.</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; This would be an opportunity to =
> leverage the work of</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; the IPPM WG and some of the =
> recent application</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; monitoring activities of the =
> RMON WG, into a</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; general tool for providing =
> remote performance</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; monitoring capabilities.</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; Thanks,</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; Bob</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; _____________</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; Robert G. Cole</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; AT&amp;T Labs, Network Design =
> and Performance Analysis Dept.</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; Tel: (410) 939-8732 =
> &nbsp;&nbsp;&nbsp; FAX: (410) 939-8732</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; Pager: (888) 858-PAGE, pin =
> 127113</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; email: =
> [email-masked]&nbsp;&nbsp; URL: <A HREF=3D"http://chapman.mt.att.com/" =
> TARGET=3D"_blank">http://chapman.mt.att.com/</A></FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; 330 Saint Johns St., 2nd =
> Floor</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; Havre de Grace, MD&nbsp; =
> 21078</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt; =
> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; USA</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt;</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; &gt;</FONT>
> </P>
> 
> </BODY>
> </HTML>
> ------_=_NextPart_001_01BF8C97.0B6281FE--
>

---

From: Dan Romascanu <[email-masked]>
Date: Mon, 13 Mar 2000 09:00:16 +0200

> > See you all down under...
	[Dan]  I can try to prepare something. As Bob said that he worked
with MIBs from some vendors, I would welcome his - or anybody's -
contributions. 

	BTW, I think that Russ means this issue to be raised in the RMON WG,
as neither DISMAN, nor the OAM Area meet in Adelaide. This is OK as a
framework for the discussion (if Andy as a WG chair agrees to host it), but
it does not mean that we should do work in RMON related to 'active agents'.
I am against touching the RMON WG Charter - certainly not now, when we just
agreed on the scope of work and started to work at it.

	Regards,

	Dan

---

From: Russell Dietz <[email-masked]>
Date: Sun, 12 Mar 2000 23:15:21 -0800

Hello Dan and others,

That's correct!  I believe that the RMON WG can, at least, talk about the
issue of standardizing active performance systems.  I am not sure if the
'product' of our discussion is an RMON WG item or should find some other
home.  Let's at least see if we have time to have the discussion and if we
can put a 'frame' around the actual needs.

Sounds good?

Russ

-----Original Message-----
From: Dan Romascanu [mailto:[email-masked]]
Sent: Sunday, March 12, 2000 11:00 PM
To: 'Randy Presuhn'; [email-masked]; [email-masked]'
Subject: RE: RE: Remote Performance Management

	Regards,

	Dan

---

From: "Cole, Robert G (Bob), ALSVC" <[email-masked]>
Date: Mon, 13 Mar 2000 10:17:51 -0500

Dan,
Carl,

I guess there are several issues to tackle here.

1) The current disman charter does not specifically address remote
performance management.  We need to have Randy and the WG agree
to modify the charter to support this activity.  Maybe Randy and the
WG can shed some light on its future activities.

2) Dan suggested a draft discussing the architectural correlation between
the
use/interaction of passive and active tools in this area.  I think this
would be a 
good first start.  I would add that this might be a good place to better
describe
the active approach to peformance management and its requirements.  If you
both agree ( and item 1 is covered), I could draft up an outline and send
it to you both and we can start fleshing out a draft.

3) Dan had earlier suggested approaching the enterprise MIB vendor
to try to get them to bring forward their work.  I have had some discussion
with them.  It it too early to know their intentions.  But they do have a
very
extensive MIB in this area.

What do you all think?

Bob

-----------------------------------------------------------------
	(Dan Romascanu wrote:)
> to raise the issue might be DISMAN. In fact, the set of tools that a
> network
> combination of 'passive' and 'active' tools. Some of the probes and
> devices
> I would like to see some architectural correlation between the two methods
> -
> > > became an official work item in the rmonmib WG, part of the new
> Charter
> > of

---

From: Randy Presuhn <[email-masked]>
Date: Mon, 13 Mar 2000 15:05:38 -0800 (PST)

Hi -

> Message-ID: <[email-masked]>
> From: "Cole, Robert G (Bob), ALSVC" <[email-masked]>
> To: Dan Romascanu <[email-masked]>,
>         disman-wg-ietf
> 	 <[email-masked]>,
>         "Carl W. Kalbfleisch" <[email-masked]>
> Cc: "[email-masked]'" <[email-masked]>
> Date: Mon, 13 Mar 2000 10:17:51 -0500
...
> WG can shed some light on its future activities.
...

Whether the work happens in disman or somewhere else depends
on the level of interest within the working group, whether
any other working groups want to tackle the problem, and
whether our A-D thinks this would be an appropriate venue.

The disman WG is at the point where we need to decide whether
to go dormant, freeing up resources for other WGs, or to take
on new work items.

I personally find this an interesting topic, but would be happy
with it having a home in any of the following, in order of
preference:

    1) a new WG dedicated to this topic, especially if identification
       of specific metrics and statistics might be relevant

    2) disman (if we focus on infrastructure to perform distributed
       monitoring)

    3) applmib (if the focus is on application performance, rather
       than more generic possibilities)

    4) RMON

I'm keeping an open mind, and have no problem with this discussion
continuing on the disman list.

---

From: Dan Romascanu <[email-masked]>
Date: Tue, 14 Mar 2000 09:09:33 +0200

[Dan]  Bob,

> it to you both and we can start fleshing out a draft.
	[Dan]  This option is fine with me, and would be glad to work with
you on this. Randy volunteered the DISMAN list for continuing to host this
discussion. IMO, the separation of the monitoring methods into 'passive' and
'active' and the subsequent distribution of work in different WGs is somehow
artificial. However, I understand the problem of the limited contributor
resources in this area. That is why dealing first with an architecture
document describing the problem, requirements, differences and benefits of
the two approaches might be the right thing to do at this stage. 

	Regards, 

	Dan

---

From: "Cole, Robert G (Bob), ALSVC" <[email-masked]>
Date: Wed, 15 Mar 2000 10:39:47 -0500

Randy,

I have not yet looked at the applmib yet (but will do so right away), so
I cannot comment on that option. However, I do believe that the discussion
of this topic (if it is to proceed) should include a discussion of the 
infrastructure to perform distributed monitoring as well as specific
metrics and statistics.  Regarding the later point, I envision
relying heavily on the work from the IPPM WG in this
area.  In fact, as a first pass, I'd be happy with focusing
on the metrics and statistics of the IPPM WG solely, leaving
higher layer 'application monitoring' to later.

Thanks,
Bob

---

From: Russell Dietz <[email-masked]>
Date: Wed, 15 Mar 2000 12:13:02 -0800

Hello Folks,

Given the level of interest, we should all try to get together off-line in
Adelaide and discuss next steps?  Let me know!

Regards,

Russ

-----Original Message-----
From: Carl W. Kalbfleisch [mailto:[email-masked]]
Sent: Wednesday, March 15, 2000 10:14 AM
To: Cole, Robert G (Bob), ALSVC; Dan Romascanu; Dan Romascanu;
disman-wg-ietf
Cc: [email-masked]

Bob,

Sounds good to me. Are you going to IETF? If so we could discuss this in
person there.

Carl

> [mailto:[email-masked]]On Behalf Of Cole, Robert G (Bob),
> ALSVC
> Sent: Wednesday, March 15, 2000 9:40 AM
> To: Dan Romascanu; Dan Romascanu; disman-wg-ietf; Carl W. Kalbfleisch
> Cc: [email-masked]'
> Given the discussion over the last couple of days and the number of
> different WGs mentioned, I strongly agree with you that an architectural
> level discussion/draft is merited.  If it is OK with you and Carl, give me
> a week and I'll send you both a rough draft/outline and we can start
> fleshing it out.  I first want to spend a couple of days reading up
> on the applmib work, on the script MIB, and the IPPM rfcs and drafts
> (and anything else you think appropriate).
>
> Thanks,
> Bob
>
> > Sent:	Tuesday, March 14, 2000 2:10 AM
> > To:	Cole, Robert G (Bob), ALSVC; Dan Romascanu; disman-wg-ietf; Carl W.
> > Kalbfleisch
> > Cc:	[email-masked]'

---

From: [email-masked]
Date: Wed, 15 Mar 2000 15:06:00 -0500

Hi. I think it has been clear that active/synthetic monitoring is being
considered by RMON APM. Note from Andy's minutes on the 13th in the section
titled Configuring Agent Capabilities, the "group decided"

 " The APM standard should support client based, probe based,
    active and synthetic traffic monitoring, and even non-network
    based mechanisms."

I am assumming that active and synthetic are fairly synonomous and the
probe and passive are intended to be synonomous. I guess I'm no longer so
clear on what that means. It is clear that active has configuration issues
and maybe it's not clear that configuration is an area that the RMON APM WG
needs to address. Still it does seem to leave a hole for supporting active.

I would rather seem us work towards full solutions if only by referencing
where to go for the rest, assumming the rest exists, is complete and is
compatible.

[email-masked] on 03/13/2000 12:05:48 AM

To:   [email-masked]
cc:    (bcc: Bob Massad/NetScout)
Subject:  Fwd: RE: Remote Performance Management

Hi -

> Message-ID:
<[email-masked]>

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 15 Mar 2000 14:26:33 -0600

hi
 
I'd be interested in at least lurking during this discussion.  Is it too
late for someone to
set up a BOF?
 
Sharon

-----Original Message-----
From: Russell Dietz [mailto:[email-masked]]
Sent: Wednesday, March 15, 2000 3:13 PM
To: 'Carl W. Kalbfleisch'; Cole, Robert G (Bob), ALSVC; Dan Romascanu;
disman-wg-ietf
Cc: [email-masked]

Hello Folks, 

Regards, 

Russ 

-----Original Message----- 
From: Carl W. Kalbfleisch [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Wednesday, March 15, 2000 10:14 AM 
To: Cole, Robert G (Bob), ALSVC; Dan Romascanu; Dan Romascanu; 
disman-wg-ietf 
Cc: [email-masked] 

Bob, 

Carl 

> [ mailto:[email-masked]
<mailto:[email-masked]> ]On Behalf Of Cole, Robert G (Bob), 

> > > the active approach to peformance management and its requirements.  If

> > you 
> > discussion. IMO, the separation of the monitoring methods into 'passive'

> > and

---

From: "Cole, Robert G (Bob), ALSVC" <[email-masked]>
Date: Wed, 15 Mar 2000 15:35:51 -0500

Yea, it sounds good, but unfortunately I will not be in Adelaide.  You guys
will
have to fill me in later.  In the mean time, I'll work up my thoughts on an
outline and send it to you prior to Adelaide.

Thanks,
Bob

> From:	Russell Dietz [SMTP:[email-masked]]
> From: Carl W. Kalbfleisch [ <mailto:[email-masked]>] 
> > [ <mailto:[email-masked]>]On Behalf Of Cole, Robert G
> (Bob), 
> > ALSVC 
> > > > both agree ( and item 1 is covered), I could draft up an outline and
> 
> > > send

---

From: [email-masked]
Date: Wed, 15 Mar 2000 15:36:46 -0500

Sorry for the lack of qualification. The minutes were from the Jan 10/11,
'00  interim RMON WG meeting held boston to discuss APM.

Bob Massad
03/15/2000 03:06 PM

To:   [email-masked], [email-masked]
cc:    (bcc: Bob Massad/NetScout)
Subject:  Re: Fwd: RE: Remote Performance Management

Hi -