Subject: Re: closing Script MIB issues

From: Randy Presuhn <[email-masked]>
Date: Mon, 3 Apr 2000 23:49:10 -0700 (PDT)

Hi -

> Date: Mon, 3 Apr 2000 15:57:40 +0200
> Message-Id: <[email-masked]>
> From: Juergen Schoenwaelder <[email-masked]>
> To: [email-masked]
> CC: [email-masked]
> In-reply-to: <[email-masked]> (message from Randy
> 	Presuhn on Thu, 30 Mar 2000 17:11:57 -0800 (PST))
> Subject: Re: closing Script MIB issues
> References:  <[email-masked]>
...
(Juergen's proposed issue resolutions deleted)
...
>    10: Any changes needed for editing in the SNMP code table? (Juergen)
> 
> There have been a few comments on the smCodeTable and its flexibility
> regarding the numbering scheme and so on. Do we want to keep it the
> way it is defined? Many implementations so far do not support it and
> we may get problems with it anyway once we want to advance to Draft
> standard.
...

Let's get it right first, and then decide whether it's appropriate
to advance.  Advancement will only be used as a "tie-breaker" between
otherwise equally good solutions.

 ------------------------------------------------------------------------
 Randy Presuhn           [email-masked]       http://www.bmc.com/
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141  2141 N. First Street
 Fax:   +1 408 965-0359  San Jose, California 95131  USA
 ------------------------------------------------------------------------
 Any relationship between my opinions and BMC's should be coincidental.
 ------------------------------------------------------------------------

---

From: Randy Presuhn <[email-masked]>
Date: Wed, 5 Apr 2000 10:22:13 -0700 (PDT)

Hi -

> From: Alan Luchuk <[email-masked]>
> Date: Wed, 5 Apr 2000 12:33:53 -0400 (EDT)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Subject: Re:  Closing Script MIB issues
> Cc: [email-masked]
> List-Id: IETF disman Working Group mailing list <[email-masked]>
...
> >Randy>    06: Dependencies between scripts and script versioning
> >Randy> (Eamonn)
> >
> >Randy>    07: Storage type of script code versus storage type of
> >Randy> script meta information
> 
> If possible, could someone (privately) refresh my memory about
> the meaning of these two terse descriptions or point me to a
> better description.
...

I agree that the descriptions are a bit terse.  Here's my
understanding of what the concerns are.

   Issue 06: Although the MIB has several objects to deal with the
             problem of language and language extension
             versions, there is nothing to explicitly identify
             the version of a script.  As the MIB currently
             stands, administration would have to resort to
             things like file naming conventions to represent
             this information.

             Furthermore, going a bit further down the path of
             configuration management issues, there is no explicit
             representation of interdependencies between scripts.

             Whether either of these is a hard requirement is
             open to debate.

   Issue 07: The value of smScriptStorageType is currently defined
             as controlling the persistence of BOTH the smScriptEntry
             and the script itself.  This seems reasonable in the
             case where the script is in smCodeTable, but is not
             what is intended if smScriptSource is an URL.  This
             is explained in a couple locations in the document,
             so I think no action is needed.

Please correct me if I've gotten these wrong.