Subject: Re: RFC 2982 on Distributed Management Expression MIB

From: Randy Presuhn <[email-masked]>
Date: Thu, 2 Nov 2000 11:55:42 -0800 (PST)

Hi -

...
> A new Request for Comments is now available in online RFC libraries.
> 
> 
>         RFC 2982
> 
>         Title:	    Distributed Management Expression MIB
>         Author(s):  R. Kavasseri (Editor of this version)
>                     B. Stewart (Author of previous version)
>         Status:     Standards Track
...

A big HOORAY for Ram and the entire WG for getting this finished!

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.
 -------------------------------------------------------

---

From: Frank Strauss <[email-masked]>
Date: 04 Nov 2000 11:09:49 +0100

An early issue for the next cycle ;-). Sorry, that I did not recognize
this earlier.

  expValueOctetStringVal OBJECT-TYPE
      SYNTAX      OCTET STRING (SIZE (0..65536))
      MAX-ACCESS  read-only
      STATUS      current
      DESCRIPTION
       "The value when expExpressionValueType is 'octetString'."
      ::= { expValueEntry 7 }

The size restriction violates SMIv2:

  7.1.2.  OCTET STRING
  
     The OCTET STRING type represents arbitrary binary or textual data.
     Although the SMI-specified size limitation for this type is 65535
     octets, MIB designers should realize that there may be implementation
     and interoperability limitations for sizes in excess of 255 octets.

The size restriction should be removed or the upper limit reduced by one.