Subject: RE: RFC 2982 on Distributed Management Expression MIB

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 5 Nov 2000 00:04:59 +0100

Sorry I meant: Ram will you take note.

Bert

> ----------
> From: 	Wijnen, Bert (Bert)[SMTP:[email-masked]]
> Sent: 	Saturday, November 04, 2000 12:04 PM
> To: 	[email-masked]; Frank Strauss
> Subject: 	RE: RFC 2982 on Distributed Management Expression MIB
> 
> 
> Probably best to just remove the SIZE all together.
> 
> Kam, will you take note?
> 
> Bert
> 
> > ----------
> > From: 	Frank Strauss[SMTP:[email-masked]]
> > Sent: 	Saturday, November 04, 2000 11:09 AM
> > To: 	[email-masked]
> > Subject: 	Re: RFC 2982 on Distributed Management Expression MIB
> > 
> > 
> > An early issue for the next cycle ;-). Sorry, that I did not recognize
> > this earlier.
> > 
> >   expValueOctetStringVal OBJECT-TYPE
> >       SYNTAX      OCTET STRING (SIZE (0..65536))
> >       MAX-ACCESS  read-only
> >       STATUS      current
> >       DESCRIPTION
> >        "The value when expExpressionValueType is 'octetString'."
> >       ::= { expValueEntry 7 }
> > 
> > The size restriction violates SMIv2:
> > 
> >   7.1.2.  OCTET STRING
> >   
> >      The OCTET STRING type represents arbitrary binary or textual data.
> >      Although the SMI-specified size limitation for this type is 65535
> >      octets, MIB designers should realize that there may be
> implementation
> >      and interoperability limitations for sizes in excess of 255 octets.
> > 
> > The size restriction should be removed or the upper limit reduced by
> one.
> > 
>

---

From: Ramanathan Kavasseri <[email-masked]>
Date: Fri, 17 Nov 2000 12:42:42 -0800

Noted. 

Ram