Subject: Re: Model-neutral & Model-specific Alarm Deliverables

From: Randy Presuhn <[email-masked]>
Date: Tue, 2 Jan 2001 14:38:12 -0800 (PST)

Hi -

> Date: Tue, 5 Dec 2000 21:57:38 +0100
> Message-Id: <[email-masked]>
> From: Juergen Schoenwaelder <[email-masked]>
> To: [email-masked]
> CC: [email-masked], [email-masked]
> In-reply-to: <[email-masked]>
> 	(message from Dan Romascanu on Tue, 5 Dec 2000 18:53:40 +0200)
> Subject: Re: Model-neutral & Model-specific Alarm Deliverables
> References:  <[email-masked]>
...
> >>>>> Dan Romascanu writes:
> 
> Dan> It's even simpler. The Alarm MIB is model neutral and will keep a
> Dan> pointer to the alarm model.
> 
> Hm. I guess I need to see the details before I can understand what
> this model neutral part is and what the alarm model part is.
> 
> Dan> We think that developing a generic alarm model is too big a task
> Dan> to be dealt with in one hop. We would like to use this scalable
> Dan> mechanism, and gather some experience with building a specific
> Dan> model that deals with the ITU alarms mapping.
> 
> I was not arguing for a generic alarm model. I was arguing for one
> which is just good enough to do what many folks have done before in
> private MIBs (and they are usually based on the ITU alarm model).
...

As a technical contributor, I see merit in both Dan's and
Juergen's lines of reasoning.

As WG chair, I'd like the WG to reach a consensus quickly
on the costs and benefits of the three alternatives:

    a) a single document, sufficient for ITU-style
       alarms.

    b) two documents.  A model-neutral MIB, and
       a companion MIB sufficient for ITU-style alarms.
       (Other mappings would be potential future work.)

    c) a generic alarm model.  (perhaps too ambitious)

Dan & Sharon - could you give us a back-of-the-envelope
estimate (if not an actual I-D :-) of approximately how
many tables and object definitions it would take for
each of the two documents in alternative (b)?

How far is <draft-chisholm-disman-active-alarm-01.txt> from
being (a)?  How far is it from (c)? 

I'd like the WG to reach agreement on this question before
I go on vacation on January 12.

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.
 -------------------------------------------------------

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 3 Jan 2001 15:40:02 -0500

hi

> -----Original Message-----
> From: Randy Presuhn [mailto:[email-masked]]
> Sent: Tuesday, January 02, 2001 5:38 PM
> To: [email-masked]
<clip>
> each of the two documents in alternative (b)?
Very rough estimates, not including conformance/compliance
and other overhead objects would be
	model-neutral: 3 tables; 29 objects
	ITU-model: 2 tables; 10 objects

> being (a)?  How far is it from (c)? 
I think we're slightly closer to (a) than we are to (b) but that
(c) is quite a bit of debate away.

I'm in the process of compiling a list of issues and work items to
transform my last draft into (b).  So far the MIB work seems feasible
in the timeframe proposed.  The description additions will likely
take a few iterations to get right though.
 
> I go on vacation on January 12.
I'm in favour of (b) with an option to do (c) at some later date.

Sharon