Subject: Fwd: RE: Proposed disman charter addition: alarm tracking

From: Randy Presuhn <[email-masked]>
Date: Thu, 4 Jan 2001 06:47:32 -0800 (PST)

Hi -

I'm forwarding a posting from Bob Natale.
I've added his new address to the disman "posters" list.

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.
 -------------------------------------------------------

> Received: from tattler.bmc.com (tattler.bmc.com [172.17.0.117])
> 	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id VAA29022
> 	for <[email-masked]>; Wed, 3 Jan 2001 21:25:28 -0800 (PST)
> From: [email-masked]
> Received: from fw-us-hou1.bmc.com (localhost [127.0.0.1])
> 	by tattler.bmc.com (8.10.2/8.10.2) with SMTP id f045OJD12968;
> 	Wed, 3 Jan 2001 23:24:19 -0600 (CST)
> Received: from 66-44-3-44.s806.apx1.lnh.md.dialup.rcn.com ([66.44.3.44] helo=bnatale.acecomm.com)
> 	by smtp01.mrf.mail.rcn.net with esmtp (Exim 3.16 #5)
> 	id 14E2us-0005Pa-00 ; Thu, 04 Jan 2001 00:26:23 -0500
> Message-Id: <[email-masked]>
> X-Sender: [email-masked]
> X-Mailer: QUALCOMM Windows Eudora Version 5.0.1
> Date: Thu, 04 Jan 2001 00:22:05 -0500
> To: "Ayers, Mike" <[email-masked]>
> Subject: RE: Proposed disman charter addition: alarm tracking
> Cc: [email-masked]
> In-Reply-To: <[email-masked]>
> Mime-Version: 1.0
> Content-Type: text/plain; charset="us-ascii"
> 
> At 1/2/2001:06:39 PM, Ayers, Mike wrote:
> 
> Hi MIke,
> 
> ><propose>
> >
> >        Alarms are not notifications.  Notifications are not alarms.  Alarms
> >represent persistent conditions.  Notifications indicate transient
> >conditions.
> 
> I've tried to follow the commentary re this proposed terminology,
> but did not follow closely the exchanges leading up to it.
> 
> In the general case, I cannot agree with the quoted four statements.
> Based on ample experience with OSS-grade fault management systems,
> I would say that:
> 
>    - Alarms are a type of notification (i.e., all alarms are also
>      notifications).
>    - Not all notifications are also alarms.
>    - Alarms may represent persistent or transient conditions or events.
>    - Notifications may represent persistent or transient conditions or events.
> 
> Essentially, an alarm represents a notification to which "the user" has
> assigned some special meaning (typically expressed as an a level of
> criticality or priority).
> 
> >The requirements for the raising and clearing of alarms are
> >specific to each alarm.
> 
> Possibly true.  Although groups or classes of alarms are common (in
> practice), in which all members of the class share some or all
> raise/clear requirements.
> 
> Of course, if we are engaged in an exercise of normative definition
> here, then we do not need to refer to the ways these terms (and
> a variety of synonyms) are used in practice.
> 
> Cordially,
> 
> BobN
> 
>

---

From: Joe Fernandez <[email-masked]>
Date: Fri, 05 Jan 2001 14:06:50 +1100

At 06:47 AM 04-01-01 -0800, Bob Natale wrote:
[......]

>> a variety of synonyms) are used in practice.

Bob, I will cordially disagree.

 "When I use a word, it means just what I choose it to mean-neither more
nor less" is great literature but bad standards engineering, IMHO.

 
Joe Fernandez
Kardinia Software
[email-masked]

http://www.kardinia.com

---

From: [email-masked]
Date: Fri, 05 Jan 2001 12:08:29 -0500

At 1/4/2001:10:06 PM, Joe Fernandez wrote:

Hi Joe,

>nor less" is great literature but bad standards engineering, IMHO.

Sorry, Joe, but standards engineering (mathematics is a good example)
often begins from a *normative* set of definitions -- where "normative"
means something like "take this as a given and we'll go forward from
here".  Regardless, you evidently missed the point of my posting(s)
which was to emphasize my preference for grounding our use of these
terms in actual practice, more along the lines of the follow-ups by
Dave and Dan in recent days.

Cordially,

BobN