Subject: BITS type implamentation

From: "Mauro Restante" <[email-masked]>
Date: Fri, 18 May 2001 13:11:29 +0200

Hi to all,

I'm facing with SNMP agent implementation and in this moment 

I need some information about the ASN.1 BITS type, better I need the 

implementation specification.

Someone has some idead where I can find it? Has someone any suggestion

for me?

Let me explain my perplexity: When I set a value (BITS type) in 

the agent, and,

after that, I set another bit in the same object, which value 

I could assume to retrieve with the next get request ?

Is it correct that the agent return me only the last value set?

Is it correct the behavior of the agent?

I use the Agent++ to implement the IETF disman schedule MIB.

many thanks in advance to all

Mauro Restante

_____________________________

CEFRIEL/Politecnico di Milano
Network System Area
Via fucini,2
20133 Milano - Italy
Tel. +39 02 23954248
Fax. +39 02 23954529

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 18 May 2001 15:53:57 -0700 (PDT)

Hi -

I'm forwarding a posting from Frank Fock.  This is now his
third alias in the disman "posters" list, but as far as I
can tell, he's not subscribed so you should probably include
him in your replies.

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.
 -------------------------------------------------------

|Received: from tattler.bmc.com (tattler.bmc.com [172.17.0.117])
|	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id OAA03023
|	for <[email-masked]>; Fri, 18 May 2001 14:51:29 -0700 (PDT)
|Received: from fw-us-hou-9.bmc.com (localhost [127.0.0.1])
|	by tattler.bmc.com (8.10.2/8.10.2) with SMTP id f4ILqKE20873
|	for <[email-masked]>; Fri, 18 May 2001 16:52:20 -0500 (CDT)
|Received: from mailout00.sul.t-online.com ([194.25.134.16]) by fw-us-hou-9.bmc.com; Fri, 18 May 2001 16:52:35 +0000 (CST)
|Received: from fwd06.sul.t-online.de 
|	by mailout00.sul.t-online.com with smtp 
|	id 150sAh-00066B-02; Fri, 18 May 2001 23:52:31 +0200
|Received: from fock.de (320061250925-0001@[217.81.141.82]) by fwd06.sul.t-online.com
|	with esmtp id 150sB7-2IJMI4C; Fri, 18 May 2001 23:52:57 +0200
|Message-ID: <[email-masked]>
|Date: Sat, 19 May 2001 00:02:40 +0200
|From: [email-masked] (Frank Fock)
|Organization: AGENT++
|X-Mailer: Mozilla 4.75 [en] (Windows NT 5.0; U)
|X-Accept-Language: en
|MIME-Version: 1.0
|To: Mauro Restante <[email-masked]>
|CC: "Agent++ (E-mail)" <[email-masked]>,
|        "IETF (E-mail)" <[email-masked]>
|Subject: Re: BITS type implamentation
|References: <[email-masked]>
|Content-Type: text/plain; charset=us-ascii
|Content-Transfer-Encoding: 7bit
|X-Sender: [email-masked]
|
|
|
|Mauro Restante wrote:
|
|>
|> I could assume to retrieve with the next get request ?
|>
|
|The last one set, because you will always have to set all
|bits. In order to toggle one bit you will have to (1) get
|the value of the object (2) toggle the bit and (3) set
|the whole OCTET STRING with a SET request.
|
|>
|> Is it correct that the agent return me only the last value set?
|>
|
|Yes.
|
|>
|
|Best regards,
|Frank
|
|