Subject: Notification Log Suggested Improvements

From: "Sharon Chisholm" <[email-masked]>
Date: Mon, 10 Dec 2001 10:39:04 -0500

hi

As I've mentioned before, we have experience with a cloned
version of the Notification Log MIB. This experience has 
led us to conclude that the MIB is basically sound, but 
would benefit from some additional objects and one point
of clarification.

Here's my email from last January where I outlined some
of these changes:

> 1. Add clarifying text as to whether inform resends are
>    added to the notification Log.
> 2. Add a variable to tell you what the current log index
>   is for each named log. (nlmCurrentLogIndex )
> 3. The logIndex can increase by more than one and 
>   can technically increase different amount between 
>   notifications. It would therefore be nice for the 
>   management station to either predict this behaviour 
>   or to find out what it has increased after the fact.
>   There could be a constantIncrement object, if applicable,
>   or a lastIncrement.

At the time I forgot the most important additional object 
required, which is a number in the nlmLogTable that tells
you how many variable bindings are stored in the nlmLogVariableTable.
This allows the log entry to be retrieved in fewer queries.

Sharon Chisholm
Preside Management
Nortel Networks
Ottawa, Ontario

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 28 Dec 2001 10:32:59 -0800 (PST)

Hi -

> Message-ID: <[email-masked]>
> From: "Sharon Chisholm" <[email-masked]>
> To: [email-masked]
> Subject: Notification Log Suggested Improvements
> Date: Mon, 10 Dec 2001 10:39:04 -0500
...
> >   There could be a constantIncrement object, if applicable,
...

I'm missing something here.  Why would it be "nice" to
have such an object?  A use case might make things clearer.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------