Subject: Re: RFC 2981 (disman event MIB) Implementation Experience

From: Randy Presuhn <[email-masked]>
Date: Sun, 2 Dec 2001 23:50:20 -0800 (PST)

Hi -

> Message-ID: <[email-masked]>
> Date: Sun, 02 Dec 2001 23:48:33 -0800
> From: Ramanathan Kavasseri <[email-masked]>
> To: Randy Presuhn <[email-masked]>
> Cc: [email-masked]
> Subject: Re: RFC 2981 (disman event MIB) Implementation Experience
> References: <[email-masked]>
...
> IMHO, it would be desirable to add StorageType
> objects to the core set of tables Randy mentioned above (mteTriggerTable,
> mteObjectsTable and mteEventTable).
> 
> Several of my company's customers have voiced strong interest in using these
> 
> MIBs to help manage their networks. However, till recently, we didn't
> persist the configuration of these MIBs across reboots,
> and that has prevented adoption of these MIBs by some of our customers.
...

Care to draft some object-type definitions?

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: Ramanathan Kavasseri <[email-masked]>
Date: Mon, 03 Dec 2001 00:16:12 -0800

> Care to draft some object-type definitions?

How about the following for starters?:

mteTriggerEntryStorageType OBJECT-TYPE
    SYNTAX       StorageType
    MAX-ACCESS   read-create
    STATUS       current
    DESCRIPTION "The storage type for this conceptual row.
                 Conceptual rows having the value 'permanent' need not
                 allow write-access to any columnar objects in the row,
                 except to modify the value of mteTriggerEnabled.
                "
    DEFVAL      { nonVolatile }
    ::= { mteTriggerEntry 16 }

mteObjectsEntryStorageType OBJECT-TYPE
    SYNTAX       StorageType
    MAX-ACCESS   read-create
    STATUS       current
    DESCRIPTION "The storage type for this conceptual row.
                 Conceptual rows having the value 'permanent' need not
                 allow write-access to any columnar objects in the row.
                "
    DEFVAL      { nonVolatile }
    ::= { mteObectsEntry 6 }

mteEventEntryStorageType OBJECT-TYPE
    SYNTAX       StorageType
    MAX-ACCESS   read-create
    STATUS       current
    DESCRIPTION "The storage type for this conceptual row.
                 Conceptual rows having the value 'permanent' need not
                 allow write-access to any columnar objects in the row,
                 except to modify the value of mteEventEnabled.
                "
    DEFVAL      { nonVolatile }
    ::= { mteEventEntry 6 }

Ram