Subject: RE: only 2 remaining goals, is disman dying?

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 12 Jun 2002 09:06:54 +0300

Elias,

I am not sure that 'keeping alive' a working group is really the goal that we should follow. If there is relevant new work to do, we can certainly ask for re-Charter, otherwise there is nothing bad in declaring victory, entering in maintenance mode and leaving the scene open for other IETF activities.

Concerning the Replication MIB, I think that there is merit in what you propose, but we need to define clearly the problem that we want to solve. A more generic problem of synchronization and replication of distributed data bases seems to be hidden between what you suggest. we need to understand if this is something we want to tackle, and if yes review the range of solutions that might be available for this problem.

Also, did you submit this draft? I could not find it in the Internet-Drafts repository.

Regards,

Dan

> -----Original Message-----
> From: Elias Procopio Duarte Jr. [mailto:[email-masked]]
> Sent: Wednesday, June 12, 2002 1:18 AM
> To: [email-masked]
> Cc: Elias Procopio Duarte Jr.
> Subject: only 2 remaining goals, is disman dying?
> 
> 
> Hi,
> 
> Distributed management is a truly broad field, and disman has 
> currently
> only two remaining goals... Actually so much has been done in 
> the past, 
> and now the list is so quiet, and there are nearly no new 
> developments...
> 
> As quoted from the WG page: "It is recognized that the scope of this
> working group is narrow relative to the potential in the area 
> of distributed
> network management. This is intentional in order to increase 
> the likelihood of
> producing useful, quality specifications in a timely manner."
> 
> We think this has been accomplished in the past.
> But perhaps this is time start new developments in order to 
> keep the WG
> alive?
> We offer you the Replication MIB as a possible new goal for 
> new developments
> in the same Working Group.
> 
> We have a new revised version of the Clustering/Replication MIB, 
> and are looking forward to a disman WG meeting in Yokohama.
> 
> The document is available at:
> http://www.inf.ufpr.br/~aldri/draft/replicationmib/index.html
> 
> The proposed approach, as presented in Salt Lake City, is a 3-tier
> architecture for dependable monitoring by replicating managed objects
> in middle-layer managers called clusters.
> 
> Replication is a key component of distributed systems, it can enhance
> both the availability and performance impact of monitoring. Using the
> proposed approach, a managed object is accessible, through the regular
> MIB interface, even when the agent/network element is down.  By using
> the Replication MIB together with the Expression MIB and Event MIB we
> have a powerful approach for managing objects from agents distributed
> throughout the network.
> 
> We are looking forward to hearing from you,
> 
> Sincerely,
> 
> Elias 
>

---

From: "Elias Procopio Duarte Jr." <[email-masked]>
Date: Fri, 14 Jun 2002 20:32:38 -0300 (BRT)

Dan,

I agree with you, a WG is meaningless if there is no
significant/interesting work to be done. However IMHO distributed management
certainly presents many challenges and has a huge potential in terms of
practical/efficient/reliable solutions. I think it would be a pity to let
disman die at this point!

You can see the Replication MIB as a systematic approach for dependable
monitoring. Objects are kept at replicated cluster managers, where they can
be accessed via the regular MIB interface.

Synchronization is not really a problem in the proposed solution because
of the usage of semi-active replication, in which the order in which
replicated objects are updated is guaranteed by a _leader_, which is a
cluster manager selected for that purpose. This leader replicates objects in
so called peer clusters.

This presents a fault-tolerant approach for fault-monitoring, in the sense
that objects are available even when part of the agent at the network
element is down, or part of the cluster managers are down, or unreachable.

The current version of the draft is available at
http://www.inf.ufpr.br/~aldri/draft/replicationmib/index.html

We didn't submit it because of the uncertainty regarding disman meeting or
not in Yohohama...

Cheers,

Elias