Subject: Re: Alarm #38, #43 - trap/notification varbind and timestamps

From: "Tom Petch" <[email-masked]>
Date: Thu, 13 Jun 2002 18:14:52 +0100

I believe the same index should retrieve the same value, regardless of v1 or v2 ie 1 for sysUpTime, 2 for SNMPTrapOID etc.  It is simple., it is logical.  But I am not clear from the text if that is an option you are offering me  !
Tom Petch, Network Consultant
[email-masked]
    -----Original Message-----
    From: Sharon Chisholm <[email-masked]>
    To: [email-masked] <[email-masked]>
    Date: 06 June 2002 04:22
    Subject: Alarm #38, #43 - trap/notification varbind and timestamps

    hi 

    Since potentially always treating notification varbinds like 
    they are NOTIFICATION-TYPE in #38 is related to the always 
    storing varbinds as if they are from notifications, as appose 
    to v1 traps, in #43, I've grouped these two: 

    Alarm #38 Description of object alarmModelVarbindIndex 
      Option 1) Change "For SNMPv1 traps, a 1 indicates the first varbind. For 
      NOTIFICATION-TYPE," to "For v1Traps,For v2Traps and Informs, a 1 indicates 
      the first varbind. ". 
      Option 2) Alternatively, always treat it like v2 traps 

      Solution: For consistency with #43 and to comply with the 
      philosophy of 2576, notifications, regardless of the protocol 
      will be treated *as though* they were NOTIFICATION-TYPE. We still 
      need to provide guidance of how to use this with v1 traps, as 
      well as indicate whether an index of 3 is the third varbind in the 
      notification on the wire, or as defined in the SMI. Therefore, the 
      the text from option 1) still applies: 

       "For SNMPv1 traps, a 1 indicates the first varbind. For 
             v2Traps and Informs, a 1 indicates the first real varbind 
             after the required varbinds of sysUptime and SNMPTrapOID.". 

    Alarm #43 Timestamp Description & Do we need two timestamps 
      Change text to: 
      'The time that the error information was added to the alarm table. 
      The time when the error occurred may be retrieved from a different 
      source, e.g. from the variable bindings of the notification if a 
      distributed system using notifications for alarm generation is 
      being implemented'. 
      Does this then require sysUptime and trapOID to be stored in 
        alarmActiveVariableTable, even for v1 traps? 
      
      Solution: Change text as described above. Always store notifications 
        as if they are NOTIFICATION-TYPE/v2 traps/informs. 

    Sharon Chisholm 
    Preside Management 
    Nortel Networks 
    Ottawa, Ontario

---

From: David Partain <[email-masked]>
Date: Tue, 18 Jun 2002 14:42:34 +0200

Hi,

On Thursday 13 June 2002 19.14, Tom Petch wrote:
> I believe the same index should retrieve the same value, regardless of
> v1 or v2 ie 1 for sysUpTime, 2 for SNMPTrapOID etc.  It is simple., it
> is logical.  But I am not clear from the text if that is an option you
> are offering me  !

There is no varbind holding sysUpTime.0 or SNMPTrapOID in
an SNMPv1 trap.  They are embedded in the message wrapper.
As such, what you are asking for is not possible.

Since the first two VarBinds in a v2c/v3 trap/inform somewhat
approximate information that's in the message wrapper for
SNMPv1 traps, I thought Sharon's proposed text was just fine
(I removed the "real" from "real varbinds" since I don't know
how to send a "fake" varbind).

That is:

 "For SNMPv1 traps, a 1 indicates the first varbind. For
 v2Traps and Informs, a 1 indicates the first varbind after
 the required varbinds of sysUptime and SNMPTrapOID."

Cheers,

dlp