Subject: Event MIB mteTriggerEnabled

From: "Sajedi, Mohammad" <[email-masked]>
Date: Thu, 29 Aug 2002 10:44:33 -0400

What is the difference between (mteTriggerEnabled = false) and
(mteTriggerEntryStatus = notInService)?
I think they are the same and the mteTriggerEnabled object is redundant.

Mohammad Sajedi
Juniper Networks Inc.
10 Technology Park Drive, MS 3135
Westford, MA 01886
978-589-0524

---

From: Randy Presuhn <[email-masked]>
Date: Thu, 29 Aug 2002 15:12:42 -0700 (PDT)

Hi -

> Message-ID: <49FF5C6DDBD8D311BBBD009027DE980C0274F6AE@UNIWEST1>
> From: "Sajedi, Mohammad" <[email-masked]>
> To: "[email-masked]'" <[email-masked]>
> Subject: Event MIB mteTriggerEnabled
> Date: Thu, 29 Aug 2002 10:44:33 -0400
> List-Id: IETF disman Working Group mailing list <disman.dorothy.bmc.com>
> 
...

See the thread "RFC 2981 (disman event MIB) Implementation
Experience" in the disman WG archives for November 8th, 2001.
ftp://amethyst.bmc.com/pub/disman/archives/2001-11

Or, read the RowStatus textual convention's definition
to see the side-effects of setting something to "notInService".

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  SJC-1.3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 30 Aug 2002 11:14:58 -0700 (PDT)

Hi -

> Message-ID: <[email-masked]>
> Date: Fri, 30 Aug 2002 06:11:00 -0700 (PDT)
> From: Mohammad Sajedi <[email-masked]>
> Subject: Re:  Event MIB mteTriggerEnabled
> To: Randy Presuhn <[email-masked]>
> In-Reply-To: <[email-masked]>
> 
> you are correct. But the way the definition of row
> status reads "Once made active an entry may not be
> modified except to delete it".

Not the definition of RowStatus.
See Column "D" in the table on page 9 of RFC 2579,
which specifies what can be done with an RowStatus
value of "active".

> How the value of mteTriggerEnabled can be changed
> after row status is set to active? I thought we want
> to toggle the mteTriggerEnabled value to true and
> false.
...

The description of mteTriggerEntryStatus was fixed in
<draft-ietf-disman-event-mib-v2-00.txt>