Subject: RE: Actiuon items from ARC discussion

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Tue, 27 Aug 2002 17:41:14 -0400

There are at least three possible levels of granulatity for persistence.

(1) With a storage type object. This will allow differentiation of
different level of persistence (e.g., nonVolatile vs permanent vs 
readOnly) and different row to have different level of persistence.

(2) With a MUST sentence: "Instances of this conceptual row MUST persist 
across agent restarts." This implies ALL rows are persistent. But there
is no differentiation of different level of persistence.

(3) With a SHOULD sentence: "Instances of this conceptual row SHOULD 
persist across agent restarts." There is no differentiation of different 
level of persistence. Moreover, cannot tell which row is persistent.

I agree with Juergen's concern. To address that, I would like to propose 
adding a storage type object to the ARC table. 
Note that according to the M.3100 ARC requirements, arcState must allow
changes by management request. Therefore, no row can be readOnly.

Given that, here is the proposed text for the storage type object that 
will be added to the arcTable.

arcStorageType OBJECT-TYPE
    SYNTAX       StorageType
    MAX-ACCESS   read-create
    STATUS       current
    DESCRIPTION "The storage type for this conceptual row.
                 Conceptual rows having the value 'permanent' must 
                 allow write-access at a minimum to arcState.
                 Note that arcState must allow change by management request.      
                 Therefore, no row can be created with 'readOnly'.
                 If a set operation tries to set the value to 'readOnly',
                 then an 'inconsistentValue' error must be returned.
                "
    DEFVAL      { nonVolatile }
    ::= { arcEntry 7}

Any comments?

Regards,
Kam Lam

> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:[email-masked]]
> Sent: Tuesday, August 13, 2002 12:51 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Actiuon items from ARC discussion
> 
> 
> 
> >>>>> Lam, Hing-Kam (Kam) writes:
> 
> Lam> In version -03 of the ARC mib, the following sentence was added
> Lam> to the arcEntry to describe persistence across agent restarts.
> 
> Lam>      Instances of this conceptual row SHOULD persist across agent
> Lam>      restarts.
> 
> Lam> Any comments?
> 
> What does that tell me as a management application writer? Can I
> assume that all rows have an implicit storage type of nonVolatile or
> stronger? Moreover, can I rely on the rows being persistent?  (In
> other words, when does the SHOULD apply?)
> 
> Note that without a storage type, there is no way to distinguish
> between permanent,readOnly and nonVolatile rows which makes it harder
> to grab and replay configurations...
> 
> /js
> 
> -- 
> Juergen Schoenwaelder    
> <http://www.informatik.uni-osnabrueck.de/schoenw/>
> 
>

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 28 Aug 2002 12:04:02 +0200

Once you define this object as described, you can then
in the MODULE-COMPLIANCE specify that it cannot be
set to read-only as follows:

   OBJECT arcStorageType
   WRITE-SYNTAX StorageType {
                     other(1),      -- atually I am not sure you would like to allow this?
                     volatile(2), 
                     nonVolatile(3),
                     permanent(4) 
                }
   DESCRITPION "The arcState object must allow change by management request.      
                Therefore, no row can be created with 'readOnly'."

Bert 

> From: Lam, Hing-Kam (Kam) [mailto:[email-masked]]
> Sent: dinsdag 27 augustus 2002 23:41
> To: 'Juergen Schoenwaelder'; [email-masked]
> Subject: RE: Actiuon items from ARC discussion
> 
>