Subject: Re: non-subscriber posting (Agentx)

From: Mark Ellison <[email-masked]>
Date: Thu, 26 Sep 2002 11:33:44 -0400

Hi Red,

[Please follow-up on the agentx list]

(1) Agentx uses sessions so that the master agent and sub-agents can readily detect a breakdown in connectivity with the other.  For example, if a
-test-set is sent to a sub-agent that crashes, the master-agent can recover more quickly than by waiting for the dispatch to the sub-agent to timeout.

(2) It is possible for many subagents to know about the same object-type.  Typically, subagents will register a subtree rather than a leaf object.
There are many details involved when registering a subtree (see RFC 2741 sxn 6.2.3, "The agentx-Register-PDU").  When the master receives a request
for a particular object name, it searches its list of registrations to determine the "authorative region", and dispatches the request to a single
subagent  (see sxn. 7.1.4.1,  "Handling Duplicate and Overlapping Subtrees")

The above should get you headed in the right direction, and additional followup questions are welcome- please post to [email-masked].

Regards,

Mark Ellison
Ellison Software Consulting, Inc.

Randy Presuhn wrote:

> Dear ***,
>            I have two  questions  about agentX protocol.
>           Question 1:
>                     Why agentX use sessions?
>                     I think  that  subagent register  a connection with masterAgent ,then register the vews to masterAgent. It is enogh
>           Question 2:
>                     Can many subagents owned the same OID? when SNMP set is requested, will master Agent send agentX_test_set for each   subagent?
>
>            I am waiting for your reply, Thanks
>
>                                                    Red
>
>                     .
>
>

---

From: Randy Presuhn <[email-masked]>
Date: Thu, 26 Sep 2002 14:37:25 -0700 (PDT)

Hi -

> Message-ID: <[email-masked]>
> Date: Thu, 26 Sep 2002 11:33:44 -0400
> From: Mark Ellison <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: non-subscriber posting  (Agentx)
> References: <[email-masked]>
...
> [Please follow-up on the agentx list]
...

The mis-forward to the disman list was my error.
I was in the midst of an early-morning conference call,
and hadn't had any caffeine yet.  (Without caffeine,
I make mistakes in slow motion.  :-)

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  SJC-1.3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------