Subject: RE: Glenn's ARC comments

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Thu, 10 Oct 2002 13:52:17 -0400

Hi all,

Please see inline below.

Regards,
Kam Lam

> 
> Anyway, to the content of Glenn's comments:
> 
> > 1. The MIB requires some patches to make it compile-
> >      a. IMPORT mib-2
> 
> agreed

Agree. Will do.

> 
> >      b. terminate the IMPORTS clause with a ';'
> 
> agreed

Agree. Will do.

> 
> >      c. in arcTable DESCRIPTION (line 343)
> >          s/"/'/
> 
> it looks like this is already fixed in -05-

Yes, is already fixed in -05-

> 
> >      d. line 394
> >         s/IANAItuProbableCause/IANAItuProbableCauseOrZero/
> 
> agreed (line number is different)

It is already fixed in -05-

> 
> >      e. in the COMPLIANCES section there are some irrelevant
> >         lines
> >         delete 560-570
> 
> I don't think so.  What am I missing?

Concur with Randy.

> 
> >      f. We may want to add arcStorageType to the arcSettingGroup
> 
> Perhaps.  When I look at the conformance material, I'm
> left feeling there's far too much optionality. As a general
> principle the optional stuff gets removed as stuff progresses
> along the standards track.  As a technical contributor, I
> strongly suggest that the conformance stuff be (1) simplified
> and (2) given meaningful DESCRIPTIONs.  I don't see the need
> for multiple groups here.

arcStorageType will be added to the arcSettingGroup

In M.3100 Amd3, Time-Inhibit and Count-Down are two separate 
optional features of the ARC function. In the ARC MIB, the 
arcTIGroup and arcQICDGroup GROUPs model these two 
optional feature and thus are made optional in the conformance statement.
I hope the following addition and changes in the DESCRIPTION clauses 
will help explain the rationale.

--Addition:

         GROUP  arcTIGroup
         DESCRIPTION
           "This group is optional, but is recommended for ARC settings
            that provide the Time Inhibit (TI) function."

         GROUP  arcQICDGroup
         DESCRIPTION
           "This group is optional, but is recommended for ARC settings
            that provide the Quality Inhibit (QI) Count Down (CD)
            function."

--Changes in the DESCRIPTION:

   arcTIGroup OBJECT-GROUP
           OBJECTS {
              arcMIBTITimeInterval,
              arcNalmTimeRemaining	 	
             }
             STATUS   current
             DESCRIPTION
                  "A collection of objects applicable to
                   ARC setting that support the Time Inhibit (TI)
                   function."
             ::= { arcGroups 2}

   arcQICDGroup OBJECT-GROUP
           OBJECTS {
              arcMIBCDTimeInterval,
              arcNalmTimeRemaining	 	
             }
             STATUS   current
             DESCRIPTION
                  "A collection of objects applicable to
                   ARC setting that support the Quality Inhibit (QI)
                   Count Down (CD) function."
             ::= { arcGroups 3}

> 
> > 2. Other nits.
> >      s/MAC-ACCESS/MAX-ACCESS/g
> ...
> 
> it looks like this is already fixed.

Yes, it is already fixed in -05-

> 
> Since these are issues which would require a new i-d to be
> done before the IESG would approve the document, as WG chair
> I'd like to ask the editors to do another spin.

Agree. Will do.

---

From: Glenn Mansfield Keeni <[email-masked]>
Date: Fri, 11 Oct 2002 09:34:31 +0900

Hi,
>>Anyway, to the content of Glenn's comments:
[snip]
>>I don't think so.  What am I missing?
My mistake. I misread that part. Ignore that comment.

[snip]

Glenn