Subject: Glenn's ARC comments

From: Randy Presuhn <[email-masked]>
Date: Tue, 8 Oct 2002 18:16:33 -0700 (PDT)

Hi -

Glenn's message was stuck in our majordomo plumbing since
September 14.  I don't know why Majordomo wouldn't pass
through the headers, which read:

| Received: from tattler.bmc.com (tattler.bmc.com [172.17.0.117])
|         by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id XAA03118
|         for <[email-masked]>; Fri, 13 Sep 2002 23:59:22 -0700 (PDT)
| Received: from mx-us-hou-2-int.bmc.com (localhost [127.0.0.1])
|         by tattler.bmc.com (8.10.2/8.10.2) with ESMTP id g8E719k10785
|         for <[email-masked]>; Sat, 14 Sep 2002 02:01:10 -0500 (CDT)
| Received: from geto.cysol.co.jp (geto.cysol.co.jp [210.169.247.73])
|         by mx-us-hou-2-int.bmc.com (Postfix) with SMTP id 1E6DE1FF015
|         for <[email-masked]>; Sat, 14 Sep 2002 02:00:48 -0500 (CDT)
| Received: from cysols.com (niseko.cysol.co.jp [210.169.247.75])
|         by geto.cysol.co.jp (8.11.3/3.7W) with ESMTP id g8E70JS16123;
|         Sat, 14 Sep 2002 16:00:19 +0900 (JST)
| Message-ID: <[email-masked]>
| Date: Sat, 14 Sep 2002 16:00:17 +0900
| From: Glenn Mansfield Keeni <[email-masked]>
| Organization: Cyber Solutions Inc.
| User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/200
| 20530
| X-Accept-Language: en, ja
| MIME-Version: 1.0
| To: [email-masked]
| Subject: Re: disman wg last calls update
| References: <[email-masked]>
| Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Anyway, to the content of Glenn's comments:

> 1. The MIB requires some patches to make it compile-
>      a. IMPORT mib-2

agreed

>      b. terminate the IMPORTS clause with a ';'

agreed

>      c. in arcTable DESCRIPTION (line 343)
>          s/"/'/

it looks like this is already fixed in -05-

>      d. line 394
>         s/IANAItuProbableCause/IANAItuProbableCauseOrZero/

agreed (line number is different)

>      e. in the COMPLIANCES section there are some irrelevant
>         lines
>         delete 560-570

I don't think so.  What am I missing?

>      f. We may want to add arcStorageType to the arcSettingGroup

Perhaps.  When I look at the conformance material, I'm
left feeling there's far too much optionality. As a general
principle the optional stuff gets removed as stuff progresses
along the standards track.  As a technical contributor, I
strongly suggest that the conformance stuff be (1) simplified
and (2) given meaningful DESCRIPTIONs.  I don't see the need
for multiple groups here.

> 2. Other nits.
>      s/MAC-ACCESS/MAX-ACCESS/g
...

it looks like this is already fixed.

Since these are issues which would require a new i-d to be
done before the IESG would approve the document, as WG chair
I'd like to ask the editors to do another spin.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  SJC-1.3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: Randy Presuhn <[email-masked]>
Date: Thu, 10 Oct 2002 11:21:07 -0700 (PDT)

Hi -

> Message-ID: <[email-masked]>
> From: "Lam, Hing-Kam (Kam)" <[email-masked]>
> To: "'Randy Presuhn'" <[email-masked]>, [email-masked]
> Subject: RE: Glenn's ARC comments
> Date: Thu, 10 Oct 2002 13:52:17 -0400
...
> In M.3100 Amd3, Time-Inhibit and Count-Down are two separate 
> optional features of the ARC function. In the ARC MIB, the 
> arcTIGroup and arcQICDGroup GROUPs model these two 
> optional feature and thus are made optional in the conformance statement.

WG chair says:
That it's optional in M.3100 does not mean that we have to retain
that optionality.  Keep in mind these provisions of RFC 2026, the
internet standards process:

|  The requirement for at least two independent and interoperable
|  implementations applies to all of the options and features of the
|  specification.  In cases in which one or more options or features
|  have not been demonstrated in at least two interoperable
|  implementations, the specification may advance to the Draft Standard
|  level only if those options or features are removed.

> I hope the following addition and changes in the DESCRIPTION clauses 
> will help explain the rationale.
> 
> --Addition:
> 
>          GROUP  arcTIGroup
>          DESCRIPTION
>            "This group is optional, but is recommended for ARC settings
>             that provide the Time Inhibit (TI) function."

Technical contributor says:  I think "recommended" should be replaced
with "REQUIRED" here.

>          GROUP  arcQICDGroup
>          DESCRIPTION
>            "This group is optional, but is recommended for ARC settings
>             that provide the Quality Inhibit (QI) Count Down (CD)
>             function."
...

Technical contributor says:  I think "recommended" should be replaced
with "REQUIRED" here.

One thing that *really* bugs me about making these things optional
is that it could result in these being present for some rows but
not others in the same table, since different rows can correspond
to different component implementations in a system.

---

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Fri, 11 Oct 2002 08:26:14 -0400

Hi,

The DESCRIPTION clauses will be changed to:

         GROUP  arcTIGroup
         DESCRIPTION
           "This group is REQUIRED for ARC settings
            that provide the Time Inhibit (TI) function."

         GROUP  arcQICDGroup
         DESCRIPTION
           "This group is REQUIRED for ARC settings
            that provide the Quality Inhibit (QI) Count Down (CD)
            function."

Regards,
Kam Lam 

> -----Original Message-----
> From: Randy Presuhn [mailto:[email-masked]]
> Sent: Thursday, October 10, 2002 2:21 PM
> To: [email-masked]
> > Message-ID: 
> <[email-masked]>
>  Tel: +1 408 546-1006   San Jose, California 95131  USA