Subject: [Disman] RE: Conditionmib version 09

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 3 Sep 2003 16:31:05 +0200

OK, what I then propose is that I issue IETF Last Call, and
that the below comments (together with any IETF Last Call
comments that may come up) will be addressed in a new
revision after the IETF Last Call but before I put it
on iesg agenda. Makes sense?

Thanks,
Bert 

> -----Original Message-----
> From: Randy Presuhn [mailto:[email-masked]]
> Sent: dinsdag 2 september 2003 22:54
> To: Wijnen, Bert (Bert)
> Cc: Disman (E-mail)
> Subject: Re: Conditionmib version 09
> 
> 
> Hi Bert -
> 
> I checked through 
> http://www.ietf.org/internet-drafts/draft-ietf-disman-conditio
> nmib-09.txt
> and found a couple of really minor nits that could probably 
> be  handled
> in the 48-hour review, if the RFC editor doesn't fix them as 
> a matter of course.
> 
> The technical issues are really minor.  One is no different from
> an existing problem with ifIndex and ifIndexOrZero.  
> Specifically, automated
> tools will be able to generate human-readable labels for the possible
> values of IANAItuProbableCause, but not for 
> IANAItuProbableCauseOrZero.
> I recommend no action on this item.
> 
> The other is that arcRowStatus should specify what objects need to be
> set for a row to go active, in accordance with page 21 of
> http://www.ietf.org/internet-drafts/draft-ietf-ops-mib-review-
> guidelines-02.txt
> I believe the intent is that all *except* 
> arcNalmTimeRemaining must be set.
> I think arcNalmTimeRemaining *may* be set at create time, but 
> this would
> have no effect given the current wording of the third 
> paragraph of its DESCRIPTION.
> 
> Purely editorial:
> 
> indentation of (a) in section 4's first paragraph is odd.
> 
> section 4.2 isn't really needed; one would expect to find it 
> in an IANA
> considerations section if it were retained.
> 
> arcTITimeInterval needs UNITS.  (already in DESCRIPTION, so editorial)
> 
> arcCDTimeInterval needs a UNITS clause.  (already in 
> DESCRIPTION, so editorial)
> 
> arcNalmTimeRemaining needs a UNITS clause.  (It's already in 
> the DESCRIPTION,
> so this is editorial.)
> 
> Section 6: isn't fully aligned with section 3.6 of
> http://www.ietf.org/internet-drafts/draft-ietf-ops-mib-review-
guidelines-02.txt
or the latest boilerplate at http://www.ops.ietf.org/mib-security.html
However, it *does* cover some interesting threats not addressed by the
boilerplate, and I think it meets the spirit of the requirement.

Section 8.1: the year for reference "zzzz" won't be 2002.

Randy

> From: "Wijnen, Bert (Bert)" <[email-masked]>
> To: "Randy Presuhn (E-mail)" <[email-masked]>
> Cc: "Bert Wijnen (E-mail)" <[email-masked]>
> Sent: Thursday, August 28, 2003 2:05 PM
> Subject: FW: Conditionmib version 09
>

> DId you check this one, and is it OK to be processed as PS?
>
> Thanks,
> Bert
>
> >  -----Original Message-----
> > From: Lam, Hing-Kam (Kam)
> > Sent: dinsdag 22 juli 2003 23:26
> > To: [email-masked]'
> > Cc: Wijnen, Bert (Bert); 'David Perkins'; [email-masked]'; 'Randy Presuhn'
> > Subject: Conditionmib version 09
> >
> > Attached is an updated version of the Condition MIB,
> > draft-ietf-disman-conditionmib-09.txt
> >
> > This version is produced to incorporate the comments from the Area Director review of Version 08.
> >
> > Please post this revision to the Disman WG site
> > http://www.ietf.org/ids.by.wg/disman.html
> >
> > Title: Alarm Reporting Control MIB
> > File: draft-ietf-disman-conditionmib-09.txt
> > Authors: Kam Lam (Lucent), An-ni Huynh (Cetus), and David Perkins (SNMPinfo)
> >
> > Abstract:
> >    This memo defines a portion of the Management Information Base (MIB)
> >    for use with network management protocols in TCP/IP-based internets.
> >    In particular, it defines objects for controlling the reporting of
> >    alarm conditions.
> >
> > Thanks.
> > Kam Lam
> >
> >

---

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Wed, 3 Sep 2003 12:01:59 -0400

I agree with the approach and thank Randy for the comments.

--Kam

> From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> Sent: Wednesday, September 03, 2003 10:31 AM
> To: 'Randy Presuhn'; Wijnen, Bert (Bert)
> Cc: Disman (E-mail)
> Subject: [Disman] RE: Conditionmib version 09
> 
>

---

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Wed, 3 Sep 2003 12:01:59 -0400

--Kam

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 23 Sep 2003 13:29:20 +0200

OK, we did not get any IETF Last Call Comments.
Sopls issue a rev 12 that addresses comments by Randy
below. I can then put it on IESG agenda.

If you can do it before COB Thursday, then I can probably
get it on IESG telechat agenda for October 2nd.
The sooner we see it, the faster I can process.

Thanks,
Bert 

> Sent: woensdag 3 september 2003 18:02
> To: Wijnen, Bert (Bert); 'Randy Presuhn'
> Cc: Disman (E-mail)
> Subject: RE: [Disman] RE: Conditionmib version 09
> 
> 
> > or the latest boilerplate at 
http://www.ops.ietf.org/mib-security.html

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 23 Sep 2003 13:29:20 +0200

Thanks,
Bert

---

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Wed, 24 Sep 2003 17:45:27 -0400

Randy,

I have modified 09 based on your comments.
Please let me know if you have any concern about the changes (see inline below).
I plan to upload version 10 on COB Thursday (Sept. 25) or once I receive an "Okay" from you.
 
Regards,
Kam

> Sent: Tuesday, September 02, 2003 4:54 PM
> To: Wijnen, Bert (Bert)
> Cc: Disman (E-mail)
> Subject: [Disman] Re: Conditionmib version 09
> 
> 
> Hi Bert -
> 
> I checked through 

Do nothing on this item.

> paragraph of its DESCRIPTION.

Add the following sentence at the end of the DESCRIPTION clause
of arcRowStatus:

    All the objects, except arcNalmTimeRemaining, must be set 
    before the row can be activated.

> indentation of (a) in section 4's first paragraph is odd.

Will fix the indentation.

> considerations section if it were retained.

Delete section 4.2 and update the table of content accordingly

> arcNalmTimeRemaining needs a UNITS clause.  (It's already in 

Add the following UNITS clause to the above objects:

  UNITS       "seconds"

guidelines-02.txt
> boilerplate, and I think it meets the spirit of the requirement.

Rewrite (purely editorially) the first two paragraphs are follow:

   There are a number of management objects defined in this MIB module
   with a MAX-ACCESS clause of read-write and/or read-create.  Such
   objects may be considered sensitive or vulnerable in some network
   environments.  The support for SET operations in a non-secure
   environment without proper protection can have a negative effect on
   network operations.  These are the tables and objects and their
   sensitivity/vulnerability:

      arcTITimeInterval, 
      arcCDTimeInterval, 
      arcState,
      arcNalmTimeRemaining, 
      arcRowStatus, 
      arcStorageType.

   Setting these objects may have disruptive effects on network 
   operation that range from omission of alarm notifications 
   to flooding of unwanted alarm notifications from the netowrk.  

   Some of the readable objects in this MIB module (i.e., objects with a
   MAX-ACCESS other than not-accessible) may be considered sensitive or
   vulnerable in some network environments.  It is thus important to
   control even GET and/or NOTIFY access to these objects and possibly
   to even encrypt the values of these objects when sending them over
   the network via SNMP.  These are the tables and objects and their
   sensitivity/vulnerability:

      arcTITimeInterval, 
      arcCDTimeInterval, 
      arcState,
      arcNalmTimeRemaining, 
      arcRowStatus, 
      arcStorageType.

   Reading these objects will provide information about the setting 
   which affects alarm notification generation.  

> Section 8.1: the year for reference "zzzz" won't be 2002.

Change to 2003.

---

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Wed, 24 Sep 2003 17:45:27 -0400

Randy,

Regards,
Kam

Do nothing on this item.

  UNITS       "seconds"

guidelines-02.txt

      arcTITimeInterval, 
      arcCDTimeInterval, 
      arcState,
      arcNalmTimeRemaining, 
      arcRowStatus, 
      arcStorageType.

      arcTITimeInterval, 
      arcCDTimeInterval, 
      arcState,
      arcNalmTimeRemaining, 
      arcRowStatus, 
      arcStorageType.

Change to 2003.

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 24 Sep 2003 23:55:47 +0200

I believe that Randy does not have (good) email access
until Sept 29th. If the WG does not see any issues 
imemdiately, then pls post the new rev. 
I will then put it on IESG agenda. If Randy shows a
concern before Thursday next week, we will deal
with it then.

Thanks,
Bert 

> Sent: woensdag 24 september 2003 23:45
> Subject: RE: [Disman] Re: Conditionmib version 09
> 
> 
> Randy,
>

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 24 Sep 2003 23:55:47 +0200

Thanks,
Bert