Subject: [Disman] traceroute-mib-1

From: Juergen Quittek <[email-masked]>
Date: Wed, 21 Jan 2004 16:53:09 +0100

Dear all,

Here is an issue on the TRACEROUTE MIB:

I want to clarify the DESCRIPTION clause of object

 traceRouteResultsLastGoodPath OBJECT-TYPE
    SYNTAX      DateAndTime
    MAX-ACCESS  read-only
    STATUS      current
    DESCRIPTION
        "The date and time when the last complete path
        was determined."
    ::= { traceRouteResultsEntry 8 }

Does anyone have an understanding of the term "complete
path" that differs from the following?

    DESCRIPTION
        "The date and time when the last complete path
        was determined.  A path is complete if the IP
        address of each hop along the path has been
        detected."

Thanks,

    Juergen
-- 
Juergen Quittek        [email-masked]        Tel: +49 6221 90511-15
NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 90511-55
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.ccrle.nec.de

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 21 Jan 2004 17:37:29 +0100

>>>>> Juergen Quittek writes:

[...]

Juergen> Does anyone have an understanding of the term "complete path"
Juergen> that differs from the following?

Juergen> The date and time when the last complete path was determined.
Juergen> A path is complete if the IP address of each hop along the
Juergen> path has been detected."

Some nodes do not send ICMP responses or they are blocked somewhere
so it happens with ordinary traceroutes that you see *s instead of
IP numbers for a certain hop. (Sure, there is a timeout associated
with this somehow.) If I take your addition by the word, I might
conclude that a traceroute in never completes in case there is node
in the path which does not send me ICMP responses.

In other words, I do not think that the clarification helps.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 21 Jan 2004 17:37:29 +0100

[...]

/js

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 22 Jan 2004 00:47:50 +0100

> in the path which does not send me ICMP responses.

But otherwise, wouldn't all paths be complete paths?
What would be an incomplete path?

In the PING MIB a good probe is defined as

 pingResultsLastGoodProbe OBJECT-TYPE^M
    SYNTAX      DateAndTime^M
    MAX-ACCESS  read-only^M
    STATUS      current^M
    DESCRIPTION^M
        "Date and time when the last response was received for^M
        a probe."^M
    ::= { pingResultsEntry 10 }^M

Wouldn't a good path be a path for which responses were received
from all hops?

> In other words, I do not think that the clarification helps.

Now I'm sure there is one needed.

    Juergen

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 22 Jan 2004 00:47:50 +0100

Juergen

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 22 Jan 2004 13:40:12 +0100

>>>>> Juergen Quittek writes:

Juergen> Wouldn't a good path be a path for which responses were
Juergen> received from all hops?

Sure, in theory. But in reality, there are hops in the path which will
simply not respond. So a good path is a path for which responses or
timeouts have been received for all hops.

(And again, if you hit an unfriendly firewall somewhere on the path,
you might end up increasing the ttl until you reach the max. ttl
value.)

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 22 Jan 2004 13:40:12 +0100

/js

---

From: Juergen Quittek <[email-masked]>
Date: Sun, 25 Jan 2004 12:37:15 +0100

> you might end up increasing the ttl until you reach the max. ttl

Of course. Would this also be a good path? I guess: yes.

Still we need to clarify this in the DESCRIPTION clause.

So here is another try:

 traceRouteResultsLastGoodPath OBJECT-TYPE
    SYNTAX      DateAndTime
    MAX-ACCESS  read-only
    STATUS      current
    DESCRIPTION
        "The date and time when the last complete path
        was determined.  A path is complete if responses
        were received or timeout occurred for each hop on
        the path, i.e. for each TTL value from the value
        of the corresponding traceRouteCtlInitialTtl object
        up to the end of the path or - if no reply from the
        target IP address was received - up to the value of
        the corresponding traceRouteCtlMaxTtl object."
    ::= { traceRouteResultsEntry 8 }

This is not really nice phrasing. Does anyone have a better suggestion?

Thanks,

    Juergen

---

From: Juergen Quittek <[email-masked]>
Date: Sun, 25 Jan 2004 12:37:15 +0100

So here is another try:

Thanks,

    Juergen