Subject: [Disman] ping-mib-1

From: Juergen Quittek <[email-masked]>
Date: Wed, 21 Jan 2004 16:35:54 +0100

Dear all,

I'm editing a new version of the remote operations MIBs.
Besides a number of editorial issues I found three issues
that I want to discuss on the list, one for each MIB module.

Here is the first one. In the PING MIB there is a
contradiction in the definition of

pingCtlTrapGeneration OBJECT-TYPE
    SYNTAX      BITS {
                   probeFailure(0),
                   testFailure(1),
                   testCompletion(2)
                  }
    MAX-ACCESS  read-create
    STATUS      current
    DESCRIPTION
        "The value of this object determines when and if
        to generate a notification for this entry:

        probeFailure(0)   - Generate a pingProbeFailed
            notification subject to the value of
            pingCtlTrapProbeFailureFilter.  The object
            pingCtlTrapProbeFailureFilter can be used
            to specify the number of successive probe failures
            that are required before a pingProbeFailed
            notification can be generated.
        testFailure(1)    - Generate a pingTestFailed
            notification. In this instance the object
            pingCtlTrapTestFailureFilter can be used to
            determine the number of probe failures that
            signal when a test fails.
        testCompletion(2) - Generate a pingTestCompleted
            notification.

        The value of this object defaults to zero, indicating
        that none of the above options have been selected."
    ::= { pingCtlEntry 13 }

The last sentence of the DESCRIPTION clause refers to a default
value for which none of the option is selected.  Such a value
is not defined.  Also there is no DEFVAL clause.

I see alternatives to fix this:

1. We can just remove the last sentence from the DESCRIPTION clause.
   Then we would not have a value for this object that allows to
   disable generation of Notification in all cases.

2. We can add a value none(4), add DEFVAL { none }, and replace
   "zero" by "none(4)" in the last sentence of the description clause.

3. We can leave the DESCRIPTION clause almost unchanged and renumber
   the values:
    SYNTAX      BITS {
                   none(0),
                   probeFailure(1),
                   testFailure(2),
                   testCompletion(3)
                  }

Does anyone has a strong preference or another solution of this issue?

Thanks,

    Juergen
-- 
Juergen Quittek        [email-masked]       Tel: +49 6221 90511-15
NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 90511-55
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.ccrle.nec.de

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 21 Jan 2004 17:33:00 +0100

>>>>> Juergen Quittek writes:

Juergen> Dear all,

Juergen> Here is the first one. In the PING MIB there is a
Juergen> contradiction in the definition of
Juergen> pingCtlTrapGeneration 

[...]

Juergen> Does anyone has a strong preference or another solution of
Juergen> this issue?

I think the correct DEFAL to add is

		DEFVAL { {} }  -- No bits set.

and the text needs to be modified to talk about a bit string with
no bits set or a zero-length bit string or whatever you prefer.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 21 Jan 2004 17:33:00 +0100

Juergen> Dear all,

[...]

/js

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 22 Jan 2004 02:34:19 +0100

Juergen,

> no bits set or a zero-length bit string or whatever you prefer.

I see.

Thanks,

    Juergen
-- 
Juergen Quittek        [email-masked]        Tel: +49 6221 90511-15
NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 90511-55
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.ccrle.nec.de

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 22 Jan 2004 02:34:19 +0100

Juergen,

I see.

Thanks,

    Juergen