Subject: Re: [Disman] ping-mib-3, traceroute-mib-4

From: Juergen Quittek <[email-masked]>
Date: Wed, 11 Feb 2004 00:46:45 +0100

Dear all,

I support Giorgio's proposal to add another value called completed(3)
to pingResultsOperStatus and traceRouteResultsOperStatus.  If nobody
objects, I'll add it to the next version and modify the DESCRIPTION
clauses appropriately.

    Juergen
-- 
Juergen Quittek        [email-masked]        Tel: +49 6221 90511-15
NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 90511-55
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.ccrle.nec.de

--On 28.01.2004 12:12 Uhr +0100 Giorgio Nunzi wrote:

> Dear all,
>
> my second note involves again both the ping-mib and traceroute-mib.
>
> Refering to the ping-mib, it's not totally clear to me if the object
> pingResultsOperStatus tells if the ping test has been completed.
>
> pingResultsOperStatus OBJECT-TYPE
>      SYNTAX      INTEGER {
>                            enabled(1),  -- test is in progress
>                            disabled(2)  -- test has stopped
>                          }
>      MAX-ACCESS  read-only
>      STATUS      current
>      DESCRIPTION
>          "Reflects the operational state of a pingCtlEntry:
>             enabled(1)   - Test is active.
>             disabled(2)  - Test has stopped."
>      ::= { pingResultsEntry 1 }
>
> If the related value of pingCtlFrequency is 0 and the test is
> finished, no other tests are scheduled. At this point we cannot say
> that the 'test is in progress'; on the other hand it's not clear if
> the value disabled(2) should be set. I suggest two alternatives:
> - extend the definition of the disabled(2) to include the case when no
> more tests are scheduled;
> - add a new value completed(3).
>
> I personally find more convenient the second solution to outline that
> the values of the conceptual row will not change.
>
> Analogous considerations are valid concerning the objects
> traceRouteResultsOperStatus and traceRouteCtlFrequency; the solutions
> are the same as well.
>
> traceRouteResultsOperStatus OBJECT-TYPE
>      SYNTAX      INTEGER {
>                            enabled(1), -- test is in progress
>                            disabled(2) -- test has stopped
>                          }
>      MAX-ACCESS  read-only
>      STATUS      current
>      DESCRIPTION
>          "Reflects the operational state of an traceRouteCtlEntry:
>
>             enabled(1)  - Test is active.
>             disabled(2) - Test has stopped."
>      ::= { traceRouteResultsEntry 1 }
>
> Please let me know if you find this remark convenient.
>
> Giorgio
>
> --
> Giorgio Nunzi
> Network Laboratories              Heidelberg, Germany
> NEC Europe Ltd.                   http://www.netlab.nec.de
>
>
>

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 11 Feb 2004 00:46:45 +0100

Dear all,

    Juergen