Subject: Re: [Disman] traceroute-mib-5, ping-mib-4, lookup-2

From: Juergen Quittek <[email-masked]>
Date: Wed, 11 Feb 2004 01:00:17 +0100

Giorgio,

Thanks!  I'll add this to the next version.

    Juergen
-- 
Juergen Quittek        [email-masked]        Tel: +49 6221 90511-15
NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 90511-55
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.ccrle.nec.de

--On 28.01.2004 12:14 Uhr +0100 Giorgio Nunzi wrote:

> Dear all,
>
> my last note involves all the three REMOPS MIBs.
> I describe the traceroute-mib first.
>
> traceRouteMaxConcurrentRequests OBJECT-TYPE
>      SYNTAX      Unsigned32
>      UNITS       "requests"
>      MAX-ACCESS  read-write
>      STATUS      current
>      DESCRIPTION
>         "The maximum number of concurrent active traceroute requests
>         that are allowed within an agent implementation.  A value
>         of 0 for this object implies that there is no limit for
>         the number of concurrent active requests in effect."
>      DEFVAL { 10 }
>      ::= { traceRouteObjects 1 }
>
> An ambiguity holds when a value is set for this object and the agent
> has already more active requests than the value specified.
> The solutions possible are:
> - kill the exceeding requests (for instance the ones started recently)
> and start them again later;
> - continue to process them.
> I suggest the second case and to add the following sentence at the
> bottom of the DESCRIPTION clause.
> "The limit applies only to the new rquests being activated.  When a
> new value is set, the agent will process all the requests already
> active, even if they exceed the limit just imposed."
>
> Analogous considerations (and solutions) are valid for the objects
> pingMaxConcurrentRequests and lookupMaxConcurrentRequests.
>
> pingMaxConcurrentRequests OBJECT-TYPE
>      SYNTAX      Unsigned32
>      UNITS       "requests"
>      MAX-ACCESS  read-write
>      STATUS      current
>      DESCRIPTION
>         "The maximum number of concurrent active ping requests
>         that are allowed within an agent implementation.  A value
>         of 0 for this object implies that there is no limit for
>         the number of concurrent active requests in effect."
>      DEFVAL { 10 }
>      ::= { pingObjects 1 }
>
>
> lookupMaxConcurrentRequests OBJECT-TYPE
>      SYNTAX      Unsigned32
>      UNITS       "requests"
>      MAX-ACCESS  read-write
>      STATUS      current
>      DESCRIPTION
>         "The maximum number of concurrent active lookup requests
>         that are allowed within an agent implementation.  A value
>         of 0 for this object implies that there is no limit for
>         the number of concurrent active requests in effect."
>      DEFVAL { 10 }
>      ::= { lookupObjects 1 }
>
>
> Giorgio
>
> --
> Giorgio Nunzi
> Network Laboratories              Heidelberg, Germany
> NEC Europe Ltd.                   http://www.netlab.nec.de
>
>
>
>
>
>

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 11 Feb 2004 01:00:17 +0100

Giorgio,

    Juergen