Subject: [Disman] mteTriggerDeltaDiscontinuityIDWildcard question

From: "mark kaplun" <[email-masked]>
Date: Sat, 29 Oct 2005 19:42:16 +0200

Hi,

By the description of the object it is possible to conclude that there is no 
difference between this object and mteTriggerValueIDWildcard, so why does it 
exist? am I missing something?

Mark. 

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.361 / Virus Database: 267.12.6/151 - Release Date: 28.10.2005

---

From: "Randy Presuhn" <[email-masked]>
Date: Sat, 29 Oct 2005 12:02:16 -0700

Hi -

> From: "mark kaplun" <[email-masked]>
> To: <[email-masked]>
> Sent: Saturday, October 29, 2005 10:42 AM
> Subject: [Disman] mteTriggerDeltaDiscontinuityIDWildcard question
>
> Hi,
> 
...

Some discontinuity indicators, e.g. sysUpTime, are scalars.  Others are
in tables.  Consequently, whether a given object can be monitored
using wildcarding cannot be used to infer whether wildcarding would be
appropriate for its discontinuity indicator.

Randy

---

From: "mark kaplun" <[email-masked]>
Date: Mon, 31 Oct 2005 17:34:31 +0200

----- Original Message ----- 
From: "Randy Presuhn" <[email-masked]>
To: "Disman" <[email-masked]>
Sent: Saturday, October 29, 2005 9:02 PM
Subject: Re: [Disman] mteTriggerDeltaDiscontinuityIDWildcard question

> appropriate for its discontinuity indicator.

Makes sense, but the description says

        "Note that the value of this object will
        be the same as that of the corresponding instance of
        mteTriggerValueIDWildcard when the corresponding
        mteTriggerSampleType is 'deltaValue'."

My understanding is that mteTriggerDeltaDiscontinuityIDWildcard MUST be
false when mteTriggerValueIDWildcard is false, but can take ANY value when
mteTriggerValueIDWildcard is true. This is IMHO in contradiction with the
use of the word "same" in the description.

Mark

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 31 Oct 2005 12:32:35 -0800

Hi -

> To: "Randy Presuhn" <[email-masked]>; "Disman" <[email-masked]>
> Sent: Monday, October 31, 2005 7:34 AM
...
> My understanding is that mteTriggerDeltaDiscontinuityIDWildcard MUST be

The note doesn't say "MUST", but this is just a quibble.

...

Yes, I agree that the note appears to be in error.  I suggest deleting the note.
Comments?

Randy