Subject: Re: Re: [Disman] DISMAN deployment

From: Yves Bertsch <[email-masked]>
Date: Thu, 10 Nov 2005 09:22:11 +0100

The precise point I was looking for was to find something similar as Rmon event/alarm mechanism to send traps from systems on occurence of integer values (CPU activity, disk free...etc)
Some Disman MIBs (Alarm MIBs) seems to answer this question 
I have understood DISMAN is much more general, and before starting studying these MIBs, I just wanted to know how these mechanism are really implemented and deployed
I see nothing on windows for example.
thanks in advance
yb

> Hi -
> 
> > From: "Yves Bertsch" <[email-masked]>
> > To: <[email-masked]>
> > Sent: Wednesday, November 09, 2005 2:28 PM
> > Subject: [Disman] DISMAN deployment
> ...
> > is it possible to find some documentation on implementation/deployment of DISMAN ?
> > which CPU, vendor ...
> ...
> 
> It might help to know which specific MIBs you are interested in.
> You can also find some discussion of implementations in the
> working group archives.
> 
> Randy
> 
> 
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 11 Nov 2005 04:07:53 +0100

On Thu, Nov 10, 2005 at 09:22:11AM +0100, Yves Bertsch wrote:

> The precise point I was looking for was to find something similar as
> Rmon event/alarm mechanism to send traps from systems on occurence
> of integer values (CPU activity, disk free...etc)
> I have understood DISMAN is much more general, and before starting
> studying these MIBs, I just wanted to know how these mechanism are
> really implemented and deployed

It seems that some of the MIB modules produced by the DISMAN WG turned
out to be too generic to be successful in terms of wide deployment.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany

---

From: Dave Shield <[email-masked]>
Date: Fri, 11 Nov 2005 10:02:46 +0000

On Thu, 2005-11-10 at 09:22 +0100, Yves Bertsch wrote:
> The precise point I was looking for was to find something similar
> as Rmon event/alarm mechanism to send traps from systems on occurence

That actually feels to be closer to the DisMan Event MIB,
rather than the Alarm MIB.

> I see nothing on windows for example.

The Net-SNMP agent has supported a (somewhat limited) version of
the Event MIB for several years, though we're only now bringing
a (rewritten) version of both this and the Schedule MIB, into
the default configuration.
  I'm not 100% sure whether these work with the Windows version
of the agent, but if they don't, that will be down to problems
with the callback mechanism for retrieving information (and the
general Unix bias of most of the developers) rather than anything
more fundamental to the MIBs themselves.

I intend to submit a proper implementation report shortly, once
the new code has received a little more practical testing.  (*I*
think these MIBs work, but the wider Net-SNMP community may have
different ideas!)

Dave

---

From: "Carl W. Kalbfleisch" <[email-masked]>
Date: Sat, 12 Nov 2005 08:22:27 -0600

Yves,

My company is using the DISMAN Event MIB in its product to monitor  
CPU,Memory, and Swap from the Host Resources MIB and generate  
notifications. We intend to monitor other attributes as well.

Carl