Subject: Re: [dispatch] I-D Action:draft-wing-dispatch-v6-migration-00.txt

From: "Elwell, John" <[email-masked]>
Date: Wed, 1 Sep 2010 18:01:10 +0200

Thanks to the authors for writing this draft, which was triggered by the Bar BoF in Maastricht, which was in turn triggered by drafts discussed in MMUSIC such as ICE-microlite (of which I am a co-author) and ALTC.

Whilst doubting the need for connectivity checks (whether they be STUN-based, RTP-based, RTCP-based or whatever) in certain closed networks, in my opinion, where connectivity checks are needed, the existing STUN-based connectivity checks will suffice. To introduce a second method (whether RTP-based, RTCP-based or STUN-based-without-SHA1) will not help interoperability, and will likely introduce as many problems as it solves.

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: 27 August 2010 21:15
> To: [email-masked]
> Subject: I-D Action:draft-wing-dispatch-v6-migration-00.txt 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 	Title           : Migrating SIP to IPv6 Media Without 
> Connectivity Checks
> 	Author(s)       : D. Wing, A. Yourtchenko
> 	Filename        : draft-wing-dispatch-v6-migration-00.txt
> 	Pages           : 8
> 	Date            : 2010-08-27
> 
> During the migration from IPv4 to IPv6, it is anticipated that an
> IPv6 path might be broken for a variety of reasons, causing endpoints
> to not receive RTP data.  Connectivity checks would detect and avoid
> the user noticing such a problem, but there is industry reluctance to
> implement connectivity checks.
> 
> This document describes a mechanism allowing dual-stack SIP endpoints
> to attempt communications over IPv6 and fall back to IPv4 if the IPv6
> path is not working.  The mechanism does not require connectivity
> checks.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-wing-dispatch-v6-mig
ration-00.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 2 Sep 2010 15:33:20 +0200

Hi,

The draft does not (maybe on purpose) take SBCs into consideration.

An SBC would have to establish pinholes for both IPv4 and IPv6, in order to RTP packages using both versions to pass.

In addition you have the issue (not unique to your draft) that there might not be end-to-end media connectivity in the first place before the call has been answered etc.

Regards,

Christer

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Elwell, John [[email-masked]]
Sent: Wednesday, September 01, 2010 7:01 PM
To: IETF DISPATCH list
Subject: Re: [dispatch] I-D Action:draft-wing-dispatch-v6-migration-00.txt

John

ration-00.txt
> implementation to automatically retrieve the ASCII version of the
_______________________________________________
dispatch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dispatch