Subject: Re: [dispatch] HTTP streaming WAS (Re: I-D Action:draft-wu-http-streaming-optimization-ps-00.txt)

From: "David A. Bryan" <[email-masked]>
Date: Wed, 1 Sep 2010 08:43:48 -0400

I think there are two issues here, Does this work need to be done, and
where to do it?

I think work to define a standard for HTTP streaming certainly needs
to be done. HTTP streaming is becoming more prevalent, and there are
non-compatible standards floating around out there today. As an
example, just today Apple will be broadcasting their September media
event using their own HTTP streaming proposal, and it turns only Apple
hardware users can watch it:

http://www.macrumors.com/2010/09/01/can-you-watch-apples-keynote-stream-requirements-and-workarounds/

The second question is where to do this work. Yes, other standards
organizations have looked at this, but it's not like there haven't
been a good number of proposals brought to the IETF as well. As
Gonzalo pointed out, draft-wu-http-streaming-optimizations-ps-00 is
out there, and draft-pantos-http-livestreaming-04, documenting the
Apple mechanism I discussed above has been brought to the IETF as
well.

In addition, to me this seems much more the sort of work that belongs
at the IETF than somewhere like W3C. Even ignoring the issue that HTTP
itself is defined in the IETF, there are aspects of coordinating a
standard on HTTP streaming that require consideration of transport
issues (fairness, delay, etc.), issues involving real-time
considerations and interoperability with other streaming techniques
(which could touch work on RTP, work in the new PPSP WG, etc.) The
membership of the IETF, to me, appears to be the group with the right
skill set, and more importantly, the IETF is responsible for the other
protocols that this inevitably seems to require coordination with,

I'd like to see us work in this area, and would be interested in participating.

David

On Tue, Aug 31, 2010 at 10:15 PM, Gerard Fernando <[email-masked]> wrote:
> Hello,
>
> I also agree with you that it's not the content of the ID that one should
> discuss at this point, instead it is more the direction or policy of IETF
> with regard to this important subject. Being new to the DISPATCH WG
> discussions I'm not sure whether this has been discussed in the last few
> months.
>
> Several other SDO's (MPEG, 3GPP and Open IPTV Forum) have been very active
> in spec. development, and there seems to be a large degree of coordination
> between those SDO's. Has there been any coordination between them and IETF?
> After all... it is HTTP 1.1 that forms the basis for those efforts!
>
> It is important to understand the policy of IETF with regard to such
> efforts. I hope that IETF does have a role to play with this activity, and
> would at the minimum set some guidelines.
>
> Thanks
>
> Gerard
> ----------
>
> Gerard Fernando
> ZTE Corporation
>
> ________________________________
> From: Gonzalo Camarillo <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Sent: Tue, 31 August, 2010 0:34:07
> Subject: Re: [dispatch] HTTP streaming WAS (Re: I-D
> Action:draft-wu-http-streaming-optimization-ps-00.txt)
>
> Hi,
>
> we have not seen any comments on this topic (HTTP streaming). However,
> many people were on vacation in August. Please, send your comments to
> this list.
>
> Thanks,
>
> Gonzalo
>
> On 28/07/2010 10:24 AM, Gonzalo Camarillo wrote:
>> Hi,
>>
>> yes, to be clear, the idea is not to only discuss this draft. The idea
>> is to discuss what can be done in the HTTP streaming area at the IETF (I
>> have changes the subject of this email).
>>
>> As Ali pointed out below, this is an important area that is advancing
>> fast. So, we would like to get your input sooner rather than later.
>>
>> Thanks,
>>
>> Gonzalo
>>
>>
>> On 28/07/2010 12:15 AM, Ali C. Begen (abegen) wrote:
>>> (Responding to Gonzalo's email)
>>>
>>> I read this draft, but I won't comment on the draft here. Rather, I would
>>> like to understand the goal(s) of this draft.
>>>
>>> HTTP streaming, as noted by the draft, has been around for some time now
>>> and there are already multiple products available. Many groups besides IETF
>>> have shown interest in this topic and worked towards producing their own
>>> specs in the past year. Just last week, MPEG also joined the club and has
>>> started evaluating the received proposals.
>>>
>>> Sure, we can discuss some of the design issues here at IETF. But, do we
>>> want to achieve more than that? If yes, we should be aware of the time
>>> pressure.
>>>
>>> -acbegen
>>> _______________________________________________
>>> dispatch mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/dispatch
>>>
>>
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>
>

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 1 Sep 2010 09:04:52 -0400

> I'd like to see us work in this area, and would be interested in participating.

+1 David put it very well.

Regards
Marshall

---

From: Roni Even <[email-masked]>
Date: Wed, 01 Sep 2010 18:25:37 +0300

Hi,
I think David brought some good points. The issue of using HTTP for live
streaming in draft-pantos-http-livestreaming-04 was discussed in the AVT
mailing list and there was interest but this is not AVT charter. Yet I think
that the IETF should look at it not only on how to carry the media but also
in the wide aspect of addressing the transport issues as David mentioned and
also at how to work in environments that may use a combination of RTP
multicast and HTTP unicast.

I would like us to work in this area and will participate in this work

Roni Even 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of David A. Bryan
> Sent: Wednesday, September 01, 2010 3:44 PM
> To: Gerard Fernando
> Cc: [email-masked]; [email-masked]
> Subject: Re: [dispatch] HTTP streaming WAS (Re: I-D Action:draft-wu-
> http-streaming-optimization-ps-00.txt)
>

---

From: Qin Wu <[email-masked]>
Date: Thu, 02 Sep 2010 17:08:01 +0800

> at the IETF than somewhere like W3C.

[Qin]: Yes, Comparing their difference, I think W3C more looks at client implentation and API standardization while IETF
focus on protocol aspect specification. They may be complementary to each other with coordination effort.

> Even ignoring the issue that HTTP
> (which could touch work on RTP, work in the new PPSP WG, etc.) 

[Qin]: Yes, Looking at data transport(i.e.,HTTP 1.1), HTTP with tranditional polling support seems not designed for real-time 
interactive media such as real time voice and video communications, . Therefore it is obvious the interactive media transport is 
not implemented in the browser itself. Given user expericence into consideration, delivering the same experience as the TV for all consumers
or delivering the experience complementary to TV for all consumers is still a big challenges to HTTP Streaming. These
chanllenges include delayed starts, poor video quality, and long buffering interruptions.

A study conducted by StreamGuard.net examined more than 2,400 different Internet video streams. They concluded that:
. 51% of stream viewers were frustrated with the experience.
. 17% of streams have an immediate fatal error.
. 25% take between 5 and 10 seconds to start playing, and stop to rebuffer before the video is finished.

>The membership of the IETF, to me, appears to be the group with the right

[Qin] +1.

---

From: Colin Perkins <[email-masked]>
Date: Thu, 2 Sep 2010 20:21:34 +0100

On 1 Sep 2010, at 13:43, David A. Bryan wrote:
> I think there are two issues here, Does this work need to be done,  
> and where to do it?

Right. It's clear that having a widely accepted standard in this area  
would be a good thing. I think it's also clear that the IETF has the  
expertise to do the work. What's not yet clear to me, though, is what  
contribution the IETF would make, and why any standard we develop will  
be accepted by the industry, especially given the ongoing work in  
other standards bodies. The drafts I've seen submitted (draft-wu-http- 
streaming-optimization-ps and draft-pantos-http-live-streaming) give a  
survey and problem statement, and a sketch of playlist-based streaming  
operation, but primarily describe existing systems, with little new  
contribution. If there were proposals that leveraged the IETF's  
strengths -- e.g., tweaking HTTP to improve streaming performance, or  
giving strong guidance on how to use HTTP in a network-friendly way --  
then I'd support spinning-up work in the area, but I've yet to see  
anything compelling.

Cheers,
Colin

> event using their own HTTP streaming proposal, and it turns only  
> Apple hardware users can watch it:
>
> In addition, to me this seems much more the sort of work that  
> belongs at the IETF than somewhere like W3C. Even ignoring the issue  
> that HTTP itself is defined in the IETF, there are aspects of  
> coordinating a standard on HTTP streaming that require consideration  
> of transport issues (fairness, delay, etc.), issues involving real- 
> time considerations and interoperability with other streaming  
> techniques (which could touch work on RTP, work in the new PPSP WG,  
> etc.) The membership of the IETF, to me, appears to be the group  
> with the right skill set, and more importantly, the IETF is  
> responsible for the other protocols that this inevitably seems to  
> require coordination with,
>
> On Tue, Aug 31, 2010 at 10:15 PM, Gerard Fernando <[email-masked] 
> > wrote:
>> Hello,
>>
>> I also agree with you that it's not the content of the ID that one  
>> should discuss at this point, instead it is more the direction or  
>> policy of IETF with regard to this important subject. Being new to  
>> the DISPATCH WG discussions I'm not sure whether this has been  
>> discussed in the last few months.
>>
>> Several other SDO's (MPEG, 3GPP and Open IPTV Forum) have been very  
>> active in spec. development, and there seems to be a large degree  
>> of coordination between those SDO's. Has there been any  
>> coordination between them and IETF? After all... it is HTTP 1.1  
>> that forms the basis for those efforts!
>>
>> It is important to understand the policy of IETF with regard to  
>> such efforts. I hope that IETF does have a role to play with this  
>> activity, and would at the minimum set some guidelines.
>>
>> Thanks
>>
>> Gerard
>> ----------
>>
>> Gerard Fernando
>> ZTE Corporation
>>
>> we have not seen any comments on this topic (HTTP streaming).  
>> However, many people were on vacation in August. Please, send your  
>> comments to this list.
>>
>> Thanks,
>>
>> Gonzalo
>>
>>> yes, to be clear, the idea is not to only discuss this draft. The  
>>> idea is to discuss what can be done in the HTTP streaming area at  
>>> the IETF (I have changes the subject of this email).
>>>
>>> As Ali pointed out below, this is an important area that is  
>>> advancing fast. So, we would like to get your input sooner rather  
>>> than later.
>>>
>>> Thanks,
>>>
>>> Gonzalo
>>>
>>>
>>>> I read this draft, but I won't comment on the draft here. Rather,  
>>>> I would like to understand the goal(s) of this draft.
>>>>
>>>> HTTP streaming, as noted by the draft, has been around for some  
>>>> time now and there are already multiple products available. Many  
>>>> groups besides IETF have shown interest in this topic and worked  
>>>> towards producing their own specs in the past year. Just last  
>>>> week, MPEG also joined the club and has started evaluating the  
>>>> received proposals.
>>>>
>>>> Sure, we can discuss some of the design issues here at IETF. But,  
>>>> do we want to achieve more than that? If yes, we should be aware  
>>>> of the time pressure.
>>>>
>>>> -acbegen

-- 
Colin Perkins
http://csperkins.org/

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 02 Sep 2010 20:42:00 -0500

I believe Colin says here the operational word, if I understand correctly:

>tweaking HTTP to improve streaming performance, or
>giving strong guidance on how to use HTTP in a network-friendly way

...and I would like to add, taking into consideration the requirements for
network elements in Content Distribution Networks (CDN) to support streaming
HTTP.

Specifically, what are the standards requirements for CDN network elements
for interoperability with existing streaming implementations?

There is an excellent overview here from the perspective of the client and
servers, but CDN, though mentioned, are not described or referenced as far
as I could find. Does anyone know?

http://developer.apple.com/iphone/library/documentation/networkinginternet/c
onceptual/streamingmediaguide/HTTPStreamingArchitecture/HTTPStreamingArchite
cture.html

Thanks, Henry

---

From: Qin Wu <[email-masked]>
Date: Fri, 03 Sep 2010 17:55:02 +0800

----- Original Message ----- 
From: "Colin Perkins" <[email-masked]>
To: "David A. Bryan" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, September 03, 2010 3:21 AM
Subject: Re: [dispatch] HTTP streaming WAS (Re: I-DAction:draft-wu-http-streaming-optimization-ps-00.txt)

> then I'd support spinning-up work in the area, but I've yet to see  

[Qin]: Good point.
One of my thoughts would be the current HTTP Streaming has not been effective in delivering high-quality video content across the Internet. 
The typical user experience is limited by delayed startups, poor quality, buffering delays.Does it worth providing better transport scheme to improve
streaming  performance, satisfy the video quality requirements (e.g., bandwidth, layered video codec, delay and loss requirements)? Does it make
 sense to head toward this direction.