Subject: [dmarc-ietf] Kicking off DMARCbis -- tracker and process updates

From: Seth Blank <[email-masked]>
Date: Sun, 3 May 2020 22:34:30 -0700

Hi all,

For us to present a standards track document to the IESG, there are many
items, some contentious and potentially time consuming, that we must
discuss and resolve. While Tim has set up a GitHub repository for work on
the I-D, we will be using the datatracker to manage that work.

The intention of the Chairs is to have an orderly discussion of all the
items, ensure all concerns are raised, tracked, and resolved, and deliver a
document that successfully makes the transition from ISE to IESG approval.

Look for a separate email from Alexey on our process for managing items in
the data tracker itself. Please refrain from adding any new items until
Alexey's email is in hand.

The datatracker now reflects items raised on the list as well as other
items brought to the Chairs directly:
https://trac.ietf.org/trac/dmarc/report/1 Please do NOT edit, close, or
comment on issues until a Chair explicitly opens discussion on the item on
list, as discussed below.

As of this evening, there are 56 open items in the tracker, they all appear
to roughly fall into the following buckets (with some examples from each):

1) nits
    - ABNF issues, preventing feedback loops, better statuses

2) updates to tags (primarily calls for removal)
    - remove sp, pct, ri, apsf, adkim, and reporting chunking

3) reporting enhancements
    - more extensible reporting, ARC reports, JSON reports, https POST
reporting, stripped down failure reports

4) clarifying prose
    - implications of failure reports, define what it means to have
"implemented" DMARC

5) general improvements
    - PSD, removing the PSL and Org Domain definition from DMARC

None of these items are themselves requirements, some may overstate their
claims, other under, and others still are mutually exclusive or depend on
the resolution state of other items. The only requirement is that every
item in the tracker must be brought to the group for discussion.

To efficiently discuss as a WG and arrive at a rough consensus on each
item, the Chairs will use the following process for DMARCbis to tear
through open tracker items:

- We will have three tickets from the datatracker open for discussion on
the list at any given time

- Each ticket will have a Chair responsible for shepherding discussion

- Once consensus is called on a ticket, that will be recorded in the
tracker, and a new ticket will be opened for discussion

- This process is separate from editing the I-D (or I-Ds), which will occur
in parallel, but will not block this process

We'll be bringing the first three items to the list later this week.

As MSK said in March, it will likely be a long road to get this work ready
for Standards Track and address all the open issues. We're looking forward
to everyone's collaboration and progressing this work together.

Seth, as Chair

-- 

*Seth Blank* | VP, Standards and New Technologies
*e:* [email-masked]
*p:* 415.273.8818

This email and all data transmitted with it contains confidential and/or
proprietary information intended solely for the use of individual(s)
authorized to receive it. If you are not an intended and authorized
recipient you are hereby notified of any use, disclosure, copying or
distribution of the information included in this transmission is prohibited
and may be unlawful. Please immediately notify the sender by replying to
this email and then delete it from your system.

---

From: "Alexey Melnikov" <[email-masked]>
Date: Sat, 09 May 2020 15:43:42 +0100

Hi all, 

This is the followup email that Seth was talking about in the message below. Here is the process that chairs will use for managing tickets in trac (and just to clarify, when Seth wrote "datatracker" he really meant "trac" on tools.ietf.org)

1) Opening tickets: anyone can open a new ticket. But please check existing tickets (including the closed ones) if the issue was already discussed. Chairs would require higher bar for reopening closed tickets. If you want to reopen a ticket, please email WG chairs directly at [email-masked].

2) Closing tickets:

Document editors can close tickets about editorial issues. These will have the summary line starting with "Editorial: ".
(If in doubt, please ask WG chairs whether you think it is editorial or not)

Only Chairs can close larger issues.

All issues must be closed with a reference to the mailing list discussion (typically an URL of a message in the DMARC mailing list archive).

When we get closer to being done with DMARCbis, chairs might switch to stricter rules about closing tickets. If we do, we will send a separate email about that at that time.

Best Regards,
Alexey, on behalf of chairs.

On Mon, May 4, 2020, at 6:34 AM, Seth Blank wrote:
> Hi all,
> 
> For us to present a standards track document to the IESG, there are many items, some contentious and potentially time consuming, that we must discuss and resolve. While Tim has set up a GitHub repository for work on the I-D, we will be using the datatracker to manage that work.
> 
> The intention of the Chairs is to have an orderly discussion of all the items, ensure all concerns are raised, tracked, and resolved, and deliver a document that successfully makes the transition from ISE to IESG approval.
> 
> 
> Look for a separate email from Alexey on our process for managing items in the data tracker itself. Please refrain from adding any new items until Alexey's email is in hand.
> 
> The datatracker now reflects items raised on the list as well as other items brought to the Chairs directly: https://trac.ietf.org/trac/dmarc/report/1 Please do NOT edit, close, or comment on issues until a Chair explicitly opens discussion on the item on list, as discussed below.
> 
> As of this evening, there are 56 open items in the tracker, they all appear to roughly fall into the following buckets (with some examples from each):
> 
> 1) nits
>  - more extensible reporting, ARC reports, JSON reports, https POST reporting, stripped down failure reports
> 
> 4) clarifying prose
>  - implications of failure reports, define what it means to have "implemented" DMARC
> 
> 5) general improvements
> None of these items are themselves requirements, some may overstate their claims, other under, and others still are mutually exclusive or depend on the resolution state of other items. The only requirement is that every item in the tracker must be brought to the group for discussion.
> 
> 
> To efficiently discuss as a WG and arrive at a rough consensus on each item, the Chairs will use the following process for DMARCbis to tear through open tracker items:
> 
> - We will have three tickets from the datatracker open for discussion on the list at any given time
> 
> - Once consensus is called on a ticket, that will be recorded in the tracker, and a new ticket will be opened for discussion
> 
> - This process is separate from editing the I-D (or I-Ds), which will occur in parallel, but will not block this process
> 
> As MSK said in March, it will likely be a long road to get this work ready for Standards Track and address all the open issues. We're looking forward to everyone's collaboration and progressing this work together..
> 
> Seth, as Chair
> 
> -- 
> 

> This email and all data transmitted with it contains confidential and/or proprietary information intended solely for the use of individual(s) authorized to receive it. If you are not an intended and authorized recipient you are hereby notified of any use, disclosure, copying or distribution of the information included in this transmission is prohibited and may be unlawful. Please immediately notify the sender by replying to this email and then delete it from your system.

> _______________________________________________
> dmarc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmarc
>