Subject: Re: [dmarc-ietf] ARC questions

From: "Douglas E. Foster" <[email-masked]>
Date: Sun, 22 Nov 2020 14:18:44 -0500

ARC has a very limited set of items included in the signature.   Body hash is purposefully excluded.  So it is the same signature algorithm but with different parameters and a different purpose.  Therefore it has a different header label .Sent from my Verizon, Samsung Galaxy smartphone<div>
</div><div>
</div><!-- originalMessage --><div>-------- Original message --------</div><div>From: John R Levine <[email-masked]> </div><div>Date: 11/22/20  2:14 PM  (GMT-05:00) </div><div>To: Michael Thomas <[email-masked]>, "Kurt Andersen (b)" <[email-masked]> </div><div>Cc: [email-masked] </div><div>Subject: Re: [dmarc-ietf] ARC questions </div><div>
</div>> Is there a reason that there is a separate ARC-signature rather than just 
> using the DKIM signature that is normally created for the new message? Since 
> ARC is new, you'd not want the intermediary to stop DKIM signing the message 
> so you end up with essentially two signatures doing essentially the same 
> thing?

The ARC signature has a sequence number so you can track the chain of 
custody.  You are right that it is similar to the DKIM signature but the 
extra ovehead doesn't seem excessive.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

_______________________________________________
dmarc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dmarc

---

From: Michael Thomas <[email-masked]>
Date: Sun, 22 Nov 2020 11:31:23 -0800

On 11/22/20 11:18 AM, Douglas E. Foster wrote:
> ARC has a very limited set of items included in the signature.   Body 
> hash is purposefully excluded.  So it is the same signature algorithm 
> but with different parameters and a different purpose.  Therefore it 
> has a different header label .

Now wait, Kurt just said that the body hash is included. Somebody has to 
be wrong here.

Mike

>
>
> Sent from my Verizon, Samsung Galaxy smartphone
>
>
>
> -------- Original message --------
> From: John R Levine <[email-masked]>
> Date: 11/22/20 2:14 PM (GMT-05:00)
> To: Michael Thomas <[email-masked]>, "Kurt Andersen (b)" 
> <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [dmarc-ietf] ARC questions
>
> > Is there a reason that there is a separate ARC-signature rather than 
> just

---

From: "John Levine" <[email-masked]>
Date: 22 Nov 2020 15:01:18 -0500

In article <[email-masked]> you write:
>-=-=-=-=-=-
>> ARC has a very limited set of items included in the signature.� �Body 
>> hash is purposefully excluded.� So it is the same signature algorithm 
>> but with different parameters and a different purpose.� Therefore it 

Doug is mistaken. The ARC-Message-Signature (AMS) header has the same
body hash as a DKIM signature.

---

From: "Douglas E. Foster" <[email-masked]>
Date: Sun, 22 Nov 2020 15:34:49 -0500

Apologies.    Either I read an obsolete version of the document, an unrelated document, or have a hallucinating memory.   Hoping it is not my mind going south...

Doug

----------------------------------------

From: "John Levine" <[email-masked]>
Sent: 11/22/20 3:01 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [dmarc-ietf] ARC questions

In article <[email-masked]> you write:
>> ARC has a very limited set of items included in the signature.? ?Body
>> hash is purposefully excluded.? So it is the same signature algorithm
>> but with different parameters and a different purpose.? Therefore it