Subject: [dmarc-ietf] Trac #117

From: "Brotman, Alex" <[email-masked]>
Date: Sat, 14 Aug 2021 14:10:45 +0000

Folks,

A ticket was opened to add a "human_result" to the SPF results in the report.  As DKIM has similar, I don't necessarily see an issue here.  It seems like this could be useful to those attempting to resolve issues relating to failing SPF results. The ticket illustrates a few examples:

----------------------------------------------
Justification:
A free text string <human_result> allows to add a meaningful error message in case when the SPF result is permerror or temperror.
This can be used as signaling mechanism, especially when the error is not obvious or does not occur with every mail receiver (subject to how strict they interpret the SPF spec and how they handle minor errors).

Here are a couple of real-world examples (anonymized) during SPF checks that have been all subsumed as permerror:

    "example.net: Maximum DNS-interactive terms limit (10) exceeded"
    "example.net ... example.com: Maximum DNS-interactive terms limit (10) exceeded"
    "example.net: Redundant applicable 'v=spf1' sender policies found"
    "example.net: Included domain 'example.com' has no applicable sender policy"
    "mail.example.net: Junk encountered in record 'v=spf1 a mx ip4:192.0.2.1 ip4:192.0.2.51 ~all|'"
    "example.net: Junk encountered in record 'v=spf1 ip4:192.0.2.1 ip4:192.0.2.51 include:_spf.example.com <​http://spf.example.com> ~all'"
    "example.net: Missing required domain-spec in 'Include:'"

Note that there are different interpretations of how to count the number of DNS lookups:
<​https://www.mail-archive.com/[email-masked]/msg03268.html>

Examples for temperror:

    "example.net: 'SERVFAIL' error on DNS 'TXT' lookup of 'example.net'"
    "email.example.net: 'SERVFAIL' error on DNS 'TXT' lookup of 'email.example.net'"
    "example.net: 'SERVFAIL' error on DNS 'PTR' lookup of '1.2.0.192.in-addr.arpa'"

The name <human_result> has been chosen, because it already exists for the <dkim> section.
-------------------------------------

https://trac.ietf.org/trac/dmarc/ticket/117

--
Alex Brotman
Sr. Engineer, Anti-Abuse & Messaging Policy
Comcast

---

From: Alessandro Vesely <[email-masked]>
Date: Sat, 14 Aug 2021 17:30:58 +0200

On Sat 14/Aug/2021 16:10:45 +0200 Brotman, Alex wrote:
> Folks,
> 
> A ticket was opened to add a "human_result" to the SPF results in the report.  As DKIM has similar, I don't necessarily see an issue here.

That field addition seems to me to be a due fix.

Best
Ale
--