Subject: [DMM] I-D Action: draft-ietf-dmm-requirements-14.txt

From: [email-masked]
Date: Mon, 03 Feb 2014 14:36:41 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Distributed Mobility Management Working Group of the IETF.

        Title           : Requirements for Distributed Mobility Management
        Authors         : H Anthony Chan
                          Dapeng Liu
                          Pierrick Seite
                          Hidetoshi Yokota
                          Jouni Korhonen
	Filename        : draft-ietf-dmm-requirements-14.txt
	Pages           : 19
	Date            : 2014-02-03

Abstract:
   This document defines the requirements for Distributed Mobility
   Management (DMM) at the network layer.  The hierarchical structure in
   traditional wireless networks has led primarily to centralized
   deployment models.  As some wireless networks are evolving away from
   the hierarchical structure, a distributed model for mobility
   management can be useful to them.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dmm-requirements/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-dmm-requirements-14

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-dmm-requirements-14

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 04 Feb 2014 10:28:09 +0100

Thanks for this new version.

A comment:

> Mobility support is also needed, for example, when a mobile router
> moves together with a host and an application in the host is
> interrupted by a change of IP address of the mobile router.
                                                             ^and 
presence of ingress filtering.

Alex

Le 03/02/2014 23:36, [email-masked] a écrit :
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Distributed Mobility
> Management Working Group of the IETF.
>
> Authors         : H Anthony Chan Dapeng Liu Pierrick Seite Hidetoshi
> Yokota Jouni Korhonen Filename        :
> draft-ietf-dmm-requirements-14.txt Pages           : 19 Date
> : 2014-02-03
>
> Abstract: This document defines the requirements for Distributed
> Mobility Management (DMM) at the network layer.  The hierarchical
> structure in traditional wireless networks has led primarily to
> centralized deployment models.  As some wireless networks are
> evolving away from the hierarchical structure, a distributed model
> for mobility management can be useful to them.
>
>
>
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> _______________________________________________ I-D-Announce mailing
> list [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce Internet-Draft
> directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>

---

From: h chan <[email-masked]>
Date: Thu, 13 Feb 2014 23:35:50 +0000

Alex,

Thanks for spelling out the conditions more accurately. Just to confirm whether the addition the text in red as in the following is needed for accuracy reasons.

May I ask whether we can alternatively assume that ingress filtering should always not be prevented. Then when the red text is missing as in version 14, is that still incorrect or it needs to be corrected?

REQ2: Bypassable network-layer mobility support

DMM solutions MUST enable network-layer mobility but it MUST

be possible to not use it. Mobility support is needed, for

example, when a mobile host moves and an application cannot

cope with a change in the IP address. Mobility support is

also needed, for example, when a mobile router moves together

with a host and an application in the host is interrupted by a

change of IP address of the mobile router

and the presence of ingress filtering.

However mobility

support at the network-layer is not always needed; a mobile

node can often be stationary, and mobility support can also be

provided at other layers. It is then not always necessary to

maintain a stable IP address or prefix.

H Anthony Chan

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
Sent: Tuesday, February 04, 2014 3:28 AM
To: [email-masked]
Subject: Re: [DMM] I-D Action: draft-ietf-dmm-requirements-14.txt

> interrupted by a change of IP address of the mobile router.

                                                             ^and presence of ingress filtering.

Alex

Le 03/02/2014 23:36, [email-masked]<mailto:[email-masked]> a écrit :

> centralized deployment models.  As some wireless networks are evolving

> away from the hierarchical structure, a distributed model for mobility

> list [email-masked]<mailto:[email-masked]>

_______________________________________________

dmm mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dmm

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 19 Feb 2014 16:03:28 +0100

H Anthony,

> and the presence of ingress filtering.

Sounds good, technically.  Since this is already a long phrase maybe we 
could detail it further, and then later make it better, or separate.

How about this:

> Distributed Mobility Management support is also needed, for example,
> when a Mobile Router moves together with a Host and an application
> running in the Host (LFN) is disturbed by the change of address of
> the Mobile Router.  Specifically, the incoming packets towards the
> Host may be blocked at a Router in the path from the CN, or may be
> taking a longer path through the Home Agent (in case Mobile IP is
> used); an application sending packets from the Host may be blocked by
> the ingress filtering potentially set in the access network, or may
> take a longer path through the Home Agent (in case Mobile IP is
> used).

What do you think?

Alex

Alex

Le 14/02/2014 00:35, h chan a écrit :
> Alex,
>
> Thanks for spelling out the conditions more accurately. Just to
> confirm whether the addition the text in red as in the following is
> needed for accuracy reasons.
>
> May I ask whether we can alternatively assume that ingress filtering
> should always not be prevented. Then when the red text is missing as
> in version 14, is that still incorrect or it needs to be corrected?
>
> -----Original Message----- From: dmm [mailto:[email-masked]]
> On Behalf Of Alexandru Petrescu Sent: Tuesday, February 04, 2014 3:28
> AM To: [email-masked] Subject: Re: [DMM] I-D Action:
> draft-ietf-dmm-requirements-14.txt
>
> Le 03/02/2014 23:36, [email-masked]
> <mailto:[email-masked]> a écrit :
>
>>
>
>> evolving
>> list [email-masked] <mailto:[email-masked]>
>
> [email-masked] <mailto:[email-masked]>
>

---

From: h chan <[email-masked]>
Date: Mon, 24 Feb 2014 21:58:02 +0000

Alex,

In the 2 choices to describe the need for mobility support for MR, the second choice involves more changes than the first choice. Because the draft is already going through IESG, I think we can take the first choice as the basis: 

Mobility support is also needed, for example, when a mobile router moves together with a host and an application in the host is interrupted by a change of IP address of the mobile router and the presence of ingress filtering.

Since this mobile router sentence was okay technically except for being too long, I think we can simply shorten it as follows: 

Mobility support is also needed when a mobile router changes its IP address as it moves together with a host and, in the presence of ingress filtering, an application in the host is interrupted. 

The entire REQ2 is then:

          DMM solutions MUST enable network-layer mobility but it MUST
          be possible to not use it.  Mobility support is needed, for
          example, when a mobile host moves and an application cannot
          cope with a change in the IP address.  Mobility support is
          also needed when a mobile router changes its IP address as it
          moves together with a host and, in the presence of ingress
          filtering, an application in the host is interrupted.  However
          mobility support at the network-layer is not always needed; a
          mobile node can often be stationary, and mobility support can
          also be provided at other layers.  It is then not always
          necessary to maintain a stable IP address or prefix.

H Anthony Chan

-----Original Message-----
From: Alexandru Petrescu [mailto:[email-masked]] 
Sent: Wednesday, February 19, 2014 9:03 AM
To: h chan; [email-masked]
Subject: Re: [DMM] I-D Action: draft-ietf-dmm-requirements-14.txt

H Anthony,

> and the presence of ingress filtering.

Sounds good, technically.  Since this is already a long phrase maybe we could detail it further, and then later make it better, or separate.

How about this:

> running in the Host (LFN) is disturbed by the change of address of the 
> Mobile Router.  Specifically, the incoming packets towards the Host 
> may be blocked at a Router in the path from the CN, or may be taking a 
> longer path through the Home Agent (in case Mobile IP is used); an 
> application sending packets from the Host may be blocked by the 
> ingress filtering potentially set in the access network, or may take a 
> longer path through the Home Agent (in case Mobile IP is used).

What do you think?

Alex

Alex

Le 14/02/2014 00:35, h chan a écrit :
> -----Original Message----- From: dmm [mailto:[email-masked]] On 
> Behalf Of Alexandru Petrescu Sent: Tuesday, February 04, 2014 3:28 AM 
> To: [email-masked] Subject: Re: [DMM] I-D Action: