Subject: [DMM] MPTCP Proxy for Mobile Networks

From: "Xiongchunshan (Sam)" <[email-masked]>
Date: Fri, 21 Feb 2014 07:18:44 +0000

Hello folks,

Here I have some comments on this document:

1)
5.2  Traffic mediation
   (a) Anchoring of sub-flow traffic: On one hand, it is not always
   possible for a single GW be sitting on the path of every sub-flow
   from a MPTCP session, hence explicit traffic anchoring to enable a
   single point of general control over MPTCP sub-flows should be
   considered.
   (b) Mediation of sub-flow traffic: On the other hand, for fine-
   grained mediation of sub-flow traffic, both static and dynamic
   selection/offloading/pooling policies should be allowed. For
   instance, "always prefer Wi-Fi over 3GPP" could be a static policy
   for bulk data transfer services, while "use 3GPP only for backup
   unless Wi-Fi is congested" could be a dynamic offloading policy for a
   un-prioritized VoIP service.
[xcs]Question for clarification: How does the MPTCP proxy know the binding information between the IP and RAT ?  The mobile node knows which IP is allocated from which RAT, but it is very hard for the MPTCP Proxy in the core network to know these mapping information.
One possible solution is the PCRF (defined in the 3GPP) to provide these binding information to the MPTCP proxy if the MPTCP proxy performance the traffic mediation or let the mobile to do the traffic mediation.

Another question is how the rules (e.g. "always prefer Wi-Fi over 3GPP") are provided to the MPTCP Proxy or the mobile ? For the MPTCP proxy, it is again the PCRF; for the mobile , it is the ANDSF ?

2)
4.2 Resource pooling for reduced expense
   Due to its low construction and operation expenses, Wi-Fi has been
   adopted by mobile operators as a complementary RAT for their
   traditional 3GPP networks. However, different construction and
   operation expenses of various radio networks result in differences in
   charging rates/policies for different RATs.
   For instance, Wi-Fi access may be charged by the access duration,
   while the 3GPP access may be charged by the consumed data volume.
   Even if using the same policy, Wi-Fi service is expected to be much
   cheaper than 3GPP data service.
   Moreover, different subscription packages may offer various data
   plans for various RATs. For instance, a basic 4G package may contain
   free data volume as well free Wi-Fi access too.
   By enabling MPTCP session between UE and network proxy, via mediating
   sub-flow data traffic based on their Radio access types and the
   user's subscription package, it is possible to further reduce the
   usage expenses from both sides of the network and user.

[xcs] it will benefit the user if the user's expense of data usage is reduced, if the WiFi connection is available and charging fee is very low, maybe all the traffic from the 4G are moved to the WiFi by the MPTCP proxy, and the mobility and QoS of the service maybe aren't ensured, so it is proposed to adding the following sentence to the end of this chapter:
The QoS/QoE/Service continuity of the current data services are still kept when the MPTCP proxy is used to reduce the user's usage expenses.

A assumption for reducing user expense is that the WiFi connection is activated beforehand, but sometimes the WiFi connection isn't activated or a wrong WiFi AP is selected by the user( that MPTCP Proxy can't access the WiFi IP flow), that is, one hand, the network need to control the MPTCP Proxy to mediate the IP flows, another hand, the network should tell the mobile to open which RAT/WiFi to make the MPTCP Proxy work.  i.e. the network should provide some information to the UE , to guide the UE to select and open another RAT to enable the MPTCP.

3)
4.1 Dynamic traffic offloading based on network information
   For real-time interactive services with higher QoS requirements it is
   expected that 3GPP network can provide better guarantees on the
   average case. For bulk data transfer who is satisfied with best-
   effort delivery, Wi-Fi would be a great choice. But the vertical
   partition does not fit everywhere for the wireless condition itself
   is quite dynamic and hard to predict. It is important to implement
   adaptive offloading mechanisms in order to achieve higher resource
   utility with ever changing radio environment for a possibly moving
   terminal based on network status, e.g. cell load, AP's signal
   intensity, user's subscription type, etc.
[xcs]The same question from 1):  How does the MPTCP Proxy/UE know the network status ? The PCRF/ANDSF provides these information to the MPTCP Proxy/UE ?

BRs
Chunshan Xiong
Huawei Technologies Co., Ltd.

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 21 Feb 2014 10:52:56 +0200

Do you mean draft-deng-mptcp-mobile-network-proxy-00 I-D ?

- Jouni

On Feb 21, 2014, at 9:18 AM, Xiongchunshan (Sam) <[email-masked]> wrote:

>    user’s subscription package, it is possible to further reduce the
> [xcs] it will benefit the user if the user’s expense of data usage is reduced, if the WiFi connection is available and charging fee is very low, maybe all the traffic from the 4G are moved to the WiFi by the MPTCP proxy, and the mobility and QoS of the service maybe aren’t ensured, so it is proposed to adding the following sentence to the end of this chapter:
> The QoS/QoE/Service continuity of the current data services are still kept when the MPTCP proxy is used to reduce the user’s usage expenses.
>  
> A assumption for reducing user expense is that the WiFi connection is activated beforehand, but sometimes the WiFi connection isn’t activated or a wrong WiFi AP is selected by the user( that MPTCP Proxy can’t access the WiFi IP flow), that is, one hand, the network need to control the MPTCP Proxy to mediate the IP flows, another hand, the network should tell the mobile to open which RAT/WiFi to make the MPTCP Proxy work.  i.e. the network should provide some information to the UE , to guide the UE to select and open another RAT to enable the MPTCP.
>  
>  
> 3)
>    terminal based on network status, e.g. cell load, AP’s signal
>    intensity, user’s subscription type, etc.
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm

---

From: <[email-masked]>
Date: Fri, 21 Feb 2014 08:54:03 +0000

Which document are you referring ?

De : dmm [mailto:[email-masked]] De la part de Xiongchunshan (Sam)
Envoyé : vendredi 21 février 2014 08:19
À : [email-masked]
Objet : [DMM] MPTCP Proxy for Mobile Networks

Hello folks,

1)
5.2  Traffic mediation

2)

3)

BRs
Chunshan Xiong

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Xiongchunshan (Sam)" <[email-masked]>
Date: Fri, 21 Feb 2014 09:03:17 +0000

Hello Pierrick , Jouni,

The comments are for the ID: draft-deng-mptcp-mobile-network-proxy-00.txt

Thanks for the reminding  and I change the title of the email.

BRs
Chunshan Xiong 熊春山

From: [email-masked] [mailto:[email-masked]]
Sent: Friday, February 21, 2014 4:54 PM
To: Xiongchunshan (Sam); [email-masked]
Subject: RE: [DMM] MPTCP Proxy for Mobile Networks

De : dmm [mailto:[email-masked]] De la part de Xiongchunshan (Sam)
Envoyé : vendredi 21 février 2014 08:19
À : [email-masked]<mailto:[email-masked]>
Objet : [DMM] MPTCP Proxy for Mobile Networks

Hello folks,

1)
5.2  Traffic mediation

2)

3)

BRs
Chunshan Xiong

Thank you.

---

From: Hidetoshi Yokota <[email-masked]>
Date: Tue, 25 Feb 2014 09:05:06 +0900

Hi Chunshan,

Isn't this I-D for MPTCP WG (although it is somewhat related to DMM)?

Regards,

-- 
Hidetoshi Yokota

KDDI R&D Laboratories, Inc.
e-mail:[email-masked]

(2014/02/21 16:18), Xiongchunshan (Sam) wrote:
> [xcs]Question for clarification: How does the MPTCP proxy know the 
> binding information between the IP and RAT ? The mobile node knows 
> which IP is allocated from which RAT, but it is very hard for the 
> MPTCP Proxy in the core network to know these mapping information.
>
> One possible solution is the PCRF (defined in the 3GPP) to provide 
> these binding information to the MPTCP proxy if the MPTCP proxy 
> performance the traffic mediation or let the mobile to do the traffic 
> mediation.
>
> Another question is how the rules (e.g. "always prefer Wi-Fi over 
> 3GPP") are provided to the MPTCP Proxy or the mobile ? For the MPTCP 
> proxy, it is again the PCRF; for the mobile , it is the ANDSF ?
>
> 2)
>
> [xcs] it will benefit the user if the user’s expense of data usage is 
> reduced, if the WiFi connection is available and charging fee is very 
> low, maybe all the traffic from the 4G are moved to the WiFi by the 
> MPTCP proxy, and the mobility and QoS of the service maybe aren’t 
> ensured, so it is proposed to adding the following sentence to the end 
> of this chapter:
>
> *The QoS/QoE/Service continuity of the current data services are still 
> kept when the MPTCP proxy is used to reduce the user’s usage expenses.*
>
> A assumption for reducing user expense is that the WiFi connection is 
> activated beforehand, but sometimes the WiFi connection isn’t 
> activated or a wrong WiFi AP is selected by the user( that MPTCP Proxy 
> can’t access the WiFi IP flow), that is, one hand, the network need to 
> control the MPTCP Proxy to mediate the IP flows, another hand, the 
> network should tell the mobile to open which RAT/WiFi to make the 
> MPTCP Proxy work. i.e. the network should provide some information to 
> the UE , to guide the UE to select and open another RAT to enable the 
> MPTCP.
>
> 3)
>
> [xcs]The same question from 1): How does the MPTCP Proxy/UE know the 
> network status ? The PCRF/ANDSF provides these information to the 
> MPTCP Proxy/UE ?
>
> BRs
>
> Chunshan Xiong
>

---

From: "Xiongchunshan (Sam)" <[email-masked]>
Date: Tue, 25 Feb 2014 00:59:26 +0000

Hello all,

So sorry, I make a mistake, I confuse all of you with another WG's document.

BRs
Chunshan Xiong

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of Hidetoshi Yokota
Sent: Tuesday, February 25, 2014 8:05 AM
To: [email-masked]
Subject: Re: [DMM] MPTCP Proxy for Mobile Networks

Hi Chunshan,

Regards,

--
Hidetoshi Yokota