Subject: [DMM] FPSM work team draft

From: Marco Liebsch <[email-masked]>
Date: Tue, 10 Mar 2015 12:59:15 +0000

Folks,

the FPSM work team published a first draft about a solution and information model for DMM Forwarding Policy Configuration.
The draft should pretty much convey the approach but it's not yet complete.

It would be good to receive some feedback, constructive comments and foster discussion before IETF92 meeting
on this mailing list, so we can address a set of items during the meeting.

marco

A new version of I-D, draft-wt-dmm-fpc-cpdp-00.txt has been successfully submitted by Marco Liebsch and posted to the IETF repository.

Name:                  draft-wt-dmm-fpc-cpdp

Revision:              00

Title:                      Protocol for Forwarding Policy Configuration (FPC) in DMM

Document date:               2015-03-09

Group:                  Individual Submission

Pages:                   26

URL:            http://www.ietf.org/internet-drafts/draft-wt-dmm-fpc-cpdp-00.txt

Status:         https://datatracker.ietf.org/doc/draft-wt-dmm-fpc-cpdp/

Htmlized:       http://tools.ietf.org/html/draft-wt-dmm-fpc-cpdp-00

---

From: <[email-masked]>
Date: Fri, 13 Mar 2015 13:08:11 +0100

Dear Marco and WT,
Thanks for all the work! IMO the draft is quite clearly written and covers many details on messages and attributes for node configuration according to policies - I didn't find missing ones so far ... ;-)
I only have few comments / nits detected so far:
P.3:
These
   requirements are met by various transport network components, such as
   IP switches and routers, though configuration semantics differs
   between them.
=>
These
   requirements are met by various transport network components, such as
   IP switches and routers, though configuration semantics differ
   between them.

P.6:
or multiple DPA(s) according
=>  should this be DPN(s) or is the Data-Plane Anchor (DPA) meant?

P.7:
o  Build, modify or delete logical ports as needed
=> in Fig. 4 only messages for add and delete of ports are listed - modify here refers only to the attributes i.e. properties and rules, right?

p.10:
   o  PRT_ADD - Issued by a Client to add a new logical port at an
      Agent, to which traffic can be directed.
=> AFAIU the port is added at the DPN (where any traffic is directed to), so should it read:
   o  PRT_ADD - Issued by a Client to an Agent to add a new logical port at a
      DPN, to which traffic can be directed. (?)

P.11:
The Agent receiving such message should delete the rules from its
=> The Agent receiving such message should delete the rule from its

p.13:
LMA Control-Plane function (LMA_C), the LMA-C selects a suitable DPN
=> LMA Control-Plane function (LMA-C), the LMA-C selects a suitable DPN

For the Appendix I am too little of a YANG Dr. so I only detected on
P.22:
               container trafic-descriptor {
=>               container traffic-descriptor {

Thanks and best regards - and have a nice weekend
Dirk

From: dmm [mailto:[email-masked]] On Behalf Of Marco Liebsch
Sent: Dienstag, 10. März 2015 13:59
To: [email-masked]
Subject: [DMM] FPSM work team draft

Folks,

marco

Revision:              00

Pages:                   26

---

From: Marco Liebsch <[email-masked]>
Date: Fri, 13 Mar 2015 13:54:24 +0000

Dear Dirk,

thanks a lot for the feedback and the spotted typos.
We'll take them into account for the next revision. Hope we can continue
discussion during f2f meeting in Dallas.

marco

From: [email-masked] [mailto:[email-masked]]
Sent: Freitag, 13. März 2015 13:08
To: Marco Liebsch; [email-masked]
Subject: RE: FPSM work team draft

Dear Marco and WT,

P.6:

P.7:

p.10:

P.11:

p.13:

From: dmm [mailto:[email-masked]] On Behalf Of Marco Liebsch
Sent: Dienstag, 10. März 2015 13:59
To: [email-masked]<mailto:[email-masked]>
Subject: [DMM] FPSM work team draft

Folks,

marco

Revision:              00

Pages:                   26