Subject: [DMM] DMM API

From: Alper Yegin <[email-masked]>
Date: Wed, 25 Mar 2015 21:02:35 +0200

Hello Dapeng and Alex,

I hope you had a chance to digest our responses to your comments and questions about the API work.
If you have any remaining issues, please let us know over the email at your earliest convenience.
It'd be good if you can articulate them in detail.

Thanks.

Alper

---

From: Dapeng Liu <[email-masked]>
Date: Wed, 25 Mar 2015 16:01:45 -0500

Hello Alper,  

I still have the following comments:

1. Regarding the definition of “fixed IP address” in the draft:

  “- Fixed IP Address
This is what standard Mobile IP provides with a Home Address (HoA). The mobile host is configures a HoA from a centrally-located Home Network. Both IP session continuity and IP address reachability are provided to the mobile host with the help of a router in the Home Network (Home Agent, HA). This router acts as an anchor for the IP  
address of the mobile host.”  

If this is equal to HoA, then RFC5014 already cover that. We do not need to repeat it here with another name.

2. Regarding the definition of “sustained IP address” in the draft:

"- Sustained IP Address This type of IP address provides IP session continuity but not IP address reachability. It is achieved by ensuring that the IP address used at the beginning of the session remains usable despite the movement of the mobile host. The IP address may change after the termination of the IP session(s), therefore it does not exhibit persistence. "  
There is no clear dividing line between fixed IP address and sustained IP address. Whether the IP address is used for reachability is not determined by the IP address itself. For example, even when the MN get a HoA, after it moves to another location of the network, it may decide to release current HoA and get another HoA, in this case the "fixed IP address" becomes a "sustained IP address".

Further more, the reachability normally is implemented by domain name instead of IP address. For example, we reach “Google” by its domain name, never by it’s server’s IP address.  

Using temporary private IP address we can also achieve the goal of “reachability”. For example, using dynamic DNS, as shown in  http://hsk.oray.com/ , it can  provide reachability even the host get a private IP address.

3. Regarding the definition of “nomadic IP address”:

“- Nomadic IP Address
This type of IP address provides neither IP session continuity nor IP address reachability. The IP address is obtained from the serving IP gateway and it is not maintained across gateway changes. In other words, the IP address may be released and replaced by a new IP address when the IP gateway changes due to the movement of the mobile  
host.”

Seems this IP address is the IP address that we normally used in most cases. If this is the case, why we need a new name for it?

--  
Dapeng Liu

---

From: Alper Yegin <[email-masked]>
Date: Wed, 25 Mar 2015 23:43:46 +0200

Hello Dapeng,

On Mar 25, 2015, at 11:01 PM, Dapeng Liu wrote:

>    This is what standard Mobile IP provides with a Home Address (HoA).
>    The mobile host is configures a HoA from a centrally-located Home
>    Network.  Both IP session continuity and IP address reachability are
>    provided to the mobile host with the help of a router in the Home
>    Network (Home Agent, HA).  This router acts as an anchor for the IP 

This is not equal to "HoA".
This is equal to "HoA permanently allocated on a HA in the core network"
(as opposed to "HoA temporarily allocated on a HA in the access network")

> "- Sustained IP Address
>    This type of IP address provides IP session continuity but not IP
>    address reachability.  It is achieved by ensuring that the IP address
>    used at the beginning of the session remains usable despite the
>    movement of the mobile host.  The IP address may change after the
>    termination of the IP session(s), therefore it does not exhibit
>    persistence.
> "

If the IP stack on the host releases the IP address, then of course it's not a "fixed IP address". 
Please see the definitions of these terms in the I-D.

> Using temporary private IP address we can also achieve the goal of “reachability”. For example, using dynamic DNS, as shown in  http://hsk.oray.com/ , it can  provide reachability even the host get…

You had said this before, and I had explained it.
Nevertheless, let me recap:
You cannot ensure an ongoing IP flow continues w/o interruption if you simply rely on dynamic DNS. Ongoing flows break even if you update the DNS.
Furthermore, even if you ignore the ongoing flows, also note that DNS clients have a cache, hence a dynamic DNS update cannot be instantaneously reflected on the hosts. 
So, you cannot provide full mobility solution by relying on dynamic DNS.

>    This type of IP address provides neither IP session continuity nor IP
>    address reachability.  The IP address is obtained from the serving IP
>    gateway and it is not maintained across gateway changes.  In other
>    words, the IP address may be released and replaced by a new IP
>    address when the IP gateway changes due to the movement of the mobile 
>    host.”
> 

If you don't name it, how would you refer to it in this context?

Alper

---

From: Dapeng Liu <[email-masked]>
Date: Wed, 25 Mar 2015 17:27:16 -0500

> (as opposed to "HoA temporarily allocated on a HA in the access network")
The draft says: “This is what standard Mobile IP provides with a Home Address (HoA)...”  If it is not equal to HoA, need clarification in the draft.
> So, you cannot provide full mobility solution by relying on dynamic DNS.
The point here is “reachability” instead of “mobility”.  
Further more, even mobile IP may lost some packet during handover.  
> If you don't name it, how would you refer to it in this context?
If the justification of naming IP address as “fixed IP” and “ sustained IP” is not valid, then we may not necessary need a new name for normal IP address.

Dapeng

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 25 Mar 2015 18:18:28 -0500

Hi, Alper,

Sorry for interfering but I have a few points where I agree with Dapeng.

Le 25/03/2015 16:43, Alper Yegin a écrit :
>> If this is equal to HoA, then RFC5014 already cover that. We do not
>> need to repeat it here with another name.
>>
>
>

So that's a HoA, and RFC5014 already covers that, right?

>> There is no clear dividing line between fixed IP address and sustained
>> IP address. Whether the IP address is used for reachability is not
>> determined by the IP address itself. For example, even when the MN get
>> a HoA, after it moves to another location of the network, it may
>> decide to release current HoA and get another HoA, in this case the
>> "fixed IP address" becomes a "sustained IP address".
>>
>
>> Further more, the reachability normally is implemented by domain name
>> instead of IP address. For example, we reach “Google” by its domain
>> name, never by it’s server’s IP address.
>>
>> Using temporary private IP address we can also achieve the goal of
>> “reachability”. For example, using dynamic DNS, as shown in
>> http://hsk.oray.com/ , it can  provide reachability even the host get
>> a private IP address.
>>
>
> You cannot ensure an ongoing IP flow continues w/o interruption if you
> simply rely on dynamic DNS. Ongoing flows break even if you update the DNS.

But Dapeng talks about reachability, not about session continuity.  In 
that sense he's right, no? (DNS updates ensure reachability upon address 
change).

Even I would go as far as to say that _some_ application flows will 
resist to changes in that IP address and get restarted with the new 
address if that DNS update process was performed.

This is because the concept of 'flow' is very much ambiguous.  Very 
rarely a read in packet dump can show 'flows' as we talk commonly about 
them in the DMM discussions.  It is for this reason that there is no 
option in Wireshark that groups packets in 'flows', like a mail reader 
would group messages into 'conversations' or 'threads'.

It is for this reason too that firewall rules trying to be smart and 
identify 'flows' before blocking them very often fail, even if we do 
Deep Packet Inspection.  People always find ways to 'drill' through 
these rules.

> Furthermore, even if you ignore the ongoing flows, also note that DNS
> clients have a cache, hence a dynamic DNS update cannot be
> instantaneously reflected on the hosts.

I can agree to that.  I guess though there may be forced updates on 
these caches, or that the timers can be configured shorter in domains 
supporting mobility.

> So, you cannot provide full mobility solution by relying on dynamic DNS.

We dont know what full mobility is, and DNS updates is a good tool to 
provide reachability and session continuity, in some cases.

Alex

>> Seems this IP address is the IP address that we normally used in most
>> cases. If this is the case, why we need a new name for it?
>>
>
>

---

From: Alper Yegin <[email-masked]>
Date: Thu, 26 Mar 2015 01:54:19 +0200

> The draft says: “This is what standard Mobile IP provides with a Home Address (HoA)...”  If it is not equal to HoA, need clarification in the draft.

Draft says "This is what standard Mobile IP provides with a Home Address (HoA). The mobile host is configures a HoA from a centrally-located Home   Network. "

If this is not clear enough, we can certainly elaborate more on that in the I-D.

> Further more, even mobile IP may lost some packet during handover. 

Not sure if this point has any impact on the discussion.

> If the justification of naming IP address as “fixed IP” and “ sustained IP” is not valid, then we may not necessary need a new name for normal IP address.

I and the WT#1 believe that justification is valid.
If you believe otherwise, please elaborate.

Alper

---

From: Dapeng Liu <[email-masked]>
Date: Wed, 25 Mar 2015 20:32:33 -0500

> If this is not clear enough, we can certainly elaborate more on that in the I-D.
Yes. It needs more elaboration.  
> Not sure if this point has any impact on the discussion.
The point is: in the draft,  whether support “reachability” is the distinction between “fixed IP” and “ sustained IP”, but the truth is any type of IP address can provide “reachability”. So there is no clear dividing line between  “fixed IP” and “ sustained IP” in the definition. That is why the definition of the IP types is not valid.
> If you believe otherwise, please elaborate.

Pls see above comment.

Dapeng

---

From: Alper Yegin <[email-masked]>
Date: Thu, 26 Mar 2015 06:26:09 +0200

>> This is equal to "HoA permanently allocated on a HA in the core network" [1]
>> (as opposed to "HoA temporarily allocated on a HA in the access network") [2]
> 

No. I tried to explain it below, that it's not just "HoA".
[1] provides a fixed IP address,
[2] provides a sustained IP address.

That distinction is not captured when you call it "HoA".

> But Dapeng talks about reachability, not about session continuity.  In that sense he's right, no? (DNS updates ensure reachability upon address change).

it's not "IP address" reachability. When the host releases its IP address, that IP address is no longer reachable. 

> 
> Even I would go as far as to say that _some_ application flows will resist to changes in that IP address and get restarted with the new address if that DNS update process was performed.
> 
> This is because the concept of 'flow' is very much ambiguous.  Very rarely a read in packet dump can show 'flows' as we talk commonly about them in the DMM discussions.  It is for this reason that there is no option in Wireshark that groups packets in 'flows', like a mail reader would group messages into 'conversations' or 'threads'.
> 
> It is for this reason too that firewall rules trying to be smart and identify 'flows' before blocking them very often fail, even if we do Deep Packet Inspection.  People always find ways to 'drill' through these rules.
> 
> I can agree to that.  I guess though there may be forced updates on these caches, or that the timers can be configured shorter in domains supporting mobility.

Nope, not practical. You need to enforce that on all possible hosts that may be in comm. with the MN across the Internet. Can't do that.
> We dont know what full mobility is, and DNS updates is a good tool to provide reachability and session continuity, in some cases.
> 

Full mobility is what you get out of Mobile IP.
You cannot achieve the same effect using dynamic DNS.

Alper

---

From: Alper Yegin <[email-masked]>
Date: Thu, 26 Mar 2015 06:42:33 +0200

> The point is: in the draft,  whether support “reachability” is the distinction between “fixed IP” and “ sustained IP”, but the truth is any type of IP address can provide “reachability”. So there i…

"IP address reachability" is about ability to reach the host at a specific "IP address" even when the host changes its point of attachment.
You seem to interpret it as if it said "IP reachability" (ability to reach the host using IP protocol), but that's not the case.

That term is already defined in the I-D:

   IP address reachability: The ability to maintain the same IP address
   for an extended period of time.  The IP address stays the same across
   independent IP sessions, and even in the absence of any IP session.
   The IP address may be published in a long-term registry (e.g., DNS),
   and it is made available for serving incoming (e.g., TCP)
   connections.  IP address reachability is essential for mobile hosts
   to use specific/published IP addresses.

---

From: Dapeng Liu <[email-masked]>
Date: Thu, 26 Mar 2015 12:52:04 -0500

> You seem to interpret it as if it said "IP reachability" (ability to reach the host using IP protocol), but that's not the case.
No, I guess we have the same understanding regarding  what is “ reachability” here and still my question is: if we use “ reachability” as characteristic to distinguish  “fixed IP address” and “sustained IP  address”, there will be no clear dividing line between them.

Dapeng
  
> IP address reachability: The ability to maintain the same IP address for an extended period of time. The IP address stays the same across independent IP sessions, and even in the absence of any IP session. The IP address may be published in a long-term registry (e.g., DNS), and it is made available for serving incoming (e.g., TCP) connections. IP address reachability is essential for mobile hosts to use specific/published IP addresses.
>  
>

---

From: Dapeng Liu <[email-masked]>
Date: Thu, 26 Mar 2015 12:52:54 -0500

Dapeng