Subject: [DMM] Re： DMM API

From: "Weixinpeng (Jackie)" <[email-masked]>
Date: Thu, 26 Mar 2015 17:39:10 +0000

Hi Alper

My understanding about the reason why there needs to define serval types of IP prefixes is that,  if the application itself could deal with the change of IP address, i.e. the application itself could deal with session continuty in case of IP address change, so the host would choose a normadic address otherwise the host should choose a sustained address.

But my question is that, if the application could deal with session continuty itself, does that mean the application is willing to change its IP address? Because even though a new address might bring some kinds of benefit, but it will also

bring additional cost for application to deal with IP address change.

Thanks.

Xinpeng

________________________________
发件人: dmm [[email-masked]] 代表 Dapeng Liu [[email-masked]]
发送时间: 2015年3月26日 5:01
收件人: Alper Yegin
抄送: [email-masked]
主题: [DMM] 回复： DMM API

Hello Alper,

I still have the following comments:

1. Regarding the definition of “fixed IP address” in the draft:

  “- Fixed IP Address

   This is what standard Mobile IP provides with a Home Address (HoA).
   The mobile host is configures a HoA from a centrally-located Home
   Network.  Both IP session continuity and IP address reachability are
   provided to the mobile host with the help of a router in the Home
   Network (Home Agent, HA).  This router acts as an anchor for the IP

address of the mobile host.”

If this is equal to HoA, then RFC5014 already cover that. We do not need to repeat it here with another name.

2. Regarding the definition of “sustained IP address” in the draft:

"- Sustained IP Address

   This type of IP address provides IP session continuity but not IP
   address reachability.  It is achieved by ensuring that the IP address
   used at the beginning of the session remains usable despite the
   movement of the mobile host.  The IP address may change after the
   termination of the IP session(s), therefore it does not exhibit
   persistence.
"

There is no clear dividing line between fixed IP address and sustained IP address. Whether the IP address is used for reachability is not determined by the IP address itself. For example, even when the MN get a HoA, after it moves to another location of the network, it may decide to release current HoA and get another HoA, in this case the "fixed IP address" becomes a "sustained IP address".

Further more, the reachability normally is implemented by domain name instead of IP address. For example, we reach “Google” by its domain name, never by it’s server’s IP address.

Using temporary private IP address we can also achieve the goal of “reachability”. For example, using dynamic DNS, as shown in  http://hsk.oray.com/ , it can  provide reachability even the host get a private IP address.

3. Regarding the definition of “nomadic IP address”:

“- Nomadic IP Address

   This type of IP address provides neither IP session continuity nor IP
   address reachability.  The IP address is obtained from the serving IP
   gateway and it is not maintained across gateway changes.  In other
   words, the IP address may be released and replaced by a new IP
   address when the IP gateway changes due to the movement of the mobile

host.”

Seems this IP address is the IP address that we normally used in most cases. If this is the case, why we need a new name for it?

--
Dapeng Liu

在 2015年3月25日 星期三，下午2:02，Alper Yegin 写道：

Hello Dapeng and Alex,

I hope you had a chance to digest our responses to your comments and questions about the API work.
If you have any remaining issues, please let us know over the email at your earliest convenience.
It'd be good if you can articulate them in detail.

Thanks.

Alper

---

From: Alper Yegin <[email-masked]>
Date: Thu, 26 Mar 2015 20:13:22 +0200

Hi Xinpeng,

If your app knows how to deal with IP address changes, then it's better if we give it a chance to do so, because (as the I-D explains):

   Achieving IP session continuity and IP address reachability by using
   Mobile IP incurs some cost.  Mobile IP protocol forces the mobile
   host's IP traffic to traverse a centrally-located router (Home Agent,
   HA), which incurs additional transmission latency and use of
   additional network resources, adds to the network CAPEX and OPEX, and
   decreases the reliability of the network due to the introduction of a
   single point of failure [I-D.ietf-dmm-requirements].  Therefore, IP
   session continuity and IP address reachability should be be provided
   only when needed.

Alper

---

From: "Weixinpeng (Jackie)" <[email-masked]>
Date: Thu, 26 Mar 2015 20:42:38 +0000

Hi Alper,

For an application developer, if there are three kinds of addresses to use which are "Fixed IP Address", "Sustained IP Address" and "Nomadic IP Address",

then I believe the developer would always wants to use the "Fixed IP address", rather than the other ones. Because even though the application could cope with IP address

change, but the IP address change is not what the application want.

-Xinpeng

________________________________
发件人: Alper Yegin [[email-masked]]
发送时间: 2015年3月27日 2:13
收件人: Weixinpeng (Jackie)
抄送: Dapeng Liu; [email-masked]
主题: Re: Re： DMM API

Hi Xinpeng,

Alper

Hi Alper

Xinpeng

________________________________
发件人: dmm [[email-masked]<mailto:[email-masked]>] 代表 Dapeng Liu [[email-masked]<mailto:[email-masked]>]
发送时间: 2015年3月26日 5:01
收件人: Alper Yegin
抄送: [email-masked]<mailto:[email-masked]>
主题: [DMM] 回复： DMM API

Hello Alper,

  “- Fixed IP Address

"- Sustained IP Address

“- Nomadic IP Address

host.”

--
Dapeng Liu

Thanks.

Alper

---

From: Alper Yegin <[email-masked]>
Date: Thu, 26 Mar 2015 23:26:36 +0200

Xinpeng,

I'll give you a counter example to what you are claiming.

Imagine you are developing a chat (IM) client.
Because your app will be running on terminals that'd connect to both cellular and WiFi networks, you don't have any other option but to implement app-layer mobility management (because otherwise your chat sessions will break when the terminal moves in and out of WiFi hotspots).

Now, given that you already implemented app-layer mobility, it's to your advantage to use it even when you are on cellular network, if there was a way to tell the network to provide you a nomadic IP address (as opposed to fixed/mobile IP address that it'd normally do). Because that way, you ensure your IP packets take the shortest path, which reduces the end2end latency.

Besides, we also expect that the mobile network operators will promote "proper use" of these flags, because that ensures efficient use of their network resources. Letting an app use a fixed IP address when it could very well use a nomadic IP address is waste of network resources (back hauling, PGW capacity, etc.)

As a future thing, we can even envision mobile operators charging differently based on the type of traffic -- after all each type is consuming different amounts of network resources. 

Alper

---

From: "Weixinpeng (Jackie)" <[email-masked]>
Date: Thu, 26 Mar 2015 22:17:28 +0000

Alper,

Thanks for your clarification. And there are some of my replies inline.

Thanks.

-Xinpeng

发送时间: 2015年3月27日 5:26

Xinpeng,

[Wei] My understanding abouth the reason why application developer implements application layer support is that the host's IP address might change when their application is running, so they **have to** provide

mechanism to cope with the situation, but it's not their willing to change the IP address. Additional, The application developer might be a bit of confused with the name of "Nomadic address", theywould just think the nomadic address is a kind of address that would be changed.

[Wei] The application layer mobility management and the redundant routing path both bring additional costes, but its hard for application developers to have an idea which one has a more lower cost.

[Wei] Agree that network operator wants to reduce their network cost, but we cannot make sure the application developer will becare about too much for the operators...

Alper

Hi Alper,

-Xinpeng

________________________________
发件人: Alper Yegin [[email-masked]<mailto:[email-masked]>]
发送时间: 2015年3月27日 2:13
收件人: Weixinpeng (Jackie)
抄送: Dapeng Liu; [email-masked]<mailto:[email-masked]>
主题: Re: Re： DMM API

Hi Xinpeng,

Alper

Hi Alper

Xinpeng

Hello Alper,

  “- Fixed IP Address

"- Sustained IP Address

“- Nomadic IP Address

host.”

--
Dapeng Liu

Thanks.

Alper

---

From: Alper Yegin <[email-masked]>
Date: Fri, 27 Mar 2015 01:46:16 +0200

Hi Xinpeng,

> mechanism to cope with the situation,

That's what I'm saying too.

> but it's not their willing to change the IP address.

Sure. My point is, they know how to deal with it. And the code already handles it. So, what we are suggesting does not cause any new code development from that perspective.

> Additional, The application developer might be a bit of confused with the name of "Nomadic address", theywould just think the nomadic address is a kind of address that would be changed.
> 

Well, if you are not liking the name, please suggest a better one. We are obviously open to improvements.

> [Wei] The application layer mobility management and the redundant routing path both bring additional costes, but its hard for application developers to have an idea which one has a more lower cost.

For the IM app developer, the gain is the reduced latency.
What is the cost?

> [Wei] Agree that network operator wants to reduce their network cost, but we cannot make sure the application developer will becare about too much for the operators...

Operators know how to make the app developers care about things that the operators care.

Alper