Subject: Re: [DMM] New Version Notification for draft-sijeon-dmm-use-cases-api-source-00.txt

From: Alper Yegin <[email-masked]>
Date: Wed, 4 Mar 2015 22:12:48 +0200

Hello Seil,

As I understand, this new flag helps apps tell the IP stack to configure a new/additional IP address even if the IP stack is already configured with there requested type address.

It'd be good to spell this out in the I-D.
And also, it'd be good to explain why this might be needed, and when should the apps use this flag.

Alper

On Feb 26, 2015, at 6:36 PM, Seil Jeon wrote:

> Hi DMM folks,
> 
> We submitted a new draft that present specified use cases based on the on-demand draft we are based on for further steps.
> As we discussed and agreed in the previous audio conference, checking and investigating use cases with the three types of IP addresses, i.e. fixed, sustained, nomadic IP addresses. Hope to start broad discussions on this while trying to extend the existing address configuration mechanisms. Grasping and identifying more definitive requirements based on the IP address type will be easy and make clear our ways to go, such as what to extend and how.
> 
> With the discussion, any kinds of comments on it are welcomed.
> 
> Regards,
> 
> Seil Jeon, Ph.D
> 
> Advanced Telecommunications and Networks Group (ATNoG) - http://atnog.av.it.pt
> Instituto de Telecomunicacoes, Aveiro, Portugal - http://www.it.pt
> 
> 
> Seil Jeon, Ph.D
> 
> Advanced Telecommunications and Networks Group (ATNoG) - http://atnog.av.it.pt
> Instituto de Telecomunicacoes, Aveiro, Portugal - http://www.it.pt
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Thursday, February 26, 2015 4:23 PM
> To: Young-Han Kim; Sergio Figueiredo; Seil Jeon;
> Subject: New Version Notification for draft-sijeon-dmm-use-cases-api-source-00.txt
> 
> 
> A new version of I-D, draft-sijeon-dmm-use-cases-api-source-00.txt
> has been successfully submitted by Seil Jeon and posted to the IETF repository.
> 
> Name:		draft-sijeon-dmm-use-cases-api-source
> Revision:	00
> Title:		Use Cases and API Extension for Source IP address selection
> Document date:	2015-02-26
> Group:		Individual Submission
> Pages:		7
> URL:            http://www.ietf.org/internet-drafts/draft-sijeon-dmm-use-cases-api-source-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-sijeon-dmm-use-cases-api-source/
> Htmlized:       http://tools.ietf.org/html/draft-sijeon-dmm-use-cases-api-source-00
> 
> 
> Abstract:
>   This draft specifies and analyzes the expected cases regarding the
>   selection of a proper source IP address and address type based on
>   the application features over a distributed mobility management
>   (DMM) network. It also provides available selection methods in the
>   specified scenarios.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> 
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm

---

From: "Seil Jeon" <[email-masked]>
Date: Wed, 4 Mar 2015 21:18:44 -0000

Hi Alper,

Thanks for your interest and valuable comment.

Actually, the need of the proposed flag is being explained in Section 2.2.3
Case 2.
And the use of this flag depends on such as session duration and sensitivity
of IP address change required by apps. This will be considered in a next
update.

Regards,

Seil Jeon

-----Original Message-----
From: Alper Yegin [mailto:[email-masked]] 
Sent: Wednesday, March 04, 2015 8:13 PM
To: Seil Jeon
Cc: [email-masked]
Subject: Re: [DMM] New Version Notification for
draft-sijeon-dmm-use-cases-api-source-00.txt

Hello Seil,

As I understand, this new flag helps apps tell the IP stack to configure a
new/additional IP address even if the IP stack is already configured with
there requested type address.

It'd be good to spell this out in the I-D.
And also, it'd be good to explain why this might be needed, and when should
the apps use this flag.

Alper

On Feb 26, 2015, at 6:36 PM, Seil Jeon wrote:

> Hi DMM folks,
> 
> We submitted a new draft that present specified use cases based on the
on-demand draft we are based on for further steps.
> As we discussed and agreed in the previous audio conference, checking and
investigating use cases with the three types of IP addresses, i.e. fixed,
sustained, nomadic IP addresses. Hope to start broad discussions on this
while trying to extend the existing address configuration mechanisms.
Grasping and identifying more definitive requirements based on the IP
address type will be easy and make clear our ways to go, such as what to
extend and how.
> Advanced Telecommunications and Networks Group (ATNoG) - 
> http://atnog.av.it.pt Instituto de Telecomunicacoes, Aveiro, Portugal 
> - http://www.it.pt
> 
>
> Subject: New Version Notification for 
> draft-sijeon-dmm-use-cases-api-source-00.txt
> 
> 
> URL:
http://www.ietf.org/internet-drafts/draft-sijeon-dmm-use-cases-api-source-00
.txt
> Status:
https://datatracker.ietf.org/doc/draft-sijeon-dmm-use-cases-api-source/
> Htmlized:
http://tools.ietf.org/html/draft-sijeon-dmm-use-cases-api-source-00
> Please note that it may take a couple of minutes from the time of
submission until the htmlized version and diff are available at
tools.ietf.org.