Subject: [DMM] Regarding APN Usecase in Mobile Core

From: Lizhenbin <[email-masked]>
Date: Mon, 18 Jan 2021 13:25:33 +0000

Hi APNers and DMMers,
I remember that in the mobile core scenarios the GTP-u tunnel can be set up according to the user and application requirements, but I do not understand the details. I think when the packet tunneled by GTP-u traverses the APN-based transport network, it may be mapped to the corresponding tunnel according to the user and application requirements to implement the uniform service. If you are familiar with the principle of GTP-u in the mobile core, please help provide some details.

Best Regards,
Zhenbin (Robin)

---

From: Uma Chunduri <[email-masked]>
Date: Mon, 18 Jan 2021 11:16:52 -0800

Hi Robin,

In-line..

Cheers!
--
Uma C.

On Mon, Jan 18, 2021 at 5:25 AM Lizhenbin <[email-masked]> wrote:

> Hi APNers and DMMers,
>
> I remember that in the mobile core scenarios the GTP-u tunnel can be set
> up according to the user and application requirements, but I do not
> understand the details.
>

[Uma]: Obviously, the best reference for GTP-U is TS 29.281. However, uou
should look into
https://datatracker.ietf.org/doc/draft-ietf-dmm-5g-uplane-analysis/ where
lot more details and other references related this topic was analyzed
(primarily started after/during REL-15, when  any other use plane other
than GTP-U is worthwhile is debated for 5G N9 interface).

> I think when the packet tunneled by GTP-u traverses the APN-based
> transport network, it may be mapped to the corresponding tunnel according
> to the user and application requirements to implement the uniform service.
> If you are familiar with the principle of GTP-u in the mobile core, please
> help provide some details.
>

>
>
>
> Best Regards,
>
> Zhenbin (Robin)
>
>
>
>
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm
>

---

From: David Lake <[email-masked]>
Date: Mon, 18 Jan 2021 20:10:00 +0000

The APN provides the linkage between the application profile and the radio bearers.  GTP-u is manner by which the traffic is tunnelled to the anchor point and you MAY end up with different end points for each of the GTP bearers.

Traffic at both the UE and the PGW (in LTE - UPF in 5G) are directed to the correct APN by a Traffic Flow Template (TFT).  This is to ensure that traffic goes across both the correct radio bearer and is marked correctly in the IP network.

Users will often be unaware of multiple APNs on their UE; the most common hidden APN is one for VoLTE which, with the use of the TFT, will ensure that the VoIP frames (media) are put across the QCI 9 radio bearer and into the correct class on the IP network.  QCI 9 maps to a specific numerology on the Air Interface so that quality can be maintained for the voice call.

In theory, multiple APNs all with their own TFT rules and potentially multiple GTP-u tunnels could be used but this is very rarely done.

David

From: Apn <[email-masked]> On Behalf Of Uma Chunduri
Sent: 18 January 2021 19:17
To: Lizhenbin <[email-masked]>
Cc: [email-masked]; dmm <[email-masked]>
Subject: Re: [Apn] [DMM] Regarding APN Usecase in Mobile Core

Hi Robin,

In-line..

Cheers!
--
Uma C.

On Mon, Jan 18, 2021 at 5:25 AM Lizhenbin <[email-masked]<mailto:[email-masked]>> wrote:
Hi APNers and DMMers,
I remember that in the mobile core scenarios the GTP-u tunnel can be set up according to the user and application requirements, but I do not understand the details.

[Uma]: Obviously, the best reference for GTP-U is TS 29.281. However, uou should look into https://datatracker.ietf.org/doc/draft-ietf-dmm-5g-uplane-analysis/<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-dmm-5g-uplane-analysis%2F&data=04%7C01%7Cd.lake%40surrey.ac.uk%7C984c8fa55bbf4ea5b98908d8bbe5aa2d%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637465942368442430%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=namC6OofWdMQvTEjFwNkZT0ornR2gx1Q%2BV8SXxIHUis%3D&reserved=0> where lot more details and other references related this topic was analyzed (primarily started after/during REL-15, when  any other use plane other than GTP-U is worthwhile is debated for 5G N9 interface).

I think when the packet tunneled by GTP-u traverses the APN-based transport network, it may be mapped to the corresponding tunnel according to the user and application requirements to implement the uniform service. If you are familiar with the principle of GTP-u in the mobile core, please help provide some details.

Best Regards,
Zhenbin (Robin)

_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmm<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&data=04%7C01%7Cd.lake%40surrey.ac.uk%7C984c8fa55bbf4ea5b98908d8bbe5aa2d%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637465942368452424%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=00LmTEJXUJZfwFAMcs5abdCXTBvrrVSEMFeykW175u8%3D&reserved=0>

---

From: Uma Chunduri <[email-masked]>
Date: Mon, 18 Jan 2021 12:25:47 -0800

Hi David,

Many excellent points below w.r.t GTP-u and the Access Point Name (APN)
which defines the network path for all cellular data connectivity.

However, I presume Robin was referring to a different APN -
https://datatracker.ietf.org/wg/apn/about/

--
Uma C.

On Mon, Jan 18, 2021 at 12:10 PM David Lake <[email-masked]> wrote:

> The APN provides the linkage between the application profile and the radio
> bearers.  GTP-u is manner by which the traffic is tunnelled to the anchor
> point and you MAY end up with different end points for each of the GTP
> bearers.
>
>
>
> Traffic at both the UE and the PGW (in LTE – UPF in 5G) are directed to
> the correct APN by a Traffic Flow Template (TFT).  This is to ensure that
> traffic goes across both the correct radio bearer and is marked correctly
> in the IP network.
>
>
>
> Users will often be unaware of multiple APNs on their UE; the most common
> hidden APN is one for VoLTE which, with the use of the TFT, will ensure
> that the VoIP frames (media) are put across the QCI 9 radio bearer and into
> the correct class on the IP network.  QCI 9 maps to a specific numerology
> on the Air Interface so that quality can be maintained for the voice call.
>
>
>
> In theory, multiple APNs all with their own TFT rules and potentially
> multiple GTP-u tunnels could be used but this is very rarely done.
>
>
>
> David
>
>
>
> *From:* Apn <[email-masked]> *On Behalf Of *Uma Chunduri
> *Sent:* 18 January 2021 19:17
> *To:* Lizhenbin <[email-masked]>
> *Cc:* [email-masked]; dmm <[email-masked]>
> *Subject:* Re: [Apn] [DMM] Regarding APN Usecase in Mobile Core
>
>
>
> Hi Robin,
>
>
>
> In-line..
>
>
>
> Cheers!
> --
>
> Uma C.
>
>
>
> https://datatracker.ietf.org/doc/draft-ietf-dmm-5g-uplane-analysis/
> <https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-dmm-5g-uplane-analysis%2F&data=04%7C01%7Cd.lake%40surrey.ac.uk%7C984c8fa55bbf4ea5b98908d8bbe5aa2d%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637465942368442430%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=namC6OofWdMQvTEjFwNkZT0ornR2gx1Q%2BV8SXxIHUis%3D&reserved=0>
> where lot more details and other references related this topic was analyzed
> <https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&data=04%7C01%7Cd.lake%40surrey.ac.uk%7C984c8fa55bbf4ea5b98908d8bbe5aa2d%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637465942368452424%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=00LmTEJXUJZfwFAMcs5abdCXTBvrrVSEMFeykW175u8%3D&reserved=0>
>
>

---

From: David Lake <[email-masked]>
Date: Mon, 18 Jan 2021 20:27:21 +0000

Hi

EEK!   This could be a problem then if we have TWO definitions of APN....

David

From: Uma Chunduri <[email-masked]>
Sent: 18 January 2021 20:26
To: Lake, David (PG/R - Elec Electronic Eng) <[email-masked]>
Cc: Lizhenbin <[email-masked]>; [email-masked]; dmm <[email-masked]>
Subject: Re: [Apn] [DMM] Regarding APN Usecase in Mobile Core

Hi David,

Many excellent points below w.r.t GTP-u and the Access Point Name (APN) which defines the network path for all cellular data connectivity.

However, I presume Robin was referring to a different APN - https://datatracker.ietf.org/wg/apn/about/<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fwg%2Fapn%2Fabout%2F&data=04%7C01%7Cd.lake%40surrey.ac.uk%7C607b41fb513c48c361f908d8bbef44ae%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637465983616671466%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=i%2Fou%2ByUAzdg5kIL1N2sdXlCLM41q%2BWSnBc9lymZbgNo%3D&reserved=0>

--
Uma C.

On Mon, Jan 18, 2021 at 12:10 PM David Lake <[email-masked]<mailto:[email-masked]>> wrote:
The APN provides the linkage between the application profile and the radio bearers.  GTP-u is manner by which the traffic is tunnelled to the anchor point and you MAY end up with different end points for each of the GTP bearers.

David

From: Apn <[email-masked]<mailto:[email-masked]>> On Behalf Of Uma Chunduri
Sent: 18 January 2021 19:17
To: Lizhenbin <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; dmm <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Apn] [DMM] Regarding APN Usecase in Mobile Core

Hi Robin,

In-line..

Cheers!
--
Uma C.

[Uma]: Obviously, the best reference for GTP-U is TS 29.281. However, uou should look into https://datatracker.ietf.org/doc/draft-ietf-dmm-5g-uplane-analysis/<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-dmm-5g-uplane-analysis%2F&data=04%7C01%7Cd.lake%40surrey.ac.uk%7C607b41fb513c48c361f908d8bbef44ae%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637465983616671466%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=d1al4%2Fco3GeSDbG5EMXSZU7q35vFm%2BFv5sA4WnzTpos%3D&reserved=0> where lot more details and other references related this topic was analyzed (primarily started after/during REL-15, when  any other use plane other than GTP-U is worthwhile is debated for 5G N9 interface).

Best Regards,
Zhenbin (Robin)

_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmm<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&data=04%7C01%7Cd.lake%40surrey.ac.uk%7C607b41fb513c48c361f908d8bbef44ae%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637465983616681466%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Rr%2FLGzBbK%2FK0qdUeDoizGiWzS7LWWHIxsBodhu6ScLI%3D&reserved=0>

---

From: Uma Chunduri <[email-masked]>
Date: Mon, 18 Jan 2021 12:34:40 -0800

Indeed & it's better to disambiguate sooner if APN@IETF folks are seeking
to work with cellular domain in general.

--
Uma C.

On Mon, Jan 18, 2021 at 12:27 PM David Lake <[email-masked]> wrote:

> Hi
>
>
>
> EEK!   This could be a problem then if we have TWO definitions of APN….
>
>
>
> David
>
>
>
> *From:* Uma Chunduri <[email-masked]>
> *Sent:* 18 January 2021 20:26
> *To:* Lake, David (PG/R - Elec Electronic Eng) <[email-masked]>
> *Cc:* Lizhenbin <[email-masked]>; [email-masked]; dmm <[email-masked]>
> <https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fwg%2Fapn%2Fabout%2F&data=04%7C01%7Cd.lake%40surrey.ac.uk%7C607b41fb513c48c361f908d8bbef44ae%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637465983616671466%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=i%2Fou%2ByUAzdg5kIL1N2sdXlCLM41q%2BWSnBc9lymZbgNo%3D&reserved=0>
>
>
>
>
> --
>
> Uma C.
>
>
>
> <https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-dmm-5g-uplane-analysis%2F&data=04%7C01%7Cd.lake%40surrey.ac.uk%7C607b41fb513c48c361f908d8bbef44ae%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637465983616671466%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=d1al4%2Fco3GeSDbG5EMXSZU7q35vFm%2BFv5sA4WnzTpos%3D&reserved=0>
> <https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&data=04%7C01%7Cd.lake%40surrey.ac.uk%7C607b41fb513c48c361f908d8bbef44ae%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637465983616681466%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Rr%2FLGzBbK%2FK0qdUeDoizGiWzS7LWWHIxsBodhu6ScLI%3D&reserved=0>
>
>

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Thu, 21 Jan 2021 02:23:20 +0000

Hi Uma and all,

I have read the document and got a few questions:
In my understanding, in the UPF where traffic policy is enforced, the fine-granularity services are provided. Then what fields in the GTP-u encapsulation indicates the traffic's service requirements? When a GTP-u tunnel goes into a SRv6 policy, according to which fields in the GTP-u encapsulation the DSCP is generated? We know that there are parameters such as 5QI/QCI and QFI, whether they are associated with a GTP-u tunnel?

Best
Xuesong
From: Apn [mailto:[email-masked]] On Behalf Of Uma Chunduri
Sent: Tuesday, January 19, 2021 3:17 AM
To: Lizhenbin <[email-masked]>
Cc: [email-masked]; dmm <[email-masked]>
Subject: Re: [Apn] [DMM] Regarding APN Usecase in Mobile Core

Hi Robin,

In-line..

Cheers!
--
Uma C.

[Uma]: Obviously, the best reference for GTP-U is TS 29.281. However, uou should look into https://datatracker.ietf.org/doc/draft-ietf-dmm-5g-uplane-analysis/ where lot more details and other references related this topic was analyzed (primarily started after/during REL-15, when  any other use plane other than GTP-U is worthwhile is debated for 5G N9 interface).

Best Regards,
Zhenbin (Robin)

---

From: Kaippallimalil John <[email-masked]>
Date: Thu, 21 Jan 2021 21:25:09 +0000

Hi Xuesong,

Traffic policy for subscribers is managed per PDU session at the UPF (and gNB).
GTP-u does provide encapsulation between the end points, but its control fields are meant for conveying control semantics between the GTP endpoints: they were not intended for IP transport/ traffic underlays. 5QI/QCI etc are in the GTP extension header which may not be ideal to lookup to classify each packet in the transport network.

The entity that classifies data packets (upstream at gNB and downstream at UPF-PSA) also inserts the DSCP for that GTP packet. The classification is based on subscriber aspects but may also on be based on its content (e.g., using DPI).

Best Regards,
John

From: dmm <[email-masked]> On Behalf Of Gengxuesong (Geng Xuesong)
Sent: Wednesday, January 20, 2021 8:23 PM
To: Uma Chunduri <[email-masked]>; Lizhenbin <[email-masked]>
Cc: [email-masked]; dmm <[email-masked]>
Subject: Re: [DMM] [Apn] Regarding APN Usecase in Mobile Core

Hi Uma and all,

Best
Xuesong

Hi Robin,

In-line..

Cheers!
--
Uma C.

[Uma]: Obviously, the best reference for GTP-U is TS 29.281. However, uou should look into https://datatracker.ietf.org/doc/draft-ietf-dmm-5g-uplane-analysis/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-dmm-5g-uplane-analysis%2F&data=04%7C01%7Cjohn.kaippallimalil%40futurewei.com%7C77632db844b34a8e561108d8bdb38cb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637467926158632424%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=5nVGUJhkHBn7FWHUCFPC4lGhwr6lBqtIWNyY1o0dxsg%3D&reserved=0> where lot more details and other references related this topic was analyzed (primarily started after/during REL-15, when  any other use plane other than GTP-U is worthwhile is debated for 5G N9 interface).

Best Regards,
Zhenbin (Robin)

_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmm<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&data=04%7C01%7Cjohn.kaippallimalil%40futurewei.com%7C77632db844b34a8e561108d8bdb38cb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637467926158632424%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=oHJnGPO3hUL9xPkObVLsJ5S1JnwGOF6IeJrLADLrTVA%3D&reserved=0>

---

From: Sridhar Bhaskaran <[email-masked]>
Date: Fri, 22 Jan 2021 10:09:19 +0530

Hi Xuesong,

In addition to what John said, in 3GPP networks there is one GTP-u tunnel
per bearer (in case of 4G) and one GTP-u tunnel per PDU session (in case of
5G).

One UE (user equipment - i.e mobile device) may have multiple PDU sessions
and hence in the network there may be more than one tunnel for a UE. The
scope of GTP-u tunnel is from UPF to gNB only. GTP-u does not go all the
way upto UE. The GTP-u header has a field called "TEID" (tunnel endpoint
identifier). The TEID in the header identifies a context in UPF and gNB.
The context gets established through signalling plane. The context provides
information on the QoS to be provided for the bearer,  PDCP ciphering keys
applicable for the bearer context etc.,. If there are a million UE that are
getting connected to a UPF, there could be few million GTP-u tunnels
(TEID).

In summary:
1. The 5QI / QFI marking in the GTP-u extension header provides a lookup
for the general QoS characteristic applicable for that 5QI
2. TEID in the GTP-u header provides a lookup for UE and bearer specific
contextual information for any differentiated treatment.

Regards
Sridhar

On Fri, Jan 22, 2021 at 2:55 AM Kaippallimalil John <
[email-masked]> wrote:

> GTP-u does provide encapsulation between the end points, but its control
> fields are meant for conveying control semantics between the GTP endpoints:
> they were not intended for IP transport/ traffic underlays. 5QI/QCI etc are
> in the GTP extension header which may not be ideal to lookup to classify
> each packet in the transport network.
>
>
>
> The entity that classifies data packets (upstream at gNB and downstream at
> UPF-PSA) also inserts the DSCP for that GTP packet. The classification is
> based on subscriber aspects but may also on be based on its content (e.g.,
> using DPI).
>
>
>
> Best Regards,
>
> John
>
>
>
>
>
> *From:* dmm <[email-masked]> *On Behalf Of *Gengxuesong (Geng
> Xuesong)
> *Sent:* Wednesday, January 20, 2021 8:23 PM
> *To:* Uma Chunduri <[email-masked]>; Lizhenbin <[email-masked]>
> *Subject:* Re: [DMM] [Apn] Regarding APN Usecase in Mobile Core
>
>
>
> Hi Uma and all,
>
>
>
> In my understanding, in the UPF where traffic policy is enforced, the
> fine-granularity services are provided. Then what fields in the GTP-u
> encapsulation indicates the traffic's service requirements? When a GTP-u
> tunnel goes into a SRv6 policy, according to which fields in the GTP-u
> encapsulation the DSCP is generated? We know that there are parameters such
> as 5QI/QCI and QFI, whether they are associated with a GTP-u tunnel?
>
>
>
> Best
>
> Xuesong
>
> *From:* Apn [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Uma Chunduri
> *Sent:* Tuesday, January 19, 2021 3:17 AM
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-dmm-5g-uplane-analysis%2F&data=04%7C01%7Cjohn.kaippallimalil%40futurewei.com%7C77632db844b34a8e561108d8bdb38cb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637467926158632424%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=5nVGUJhkHBn7FWHUCFPC4lGhwr6lBqtIWNyY1o0dxsg%3D&reserved=0>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&data=04%7C01%7Cjohn.kaippallimalil%40futurewei.com%7C77632db844b34a8e561108d8bdb38cb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637467926158632424%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=oHJnGPO3hUL9xPkObVLsJ5S1JnwGOF6IeJrLADLrTVA%3D&reserved=0>
>

-- 
 o__
 _>  /__
(_) \(_)... Burn fat not fuel - Bike along to a healthier life and cleaner
world! :)

Sridhar Bhaskaran

---

From: David Lake <[email-masked]>
Date: Fri, 22 Jan 2021 08:15:24 +0000

Adding to this.

The various radio bearers will be established based on APN (that is the 3GPP APN, not this one) and there will be several parallel paths between UE and eNB.

The Traffic Flow Template is installed in the UE on EPS Attach and effectively gives "rules" to the UE as to which bearer traffic should be sent on.   That match is primarily on IP 5-tuple.

This is mapped at the eNB to the appropriate GTP tunnel so that QoS can be maintained across the air-interface and the packet core.

https://www.sharetechnote.com/html/Handbook_LTE_TFT.html

A common use for this is for media in VoLTE which is placed into a GBR radio bearer and then passed across a GTP tunnel with a matching set of QoS treatments.  The VoIP traffic is "steered" into the VoLTE APN at the UE by the TFT and then placed into the appropriate GTP tunnel by the eNB.

The same may be translated into 5G which really is no different in terms of protocol and attach architecture from 4G.

David

From: Apn <[email-masked]> On Behalf Of Sridhar Bhaskaran
Sent: 22 January 2021 04:39
To: Kaippallimalil John <[email-masked]>
Cc: [email-masked]; Gengxuesong (Geng Xuesong) <[email-masked]>; Uma Chunduri <[email-masked]>; Lizhenbin <[email-masked]>; dmm <[email-masked]>
Subject: Re: [Apn] [DMM] Regarding APN Usecase in Mobile Core

Hi Xuesong,

In addition to what John said, in 3GPP networks there is one GTP-u tunnel per bearer (in case of 4G) and one GTP-u tunnel per PDU session (in case of 5G).

One UE (user equipment - i.e mobile device) may have multiple PDU sessions and hence in the network there may be more than one tunnel for a UE. The scope of GTP-u tunnel is from UPF to gNB only. GTP-u does not go all the way upto UE. The GTP-u header has a field called "TEID" (tunnel endpoint identifier). The TEID in the header identifies a context in UPF and gNB. The context gets established through signalling plane. The context provides information on the QoS to be provided for the bearer,  PDCP ciphering keys applicable for the bearer context etc.,. If there are a million UE that are getting connected to a UPF, there could be few million GTP-u tunnels (TEID).

In summary:
1. The 5QI / QFI marking in the GTP-u extension header provides a lookup for the general QoS characteristic applicable for that 5QI
2. TEID in the GTP-u header provides a lookup for UE and bearer specific contextual information for any differentiated treatment.

Regards
Sridhar

On Fri, Jan 22, 2021 at 2:55 AM Kaippallimalil John <[email-masked]<mailto:[email-masked]>> wrote:
Hi Xuesong,

Best Regards,
John

From: dmm <[email-masked]<mailto:[email-masked]>> On Behalf Of Gengxuesong (Geng Xuesong)
Sent: Wednesday, January 20, 2021 8:23 PM
To: Uma Chunduri <[email-masked]<mailto:[email-masked]>>; Lizhenbin <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; dmm <[email-masked]<mailto:[email-masked]>>
Subject: Re: [DMM] [Apn] Regarding APN Usecase in Mobile Core

Hi Uma and all,

Best
Xuesong

Hi Robin,

In-line..

Cheers!
--
Uma C.

[Uma]: Obviously, the best reference for GTP-U is TS 29.281. However, uou should look into https://datatracker.ietf.org/doc/draft-ietf-dmm-5g-uplane-analysis/<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-dmm-5g-uplane-analysis%2F&data=04%7C01%7Cd.lake%40surrey.ac.uk%7Ca43430026077453c0d1608d8be8fcc6a%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637468872116232514%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=3DHZzzrXBa%2BO6Lv5Sf8XpMJtmupMBO3tmwhg8wFSfT4%3D&reserved=0> where lot more details and other references related this topic was analyzed (primarily started after/during REL-15, when  any other use plane other than GTP-U is worthwhile is debated for 5G N9 interface).

Best Regards,
Zhenbin (Robin)

_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmm<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&data=04%7C01%7Cd.lake%40surrey.ac.uk%7Ca43430026077453c0d1608d8be8fcc6a%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637468872116242509%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=vJ6bPTF5T6DTZ28dGO0VhxcGRh2e63T6tJ2yo3XSlGE%3D&reserved=0>
_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmm<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&data=04%7C01%7Cd.lake%40surrey.ac.uk%7Ca43430026077453c0d1608d8be8fcc6a%7C6b902693107440aa9e21d89446a2ebb5%7C0%7C0%7C637468872116252500%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=fj6gSxtJHdircaflUmtaYgOJPyfYbWKsJT5F2Udm6Zs%3D&reserved=0>

Sridhar Bhaskaran

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 22 Jan 2021 20:57:51 +0000

Many thanks to Sridhar and John 's insightful description of GTP-u tunnel for both 4G and 5G.
IMHO, APN should focus on the 5G case, i.e. potentially hundreds of thousands (or even millions) of GTP-u tunnels between a pair of one gNB and one UPF.
I think two scenarios worth exploring further separately:

  1.  5G core can exchange signal with the IP network (the N6 interface), more likely the 5G Core and N6 network are administrated by the same network operator.
     *   5G core can tag the packets before handing off to the N6 interface (i.e. the IP network), such as inserting a metadata to the data packets
     *   inform the IP network of the meaning of the inserted Metadata.
     *   The IP network needs to remove the metadata before handing the packets to their destinations

  1.  There is no communication between the 5G core and the IP network, then the IP network can only depend on the priority bits added by the UE, which can be very unpredictable.

The Section 4 (Mobility Packet Transition in the Data Network) and the Section 5 (Transport Network characteristics Mapping to SR-TE Paths) have good description on how to extend 5G core's TN aware mobility information for various TE paths within IP networks. https://datatracker.ietf.org/doc/draft-mcd-rtgwg-extension-tn-aware-mobility/

Linda Dunbar
Sent: Thursday, January 21, 2021 10:39 PM

Hi Xuesong,

In summary:

Regards
Sridhar

Best Regards,
John

Hi Uma and all,

Best
Xuesong

Hi Robin,

In-line..

Cheers!
--
Uma C.

[Uma]: Obviously, the best reference for GTP-U is TS 29.281. However, uou should look into https://datatracker.ietf.org/doc/draft-ietf-dmm-5g-uplane-analysis/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-dmm-5g-uplane-analysis%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C5985b13c46f440f9c3af08d8be8fc90e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468872069926165%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=x4dOKXMZutPMV2%2BXZltRgnXKhVzJOktjqWAt%2FuDswHs%3D&reserved=0> where lot more details and other references related this topic was analyzed (primarily started after/during REL-15, when  any other use plane other than GTP-U is worthwhile is debated for 5G N9 interface).

Best Regards,
Zhenbin (Robin)

_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmm<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C5985b13c46f440f9c3af08d8be8fc90e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468872069926165%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=z1GRKxsQ526hrkyuna0Hl1hJUh48LD8czfpfhgYh%2F4s%3D&reserved=0>
_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmm<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C5985b13c46f440f9c3af08d8be8fc90e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468872069936161%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=UPDX72peJCc%2F1ZtJ18lmfSmfwAN%2Bf112WQ6ozGdXJpQ%3D&reserved=0>

Sridhar Bhaskaran

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Fri, 29 Jan 2021 10:01:03 +0000

Hi John,

You mentioned that "5QI/QCI etc are in the GTP extension header which may not be ideal to lookup to classify each packet in the transport network". This is slightly different from my understanding about this: 5QI/QCI belongs to control plane information, and when the base station encapsulates the packet with GTPu, it maps the 5QI/QCI into the DSCP in  IP header outside GTPu encapsulation. Do I have any misunderstanding about this point?

Best
Xuesong

From: Kaippallimalil John [mailto:[email-masked]]
Sent: Friday, January 22, 2021 5:25 AM
To: Gengxuesong (Geng Xuesong) <[email-masked]>; Uma Chunduri <[email-masked]>; Lizhenbin <[email-masked]>
Cc: [email-masked]; dmm <[email-masked]>
Subject: RE: [DMM] [Apn] Regarding APN Usecase in Mobile Core

Hi Xuesong,

Best Regards,
John

Hi Uma and all,

Best
Xuesong

Hi Robin,

In-line..

Cheers!
--
Uma C.

Best Regards,
Zhenbin (Robin)

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Fri, 29 Jan 2021 10:04:37 +0000

Hi Zongpeng,

I agree that “the transport network (such as the IPRAN) should be able to provide proper SLA for different GTP-u sessions”, where APN may play a role.

Best
Xuesong

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, January 21, 2021 11:45 AM
To: Gengxuesong (Geng Xuesong) <[email-masked]>; Uma Chunduri <[email-masked]>; Lizhenbin <[email-masked]>
Cc: [email-masked]; dmm <[email-masked]>
Subject: Re: Re: [Apn] [DMM] Regarding APN Usecase in Mobile Core

Hi Xuesong and all,

    In my understanding, 5GC can establish multiple GTP-u sessions for different services with different requirements, and the requirements should be satisfied E2E.

    In the backhaul network, the transport network (such as the IPRAN) should be able to provide proper SLA for different GTP-u sessions.

    APN should be able to benefit the SLA negotiation between the 5G system and the underneath transport network.

Best Regards
Zongpeng Du

________________________________
[email-masked]<mailto:[email-masked]> & [email-masked]<mailto:[email-masked]>

From: Gengxuesong (Geng Xuesong)<mailto:[email-masked]>
Date: 2021-01-21 10:23
To: Uma Chunduri<mailto:[email-masked]>; Lizhenbin<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>; dmm<mailto:[email-masked]>
Subject: Re: [Apn] [DMM] Regarding APN Usecase in Mobile Core
Hi Uma and all,

Best
Xuesong

Hi Robin,

In-line..

Cheers!
--
Uma C.

Best Regards,
Zhenbin (Robin)

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Fri, 29 Jan 2021 10:07:33 +0000

Hi Sridhar,

Thank you for your additional information. Can I come to a conclusion that: both 5QI and TEID have the potential to provide additional information for differentiated services in transport network, although the two parameters act in different scopes?

Best
Xuesong

From: Sridhar Bhaskaran [mailto:[email-masked]]
Sent: Friday, January 22, 2021 12:39 PM
To: Kaippallimalil John <[email-masked]>
Cc: Gengxuesong (Geng Xuesong) <[email-masked]>; Uma Chunduri <[email-masked]>; Lizhenbin <[email-masked]>; [email-masked]; dmm <[email-masked]>
Subject: Re: [DMM] [Apn] Regarding APN Usecase in Mobile Core

Hi Xuesong,

In summary:

Regards
Sridhar

Best Regards,
John

Hi Uma and all,

Best
Xuesong

Hi Robin,

In-line..

Cheers!
--
Uma C.

Best Regards,
Zhenbin (Robin)

Sridhar Bhaskaran

---

From: Sridhar Bhaskaran <[email-masked]>
Date: Fri, 29 Jan 2021 17:35:48 +0530

Hi Gengxuesong,

QFI (mapped to 5QI) and TEID are to identify QoS flows and PDU sessions
within UPF and gNB. They are not meant for transport network to look into.
UPF and gNB map QFI to DSCP marking in the outer IP header which the
transport network can use for differentiated services.

Regards
Sridhar

On Fri, Jan 29, 2021 at 3:37 PM Gengxuesong (Geng Xuesong) <
[email-masked]> wrote:

> Hi Sridhar,
>
>
>
> Thank you for your additional information. Can I come to a conclusion
> that: both 5QI and TEID have the potential to provide additional
> information for differentiated services in transport network, although the
> two parameters act in different scopes?
>
>
>
> Best
>
> Xuesong
>
>
>
> *From:* Sridhar Bhaskaran [mailto:[email-masked]]
> *Sent:* Friday, January 22, 2021 12:39 PM
> *To:* Kaippallimalil John <[email-masked]>
> *Cc:* Gengxuesong (Geng Xuesong) <[email-masked]>; Uma Chunduri <
> [email-masked]>; Lizhenbin <[email-masked]>; [email-masked]; dmm
> <[email-masked]>

Sridhar Bhaskaran

---

From: Kaippallimalil John <[email-masked]>
Date: Fri, 29 Jan 2021 16:55:33 +0000

Hi Xuesong,
The point on using GTP-u extension header for classifying each packet was that unlike classifying using DSCP (which is in the IP header), finding the QCI in GTP extension requires more searches. And the control fields in GTP-u are for signaling between the 2 GTP end points (gNB, UPF, etc).

Now with regard to DSCP, since it is a mutable field, the value can be changed on path. It may be suitable in some deployments but not as a general solution.
In a gNB or UPF, there is already the subscriber context for a session and identifiers like radio bearers or IP address (upstream/downstream) to classify incoming packets.
E.g., a UPF may look up session context indexed by a UE IP address, retrieve QoS, reliability, etc , classify and select MPLS label L (or a DSCP value in some cases).
However, when there is a gNB or UPF function deployed in one network and IP transport is provided by another network, DSCP may not be able to convey slice aspects for a path across two different networks (this apart from DSCP being mutable).

Best Regards,
John

From: Gengxuesong (Geng Xuesong) <[email-masked]>
Sent: Friday, January 29, 2021 4:01 AM
To: Kaippallimalil John <[email-masked]>; Uma Chunduri <[email-masked]>; Lizhenbin <[email-masked]>
Cc: [email-masked]; dmm <[email-masked]>
Subject: RE: [DMM] [Apn] Regarding APN Usecase in Mobile Core

Hi John,

Best
Xuesong

To: Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>>; Uma Chunduri <[email-masked]<mailto:[email-masked]>>; Lizhenbin <[email-masked]<mailto:[email-masked]>>

Hi Xuesong,

Best Regards,
John

Hi Uma and all,

Best
Xuesong

Hi Robin,

In-line..

Cheers!
--
Uma C.

[Uma]: Obviously, the best reference for GTP-U is TS 29.281. However, uou should look into https://datatracker.ietf.org/doc/draft-ietf-dmm-5g-uplane-analysis/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-dmm-5g-uplane-analysis%2F&data=04%7C01%7Cjohn.kaippallimalil%40futurewei.com%7C8d3a8d34ea0049ed523f08d8c43ccbc9%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637475112703506588%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=r6m55gGEQqmacjcKy21wzksXsCzvxLBF%2Fx%2FqUFFxFPU%3D&reserved=0> where lot more details and other references related this topic was analyzed (primarily started after/during REL-15, when  any other use plane other than GTP-U is worthwhile is debated for 5G N9 interface).

Best Regards,
Zhenbin (Robin)

_______________________________________________
dmm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmm<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdmm&data=04%7C01%7Cjohn.kaippallimalil%40futurewei.com%7C8d3a8d34ea0049ed523f08d8c43ccbc9%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637475112703506588%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=5lmTCot3wizMZWRXkGRQDP8c03xbCGVOqNIBo1tplx0%3D&reserved=0>

---

From: 刘 鹏 <[email-masked]>
Date: Sat, 30 Jan 2021 01:28:27 +0000

Hi Sridhar and Xuesong,

If the IP network can obtain the QCI, TEID and other information of GTP, it can be considered as 5g's natural support for APN, and can also provide fine-grained services combined with N6 interface and edge computing. However, based on the previous discussion, it may not be able to directly obtain them. The value of DSCP alone may not be enough for APN.

It may need 5g network or UPF to make some additional support. Although it is not sure whether it is feasible, I think this information still has the possibility of potential support in the furture?

Regards,
Peng Liu

________________________________
发件人: Apn <[email-masked]> 代表 Sridhar Bhaskaran <[email-masked]>
发送时间: 2021年1月29日 20:05
收件人: Gengxuesong (Geng Xuesong) <[email-masked]>
抄送: [email-masked] <[email-masked]>; Uma Chunduri <[email-masked]>; Kaippallimalil John <[email-masked]>; dmm <[email-masked]>; Lizhenbin <[email-masked]>
主题: Re: [Apn] [DMM] Regarding APN Usecase in Mobile Core

Hi Gengxuesong,

QFI (mapped to 5QI) and TEID are to identify QoS flows and PDU sessions within UPF and gNB. They are not meant for transport network to look into. UPF and gNB map QFI to DSCP marking in the outer IP header which the transport network can use for differentiated services.

Regards
Sridhar

On Fri, Jan 29, 2021 at 3:37 PM Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Sridhar,

Best

Xuesong

From: Sridhar Bhaskaran [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Friday, January 22, 2021 12:39 PM
To: Kaippallimalil John <[email-masked]<mailto:[email-masked]>>
Cc: Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>>; Uma Chunduri <[email-masked]<mailto:[email-masked]>>; Lizhenbin <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; dmm <[email-masked]<mailto:[email-masked]>>
Subject: Re: [DMM] [Apn] Regarding APN Usecase in Mobile Core

Hi Xuesong,

In summary:

Regards

Sridhar

Hi Xuesong,

Best Regards,

John

Hi Uma and all,

Best

Xuesong

Hi Robin,

In-line..

Cheers!
--

Uma C.

Hi APNers and DMMers,

Best Regards,

Zhenbin (Robin)

--

 o__
 _>  /__

Sridhar Bhaskaran

Sridhar Bhaskaran

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Sun, 31 Jan 2021 04:18:27 +0000

Dear Linda,

Many thanks for the reference you pointed to. Through this draft I also read the other draft which seems to be source of this work, https://tools.ietf.org/html/draft-clt-dmm-tn-aware-mobility-07. I will have to first check whether I have understood it correctly.

MTNC-ID is generated by 3GPP NSSMF (TNF) and unique per path and per traffic class but not per flow/session. The MTNC-ID actually can be seen as an indicator of a path/slice in the IP transport network. This ID is carried in the packets and when the packets reach the transport network PE nodes, the ID will be read out and according to which the path/slice in the IP transport network can be selected and the traffic will be steered into it. Am I right?

My first question is where is the MTNC-ID first added, on the UE? gNB? Or UPF?

It is mentioned in the draft that "to mininise the protocol changes are required and make this underlay tranport independent IPv4/IPv6/MPLS/L2), an option is to provision a mapping of MTNC-ID to a UDP port range of the GTP encapsulated user packet....This mapping is configured in 3GPP user plane functions (5G-AN, UPF) and Provider Edge (PE) Routers that process MTNC-IDs."

My second question is whether the actual mapping procedure is like this. At the 5G-AN, the MTNC-ID is mapped to the UDP port range in the GTP-u packet header due to easier implementation/deployment, and then at the PE router, the UDP port range in the GTP-u header is used to steer the traffic into the selected path/slice. Is it correct?

It is good for you to consider to extend to N6 since it is IP to further provide SLA guarantee and other value added services. Do you plan to continue to using the UDP port range? I just keep wondering whether you have to do this. The use of the UDP port range is because of the limitation caused by the GTP-u encapsulation. So when it is N6, it is IP based. You may not need to continue this limitation. On the other hand, the UDP port range itself is also very limited, not very meaningful.

So what I am thinking is that you could use the APN ID in this case. It can serve your purpose and achieve more service provisioning possibilities.

Thank you very much for starting the discussions in the 5G scenario and N6 interface in particular! I believe it is a very important case for APN, and it can be integrated with MEC etc.

Best regards,
Shuping

From: Apn [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Saturday, January 23, 2021 4:58 AM
To: Sridhar Bhaskaran <[email-masked]>; Kaippallimalil John <[email-masked]>
Cc: [email-masked]; Gengxuesong (Geng Xuesong) <[email-masked]>; Uma Chunduri <[email-masked]>; Lizhenbin <[email-masked]>; dmm <[email-masked]>
Subject: Re: [Apn] [DMM] Regarding APN Usecase in Mobile Core

Many thanks to Sridhar and John 's insightful description of GTP-u tunnel for both 4G and 5G.
IMHO, APN should focus on the 5G case, i.e. potentially hundreds of thousands (or even millions) of GTP-u tunnels between a pair of one gNB and one UPF.
I think two scenarios worth exploring further separately:
1)      5G core can exchange signal with the IP network (the N6 interface), more likely the 5G Core and N6 network are administrated by the same network operator.
a.      5G core can tag the packets before handing off to the N6 interface (i.e. the IP network), such as inserting a metadata to the data packets
b.      inform the IP network of the meaning of the inserted Metadata.
c.      The IP network needs to remove the metadata before handing the packets to their destinations

2)      There is no communication between the 5G core and the IP network, then the IP network can only depend on the priority bits added by the UE, which can be very unpredictable.

Linda Dunbar
From: Apn <[email-masked]<mailto:[email-masked]>> On Behalf Of Sridhar Bhaskaran
Sent: Thursday, January 21, 2021 10:39 PM
To: Kaippallimalil John <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>>; Uma Chunduri <[email-masked]<mailto:[email-masked]>>; Lizhenbin <[email-masked]<mailto:[email-masked]>>; dmm <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Apn] [DMM] Regarding APN Usecase in Mobile Core

Hi Xuesong,

In summary:

Regards
Sridhar

Best Regards,
John

Hi Uma and all,

Best
Xuesong

Hi Robin,

In-line..

Cheers!
--
Uma C.

Best Regards,
Zhenbin (Robin)

Sridhar Bhaskaran

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Mon, 1 Feb 2021 02:40:20 +0000

Hi Sridhar,

Thanks for your explanation. It is much clearer for me as the following:

   UPF < ----- GTP-u tunnel [PDU session]------ > gNB

   PDU session contains multiple QoS flows [QFI marker->5QI]

   QFI marker in GTP-u extension header
5QI is not in GTP-u header directly but could be indicated by QFI. So the QoS requirements presented by 5QI can’t be used/seen by transport network in the existing in the current implementation (TEID is similar). And DSCP can act as a mediator between transport network and UPF/gNB.
Maybe the existing question becomes whether DSCP is sufficient for passing information from the mobile network to transport network? whether there is any simplification or omission of information in the mapping to the DSCP?

Best
Xuesong

From: Apn [mailto:[email-masked]] On Behalf Of Sridhar Bhaskaran
Sent: Friday, January 29, 2021 8:06 PM
To: Gengxuesong (Geng Xuesong) <[email-masked]>
Cc: [email-masked]; Uma Chunduri <[email-masked]>; Kaippallimalil John <[email-masked]>; dmm <[email-masked]>; Lizhenbin <[email-masked]>
Subject: Re: [Apn] [DMM] Regarding APN Usecase in Mobile Core

Hi Gengxuesong,

Regards
Sridhar

Best
Xuesong

Hi Xuesong,

In summary:

Regards
Sridhar

Best Regards,
John

Hi Uma and all,

Best
Xuesong

Hi Robin,

In-line..

Cheers!
--
Uma C.

Best Regards,
Zhenbin (Robin)

Sridhar Bhaskaran

Sridhar Bhaskaran

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Mon, 1 Feb 2021 03:33:17 +0000

Hi John,

Thanks for your comments.
Please find some response inline.

Best
Xuesong

Sent: Saturday, January 30, 2021 12:56 AM

Hi Xuesong,
The point on using GTP-u extension header for classifying each packet was that unlike classifying using DSCP (which is in the IP header), finding the QCI in GTP extension requires more searches. And the control fields in GTP-u are for signaling between the 2 GTP end points (gNB, UPF, etc).
[Xuesong] According to the email from Sridhar, does "requires more searches" mean that: gNB/UPF needs to first read  QFI in GTP-u extension header, then map it to the 5QI via the QFI, and determines QoS processing based on 5QI?

Now with regard to DSCP, since it is a mutable field, the value can be changed on path. It may be suitable in some deployments but not as a general solution.
[Xuesong] Sorry I'm a little confused here. What does "control fields" refer to in GTP-u here? The signaling is in control plane or data plane?

In a gNB or UPF, there is already the subscriber context for a session and identifiers like radio bearers or IP address (upstream/downstream) to classify incoming packets.
[Xuesong] "DSCP is a mutable field" may be an important limit as the interworking identifier between transport network and mobile network. But I'm not sure whether DSCP is also used in gNB or UPF, rather than transport network, for session context index?

E.g., a UPF may look up session context indexed by a UE IP address, retrieve QoS, reliability, etc , classify and select MPLS label L (or a DSCP value in some cases).
[Xuesong] The concept of "session context" is very interesting here. It seems like "session context" could be indexed by UE IP address and it could indicates QoS , reliability. Can I find more detailed specification about this in other documents?

However, when there is a gNB or UPF function deployed in one network and IP transport is provided by another network, DSCP may not be able to convey slice aspects for a path across two different networks (this apart from DSCP being mutable).
[Xuesong] Network slicing brings more complexity here. Do you think the issue of 5QI->DSCP could also be discussed together with network slicing mapping? Or we could keep them independently first?

Best Regards,
John

From: Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>>
Sent: Friday, January 29, 2021 4:01 AM
To: Kaippallimalil John <[email-masked]<mailto:[email-masked]>>; Uma Chunduri <[email-masked]<mailto:[email-masked]>>; Lizhenbin <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; dmm <[email-masked]<mailto:[email-masked]>>
Subject: RE: [DMM] [Apn] Regarding APN Usecase in Mobile Core

Hi John,

Best
Xuesong

Hi Xuesong,

Best Regards,
John

Hi Uma and all,

Best
Xuesong

Hi Robin,

In-line..

Cheers!
--
Uma C.

Best Regards,
Zhenbin (Robin)

---

From: Sridhar Bhaskaran <[email-masked]>
Date: Mon, 1 Feb 2021 10:12:16 +0530

Hi Gengxuesong,

On,

>> Maybe the existing question becomes whether DSCP is sufficient for
passing information from the mobile network to transport network? whether
there is any simplification or omission of information in the mapping to
the DSCP?

3GPP allows mapping of a GTP-u tunnel (PDU session) to an index to a
transport network configuration / policy via "Network Instance" concept.
When the GTP-u tunnel is setup in the UPF by the signalling plane, it
provides a "Network Instance" which is just a string that acts as an index
into UPF's transport layer configuration.

Now what the transport layer configuration is - 3GPP doesn't care as it is
out of their remit. If you are using just plain IP routing, then DSCP (for
IPv4) and Flow label (IPv6) are the options to map a QFI within a GTP-u
tunnel to IP transport. However if you are using - say a source routing
technology like SRv6, you may potentially configure the UPF to map a slice
(PDU session / TEID) and QFI to a specific SID list.

If you use PPR (Preferred path routing), then MTCN-ID is an option.

Also note that on the N3 interface between UPF and gNB, if it is going to
traverse a public network, operators would employ IPSec tunneling for
security. So any markings at the transport protocol layer (e.g. UDP source
port) will not be visible to on path routers due to IPSec. In such a case,
the mapping of Slice (PDU Session / TEID) and QFI should be to the outer IP
header in the IPSec tunnel. This is where a solution at IP header level
helps (e.g DSCP / flow label / SID list)

Regards
Sridhar

On Mon, Feb 1, 2021 at 8:10 AM Gengxuesong (Geng Xuesong) <
[email-masked]> wrote:

> ž   UPF < ----- GTP-u tunnel [PDU session]------ > gNB
>
> ž   PDU session contains multiple QoS flows [QFI marker->5QI]
>
> ž   QFI marker in GTP-u extension header
>
> 5QI is not in GTP-u header directly but could be indicated by QFI. So the
> QoS requirements presented by 5QI can’t be used/seen by transport network
> in the existing in the current implementation (TEID is similar). And DSCP
> can act as a mediator between transport network and UPF/gNB.
>
> Maybe the existing question becomes whether DSCP is sufficient for passing
> information from the mobile network to transport network? whether there is
> any simplification or omission of information in the mapping to the DSCP?
>
>
>
> Best
>
> Xuesong
>
>
>
>
>
> *From:* Apn [mailto:[email-masked]] *On Behalf Of *Sridhar Bhaskaran
> *Sent:* Friday, January 29, 2021 8:06 PM
> *To:* Gengxuesong (Geng Xuesong) <[email-masked]>
> *Cc:* [email-masked]; Uma Chunduri <[email-masked]>; Kaippallimalil
> John <[email-masked]>; dmm <[email-masked]>; Lizhenbin <
> [email-masked]>

Sridhar Bhaskaran