Subject: [DNA] RE: IPv6 over PPP over GPRS -- once again

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 17 Nov 2004 11:08:33 -0500

Tero, 

I think RADIUS only comes into the picture if you're running 
PPP over the air. Are you? I thought it was only between the 
phone and laptop. But if you're running it over the air 
then it's a completely different story. 

Hesham

 > -----Original Message-----
 > From: Tero Kauppinen (JO/LMF) [mailto:[email-masked]]
 > Sent: Wednesday, November 17, 2004 4:46 AM
 > To: Soliman, Hesham; Bernard Aboba
 > Cc: Dna
 > Subject: IPv6 over PPP over GPRS -- once again
 > 
 > 
 > >  > >  >       LAPTOP <-- PPP --> PHONE <---- GPRS ----> GGSN
 > >  > >  >
 > >  > >  > And the same is (obviously) true for UMTS as well...
 > >  > >
 > >  > > => The RAs are sent (at least according to the specs) 
 > but what you
 > >  > > might be seeing is that the RA is only sent to the 
 > phone and is not
 > >  > > forwarded to the laptop. So the laptop only sees a 
 > PPP connection.
 > >  >
 > >  > There is still the question of how the LAPTOP gets the IPv6
 > >  > prefix without
 > >  > RA.  Since PPP IPv6CP standards don't specify this, I'm 
 > at a loss to
 > >  > explain it.
 > > 
 > > => It doesn't get the prefix in this model.
 > > It can only get the prefix if PPP is not there. If, for instance,
 > > a bluetooth PAN profile is used, then it can get the prefix through
 > > an RA. The phone would be acting like a router in this case.
 > > 
 > > Hesham
 > 
 > I thought that there was something wrong with my setup and I 
 > came to the conclusion that RAs are indeed sent but I just 
 > couldn't see them. However, this was not a correct 
 > conclusion either. From the network administrators I learn 
 > that RAs never reach the phone because a firewall on their 
 > GPRS network side blocks them. I was indeed confused: no RAs 
 > and no option in PPP to negotiate a prefix and still the 
 > laptop had a global address. 
 > 
 > Took awhile to realize that there is a component missing 
 > from the picture and that is RADIUS (RADIUS and IPv6 -- 
 > rfc3162). Now the setup starts to make sense: the phone gets 
 > an address via a PDP context and it's delivered to the phone 
 > by using RADIUS. Does this sound reasonable or am I still in error?
 > 
 > BR,
 > 
 > Tero
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

---

From: "Tero Kauppinen (JO/LMF)" <[email-masked]>
Date: Wed, 17 Nov 2004 17:14:56 +0100

> Tero,

Hi Hesham,

> then it's a completely different story.

No, I am not. It's between the phone and laptop. 

Well, this is getting really strange...

Tero

---

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 17 Nov 2004 11:16:40 -0500

Check if the laptop is manually configured :) or if you're
using ISATAP ! 

Hesham

 > Sent: Wednesday, November 17, 2004 11:15 AM
 > Subject: RE: IPv6 over PPP over GPRS -- once again
 > 
 > 
 > > Tero,
 > 
 > Hi Hesham,
 > 
 > >

---

From: "Tero Kauppinen (JO/LMF)" <[email-masked]>
Date: Wed, 17 Nov 2004 17:22:06 +0100

> Check if the laptop is manually configured :) 

Nope. It's not... ;)

>or if you're using ISATAP !

No ISATAP either...

Tero

---

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 17 Nov 2004 11:45:18 -0500

My final attempt ;) check if it's a 6-to-4 address. Windows
does that I think if it gets a v4 address. 

 > Sent: Wednesday, November 17, 2004 11:22 AM

---

From: "Tero Kauppinen (JO/LMF)" <[email-masked]>
Date: Thu, 18 Nov 2004 08:15:54 +0100

Hi all,

It feels like this might start to disturb people and it is better that I try to find an answer to this before further posting on the mailing list.

Q'apla,
Tero

> From: Jari Arkko [mailto:[email-masked]]
> Sent: 18. marraskuuta 2004 6:53
> To: Soliman, Hesham
> Cc: Bernard Aboba; Tero Kauppinen (JO/LMF); Dna
> Subject: Re: [DNA] IPv6 over PPP over GPRS -- once again
> 
> Soliman, Hesham wrote:
> 
> > => I don't think the GGSN knows if it's for the phone
> > or laptop. But yes the RA should be sent to the phone.
> 
> The GGSN does not need to know, really. It always sends
> an RA, and if the PDP context happens to be for the phone,
> the phone is the ultimate user of that RA. If its the laptop
> for which the PDP context has been requested, then the RA
> ends up in the laptop.
> 
> > And the phone should sent it to the laptop, but it's
> > an implementatio issue. I don't recall anything in the
> > spec that says the MT has to do that. Obviously it should
> > do it though.
> 
> Yes. I did not find anything specific about this either,
> but my understanding is that if a laptop establishes a
> connection through the phone, the laptop gets its own
> PDP context and gets everything sent to it -- including
> the RAs.
> 
> --Jari