Subject: Re: [DNA] Confirming today's face-to-face meeting decisions

From: Sathya Narayanan <[email-masked]>
Date: Thu, 11 Nov 2004 10:05:19 -0500

> There may be extra cost in making all the routers on a link agree on
> a "link scoped identifier", but that is an out of band management 
> cost.Using "does this landmark still exist" has a cost during 
> movement in
> that there is no negative acknowledgement and we have to wait for a
> timer to expire if the link is new and the landmark does not still
> exist.
Yes. I agree.

Few points:
1) For aguments sake, if we find out that the out-band cost is so high it is not going to be deployed in most scenarios, it still a bad idea to work on it. Again, my only request is that we do this cost analysis using some objective way to measure this cost.
2) Whether immediate change is detected in link-scoped identifier is actually not clear - this is primarily because of the non-dependency of the method on L2 trigger (and that is arguably a good thing), so the average gain in the detection time for link-scoped identifier approach MAY not be very high. Again, we need some analysis.
3) I am not recommending timeout as the only change detection - if you think about the mechanism proposed in RRD, when the 'landmark still exists?' question is asked, if you receive a 'this NEW landmark exists' answer thats an indication of link change. Ofcourse, you need to authenticate this response - but in most cases the router that responded is likely to be the router you are going to use as default router and you need to authenticate it anyway.

with regards,
Sathya

---

From: Brett Pentland <[email-masked]>
Date: Fri, 12 Nov 2004 02:12:22 +1100

> 1) For aguments sake, if we find out that the out-band cost is so high it is not going to be deployed in most scenarios, it still a bad idea to work on it. Again, my only request is that we do this…

Agreed.

> 2) Whether immediate change is detected in link-scoped identifier is actually not clear - this is primarily because of the non-dependency of the method on L2 trigger (and that is arguably a good th…

I think this is a separate problem.  The point is in being able to make
a correct decision based on the reception of a single RA.  How you get
that RA is a separate problem.

> 3) I am not recommending timeout as the only change detection - if you think about the mechanism proposed in RRD, when the 'landmark still exists?' question is asked, if you receive a 'this NEW lan…

I can't remember the details of RRD - are you saying that there is a way
for an RA with a prefix that you haven't seen before indicates a link
change as oposed to a new router on the same link?

Brett.