Subject: RE: [DNA] DNA link hints document

From: "Tero Kauppinen (JO/LMF)" <[email-masked]>
Date: Fri, 05 Nov 2004 18:47:07 +0100

> -----Original Message-----
> From: Bernard Aboba [mailto:[email-masked]]
> Sent: 5. marraskuuta 2004 18:14
> To: Tero Kauppinen (JO/LMF)
> Cc: Dna
> Subject: RE: [DNA] DNA link hints document
> 
> > Actually, if I'm correct, the IPv6 address is acquired via the PDP context
> exchange. RAs are not sent to the terminal, for example, in the following
> scenario:
> >
> >       LAPTOP <-- PPP --> PHONE <---- GPRS ----> GGSN
> >
> > And the same is (obviously) true for UMTS as well...
> 
> PPP IPv6CP can only assign an interface-ID, not a prefix, so without RA
> there is no way for the host to obtain a prefix.  Or am I missing
> something?

Well, that's what I thought also, but after running the setup on a Linux laptop I noticed that no RAs are actually received. Being a little bit surprise myself I confirmed my observation from a colleague of mine... It's of course a different situation if I setup an IPv6-over-IPvX tunnel over the connection in which case I indeed receive RAs.

Then again, maybe there is just something wrong with my setup.

Tero

---

From: "Tero Kauppinen (JO/LMF)" <[email-masked]>
Date: Fri, 05 Nov 2004 19:32:50 +0100

Hi Hesham,

Thanks for clearing it up.

BR,

Tero

> From: Soliman, Hesham [mailto:[email-masked]]
> Sent: 5. marraskuuta 2004 20:18
> To: Tero Kauppinen (JO/LMF); Dna
> Hi Tero,
>  > Actually, if I'm correct, the IPv6 address is acquired via
>  > the PDP context exchange. RAs are not sent to the terminal,
>  > for example, in the following scenario:
>  >
> => The RAs are sent (at least according to the specs) but what you
> might be seeing is that the RA is only sent to the phone and is not
> forwarded to the laptop. So the laptop only sees a PPP connection.
> 
> The situation might be different if instead of the phone you see
> a PCMCIA card inside the laptop. Or if you snoop the traffic arriving
> at the phone itself. I.e. when the PPP part is removed.
> 
> Hesham
> 
>  >
>  > BR,
>  >
>  > Tero Kauppinen
>  >
> 
> ===========================================================
> This email may contain confidential and privileged material for the sole use
>  of the intended recipient.  Any review or distribution by others is strictly
>  prohibited.  If you are not the intended recipient please contact the sender
>  and delete all copies.
> ===========================================================

---

From: "Soliman, Hesham" <[email-masked]>
Date: Sat, 06 Nov 2004 14:14:43 -0500

> There is still the question of how the LAPTOP gets the IPv6 
 > prefix without
 > RA.  Since PPP IPv6CP standards don't specify this, I'm at a loss to
 > explain it.

=> It doesn't get the prefix in this model.
It can only get the prefix if PPP is not there. If, for instance, 
a bluetooth PAN profile is used, then it can get the prefix through
an RA. The phone would be acting like a router in this case.

Hesham