Subject: Re: [DNA] DNA BCP Submission

From: Sathya Narayanan <[email-masked]>
Date: Thu, 04 Nov 2004 10:04:38 -0500

Dear JinHyeock -

> 
> "An RA with its current active prefix" can't represent a link 
> change 
> properly. Hence, it can't be a link identifier, unless a host 
> adopts CPL
> technique. I am afraid we have a different notion about what link 
> identifier is. 

Arrival of an RA validating the current active prefix or a timeout without such an arrival can not
be used for link change identification? Please correct me if I am wrong here. The timeout value may
be 3 time MaxRtrAdvInterval, but this should still
work.

> We wrote, in "DNA solution framework" draft, 
> 
>   ............................... Each link has its unique Link 
> Identifier and all
>   routers in the link advertise the same Link Identifier in RAs.  

I DISAGREE with the requirement of a 'unique link identifier' agreed among all the routers and the nodes in the link as the ONLY way to do this. The current active prefix in each node is also an acceptable identifier for the link even though it will not be the same in every node and every router. If a node can determine whether its current prefix is supported or not, it has determined link change - it may not be fast but it will still work. Again, I building this argument on my statement above - please correct me if I am wrong.

> What concerns me the most is NOT the draft includes many 
> uncruicial 
> things BUT it doesn't include enough crucial things. Also I am afraid
> that too much focus on uncrucial things may prevent crucial things 
> from getting enough attention.  
This is a valid concern. I agree - as I said earlier
we will take your comments into consideration and improve sections 4,5 & 6 in -02.

> > I don't know if DNA is possible without link identification 
> conceptually 
> > whether or not a unique (for
> > all nodes) 'identifier' is used. See my response below:
> 
> A host may skip to check for link change and directly verify 
> IP configuration one by one. 
I think this is coming back to our disagreement on
the 'uniqueness' of an identifier versus link
identification. Based on Pekka's and your clarification for an ealier email on 'DNA Goals
Issues' from me, my understanding is that DNA
goals is to achieve 'link identification' not necessarily only through the definition of a unique link identifier. By unique, I mean the same identifier in all the node & routers on the link.
Under this understanding, any verification of IP configuration will inherently have a 'identification of the link' component in it.

> 
> The main issue should be whether the draft deals with DNA 
> adequately 
> or not. If so, either way is ok for me about whether to include 
> other 
> stuffs or not. If not, the draft would better work on DNA proper, 
> instead 
> of payint too much attention on secondary stuffs. 

Again, this is a very valid comment. With your input we will try to improve sections 4, 5  & 6 in -02.

thanks & regards,
Sathya

---

From: Sathya Narayanan <[email-masked]>
Date: Thu, 04 Nov 2004 16:17:14 -0500

Dear JinHyeock -

>I agree that 'RA with current active prefix' can be used for link 
>identity detection but kindly take notice an adverb 'PROPERLY'. 
>That's why I wrote that it can't be a link identifier, NOT it can't 
>do link identity detection. 
>  
>
ok. And, my point is that as long as you can do link identity detection 
even though you don't define a link
identifier it is still a good way to go.

>If a host receives an RA with its current active prefix, it means it still 
>remains at the same link. However, if a host receives 'an RA with 
>a different prefix', it can't check for link change with it. 
>  
>
A timeout without receiving a 'RA with current active prefix' can be 
used to indicate link change. Right?

>In this framework, because current active prefix doesn't satisfy
>2), it can't be a link identifier, though I agree that it can be used 
>to check for link change. 
>
>In CPL or LinkID (by Brett), a link change can be detected instantly, 
>when a host get a different link identifier, such as the complete 
>prefix list in CPL or LinkID option in LinkID.
>  
>
ok.

>We expect 'link identifier' to EXPLICITLY represent a link identity
>and have the following two properties. 
>1) When the same link identifer arrives, it means the same link.
>2) When a different link identifer arrives, it means a different link.
>  
>
I agree with these two properties with one 'little' caveat - these two 
properties need to hold only for a
particular node in question. i.e. two nodes in the same link could be 
using different 'identifiers' to represent
the link as long as within each of them the above two properties hold. 
You seem to be making
his point below, but ...

>To have the above properties, all the nodes adopting the same 
>link identifier method, whether it be CPL or LinkID, should agree 
>on the same, hence unique, link identifier. For example, if in a 
>link, a node use CPL and the other use LinkID, then they may 
>have different link identifers. However, among the nodes using CPL,
>or any other link identifier, there can be only one link identifier
>for a link. Otherwise 2) can't be satisfied.
>  
>
even within a same scheme , two nodes using the scheme could use 
different 'identifier', as long as the
above two properties hold within the node (neither CPL nor LinkID is an 
example for this). I guess,
you know where I am going with this. In my proposed solution draft, RRD: 
I am trying to use the current
prefix and force the timeout within a short duration by defining new 
timer for the current router. Even though
it doesn't define a 'unique' identifier for every node in the link, I 
think it is reasonable approach to achieve
link identity detection, with its own advantages (and ofcourse, 
dis-advantages).

best regards,
Sathya

---

From: JinHyeock Choi <[email-masked]>
Date: Fri, 05 Nov 2004 05:39:12 +0900

Dear Sathya

As I wrote before, we have a different notion about 'link identifier'.

 
> I DISAGREE with the requirement of a 'unique link identifier' agreed among all the routers and the nodes in the link as the ONLY way to do this. The current active prefix in each node is also an ac…

I guess this disagreement results from the disagreement on 
the link identifier definition. I wrote the above only to illuminate 
what I mean by the term 'link identifier', not to insist that is the
only way for link identity detection. 

ok. 

Thanks for your kind consideration.

Best Regards

---

From: JinHyeock Choi <[email-masked]>
Date: Fri, 05 Nov 2004 07:43:41 +0900

Dear Sathya

> identifier it is still a good way to go.

Agree. If only link identity detection can be done quickly and precisely, 
we don't have to adhere to link identifier approach. . 
 
> used to indicate link change. Right?

What concerns me about timeout approach is 
1) it's slow because a host needs to wait till timeout.
2) it's not precise. You need to rely on approximate knowledge, 
because other incidents, such as packet loss or 
prefix omission can occur timeout without receiving prefix.  

> the link as long as within each of them the above two properties hold. 

Agree. But I am afraid that in a link, unless all the node that use 
the same technique agree on the same link identifier, these two 
properties are very difficult to hold even for a particular node. 
Assume node1 and node2 use the same link identifier technique, 
hence the same link identifier format. If node1 & node2 use 
different link identifiers, when node2 receives the link identifier
used by node1, even though it receives a different link identifier,
it doesn't mean a link change. 

This is an example w.r.t. RRD. In a link, assume node1 uses prefix A:: 
and node2 Prefix B::. When node1 receives an RA only with prefix B::., 
though it receives a different prefix, it doesn't change a link.  

> example for this). '

I wrote my opinion about this on above. Also I think, 
without the unique link identifier in a link, to satisfy those two, 
each link identifier needs to carry information that indicates for which 
nodes this link identifier is intended. 

> I guess,
 
I admit that my knowledge on RRD is not thorough. However, it's not 
clear to me 
1) how to quicken timeout without side effects, such as false link change detection. 
2) what's the advantage of using <current prefix, current access router>, 
     instead of just a global prefix. 

If you use timeout to check for link change, any global prefix in a link can do 
the same, w.r.t DNA. 

A host remembers any prefix in a link, when it suspects it may be in a different 
link, it sends an RS. If it receives the same prefix, it's in the same link. If it doesn't 
receives it until timeout, a link change has happened. It doesn't have worry about 
'current' things. 

Best Regards

JinHyeock

---

From: Sathya Narayanan <[email-masked]>
Date: Thu, 04 Nov 2004 21:36:49 -0500

Dear JinHyeock -

>1) it's slow because a host needs to wait till timeout.
Agreed.

>prefix omission can occur timeout without receiving prefix.  
Doesn't the same set of problems apply to CPL also? May be to a varying 
degree?

>though it receives a different prefix, it doesn't change a link.  
Yes. If a 'unique' for all nodes 'link identifier' is not used, then the 
nodes can not make such assumptions of change.
It should be a more specific algorithm to detect change. See below ..

>1) how to quicken timeout without side effects, such as false link change detection. 
I am only suggesting to quicken the response to a RS - by defining a new 
smaller response time for current access router,
which is identified primarily by means of the current prefix.

>     instead of just a global prefix.
I could possibly name a few. But, primarily - the changes proposed in 
RRD is very minimal and I believe it to be very
effective in solving the primary problem of link change detection. I 
will try to enumerate this and other possible
advantages in my presentation (which I haven't prepared yet ;-) ).

regards,
Sathya