Subject: Re: [DNA] Confirming today's face-to-face meeting decisions

From: Sathya Narayanan <[email-masked]>
Date: Thu, 11 Nov 2004 10:24:54 -0500

<snip> 
> > 2) Whether immediate change is detected in link-scoped 
> identifier is actually not clear - this is primarily because of 
> the non-dependency of the method on L2 trigger (and that is 
> arguably a good thing), so the average gain in the detection time 
> for link-scoped identifier approach MAY not be very high. Again, 
> we need some analysis.
> 
> I think this is a separate problem.  The point is in being able to 
> makea correct decision based on the reception of a single RA.  How 
> you get that RA is a separate problem.
Yes. It is a separate problem, but when we are talking (comparing) the quickness of link-change-detection we need to look at the complete picture. If the link-scoped approach has the property of link-change-detection when a unsolicited RA is received (which is a good thing about it), but how useful is it if you need the RS message to initiate it for rapid-detection is a valid point to consider in terms of the cost. If the link-scoped approach depends on a RS message, than host-scoped approach is (arguably) as good as the link-scoped approach with less out-of-band cost.

> > 3) I am not recommending timeout as the only change detection - 
> if you think about the mechanism proposed in RRD, when the 
> 'landmark still exists?' question is asked, if you receive a 'this 
> NEW landmark exists' answer thats an indication of link change. 
> Ofcourse, you need to authenticate this response - but in most 
> cases the router that responded is likely to be the router you are 
> going to use as default router and you need to authenticate it anyway.
> 
> I can't remember the details of RRD - are you saying that there is 
> a way
> for an RA with a prefix that you haven't seen before indicates a link
> change as oposed to a new router on the same link?
Yes - if we can design a mechnism that with a high probability can ensure that the confirmation of current landmark (from current AR) is likely to happen before any other router responds. Thats what I am trying to achieve with my MaxDelayForCurrRouter and MinDelayForOtherRouters variables. If these two variables are equal to zero, the probability is 1 - packet loss probability and the time window involved can be few milli-seconds (this needs to be confirmed using simulations, ofcourse).

Sathya

---

From: Brett Pentland <[email-masked]>
Date: Fri, 12 Nov 2004 04:21:59 +1100

Sathya Narayanan wrote:
>> identifier is actually not clear - this is primarily because of the
>> non-dependency of the method on L2 trigger (and that is arguably a
>> good thing), so the average gain in the detection time for
>> link-scoped identifier approach MAY not be very high. Again, we
>> need some analysis.
>> 
> Yes. It is a separate problem, but when we are talking (comparing)
> the quickness of link-change-detection we need to look at the
> complete picture. If the link-scoped approach has the property of
> link-change-detection when a unsolicited RA is received (which is a
> good thing about it), but how useful is it if you need the RS message
> to initiate it for rapid-detection is a valid point to consider in
> terms of the cost. If the link-scoped approach depends on a RS
> message, than host-scoped approach is (arguably) as good as the
> link-scoped approach with less out-of-band cost.
> 
I'm not sure I understand your point.  Yes, I agree that the whole
picture needs to be considered, but aren't we comparing two things
that depend on receiving RAs.  If so, then isn't the time taken to
get them the same in each case?

Brett.