Subject: RE: [DNA] DNA link hints document

From: "Tero Kauppinen (JO/LMF)" <[email-masked]>
Date: Fri, 05 Nov 2004 12:25:27 +0100

-----Original Message-----
> From: [email-masked] [mailto:owner-
> [email-masked]] On Behalf Of Bernard Aboba
> Sent: 3. marraskuuta 2004 8:35
> To: NJEDJOU Eric RD-RESA-REN
> Cc: Dna
> Subject: Re: [DNA] DNA link hints document
> 
> > Actually from an IP layer perspective on an MN, the GPRS link equals to
> > a ppp connection. Therefore activation of a PDP context is seen by an IP
> > node as the establishment of a ppp connection (because 3GPP specifies
> > that an IP node interfaces to the GPRS mobile station via PPP).
> 
> Actually, activation will express itself via completion of the PPP NCP
> negotiation.  Data may be sent after NCP negotiation is complete, so that
> is when the link can be considered "up" for IPv4.  For IPv6, I think that
> isn't true; RS/RA also needs to be  completed to enable address
> assignment.  Similarly, an LCP-terminate would bring the link "down" for
> any network protocol.

Actually, if I'm correct, the IPv6 address is acquired via the PDP context exchange. RAs are not sent to the terminal, for example, in the following scenario:

      LAPTOP <-- PPP --> PHONE <---- GPRS ----> GGSN

And the same is (obviously) true for UMTS as well...

BR,

Tero Kauppinen

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 05 Nov 2004 08:14:03 -0800 (PST)

> And the same is (obviously) true for UMTS as well...

PPP IPv6CP can only assign an interface-ID, not a prefix, so without RA
there is no way for the host to obtain a prefix.  Or am I missing
something?