Subject: [DNA] IPv6 over PPP over GPRS -- once again

From: "Tero Kauppinen (JO/LMF)" <[email-masked]>
Date: Wed, 17 Nov 2004 10:46:26 +0100

>  > >  >       LAPTOP <-- PPP --> PHONE <---- GPRS ----> GGSN
>  > >  >
>  > >  > And the same is (obviously) true for UMTS as well...
>  > >
>  > > => The RAs are sent (at least according to the specs) but what you
>  > > might be seeing is that the RA is only sent to the phone and is not
>  > > forwarded to the laptop. So the laptop only sees a PPP connection.
>  >
>  > There is still the question of how the LAPTOP gets the IPv6
>  > prefix without
>  > RA.  Since PPP IPv6CP standards don't specify this, I'm at a loss to
>  > explain it.
> 
> => It doesn't get the prefix in this model.
> It can only get the prefix if PPP is not there. If, for instance,
> a bluetooth PAN profile is used, then it can get the prefix through
> an RA. The phone would be acting like a router in this case.
> 
> Hesham

I thought that there was something wrong with my setup and I came to the conclusion that RAs are indeed sent but I just couldn't see them. However, this was not a correct conclusion either. From the network administrators I learn that RAs never reach the phone because a firewall on their GPRS network side blocks them. I was indeed confused: no RAs and no option in PPP to negotiate a prefix and still the laptop had a global address. 

Took awhile to realize that there is a component missing from the picture and that is RADIUS (RADIUS and IPv6 -- rfc3162). Now the setup starts to make sense: the phone gets an address via a PDP context and it's delivered to the phone by using RADIUS. Does this sound reasonable or am I still in error?

BR,

Tero

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 17 Nov 2004 06:37:42 -0800 (PST)

> Took awhile to realize that there is a component missing from the picture and that
> is RADIUS (RADIUS and IPv6 -- rfc3162). Now the setup starts to make
> sense: the phone gets an address via a PDP context and it's delivered to
> the phone by using RADIUS. Does this sound reasonable or am I still in
> error?

This would surprise me, since if it were true, then every phone would need
to be provisioned with a RADIUS shared secret, which I doubt.  The
NAS-IPv6-Address attribute is meant to be sent from server to client,
not the other way around, so IPv6 addresses can't be assigned that
way. There are Framed-Interface-Id and Framed-IPv6-Prefix attributes, but
those are meant to be consumed by a NAS in order to inform its PPP
Link-Identifier negotation and RA, respectively.

Sounds like we are witnessing the "immaculate configuration"!

---

From: Jari Arkko <[email-masked]>
Date: Wed, 17 Nov 2004 19:30:01 +0200

Hi guys,

I can confirm that RADIUS does not belong to this
discussion. (If there's RADIUS involvement, its always
on the network side, GGSN and onwards.)

I can also confirm that RAs are indeed sent by the GGSN.
My understanding is that if PPP is used between a phone a
laptop, the PDP context is reserved for the laptop and the
RA goes straight to the laptop too.

Note that in GSM, there is nothing corresponding to a MAC
address; one of the link layer messages from the GGSN gives
the phone an IID that it can use. In the laptop case the
laptop obviously doesn't see the link layer messages, but
bases its IID either on its own MAC address or the IPv6CP
negotiated IID.

For more information, see Section 9.2.1.1 in
http://www.3gpp.org/ftp/Specs/archive/23_series/23.060/23060-660.zip

--Jari