Subject: [DNA] Relevant drafts to DNA?

From: Greg Daley <[email-masked]>
Date: Tue, 15 Feb 2005 16:54:40 +1100

Hi,

Since the -00 deadline has just passed, I'm interested
in collecting a list of documents relevant to DNA.

If you've got documents which are relevant
(even if they're not DNA keyworded) please indicate
what they are, and how to get them (if they've not
reached the repository yet).

Greg.

Link-Layer Hints
----------------
draft-ietf-dna-link-information-01.txt

Related to Current Practice
---------------------------
draft-hong-dna-if-l2-00.txt	 		
draft-jinchoi-dna-cpl-01.txt
draft-narayanan-dna-hosts-bcp-00.txt
draft-narayanan-dna-routers-bcp-00.txt
draft-narayanan-dna-bcp-01.txt (superceded)
		
Solution Space
---------------
draft-jinchoi-dna-soln-frame-01 (expired)

Router Advertisement delivery
-----------------------------
draft-daley-dna-det-fastra-01.txt
draft-daley-dna-prob-fastra-00.txt
draft-jinchoi-dna-frd-01 (expired)

Link Identifiers
----------------
draft-pentland-mobileip-linkid-03.txt
draft-narayanan-dna-rrd-00.txt

Response Matching
-----------------
draft-daley-dna-nonce-resp-00.txt

RFC-EDITOR QUEUE
----------------
draft-ietf-dna-goals-04.txt

Other Working Groups:
---------------------
draft-ietf-dhc-dna-ipv4-09.txt
draft-daley-ipv6-tsllao-01.txt

Documents Referencing DNA
-------------------------
draft-ietf-dhc-dual-stack-02.txt
draft-ietf-multi6-failure-detection-00.txt

---

From: Sathya Narayanan <[email-masked]>
Date: Tue, 15 Feb 2005 20:01:44 -0500

In the interest of initiating a discussion on the hosts BCP, I have 
tried to summarize the hosts BCP draft upto Section 6 below.

Reference: 
http://www.ietf.org/internet-drafts/draft-narayanan-dna-hosts-bcp-00.txt

The two steps for DNA recommended by the draft are:

1) Validation of current configuration (to identify link change)
       Example configurations are: the current IPv6 prefix and address, 
default router information and neighbour cache entries.
        Issues:
                 Use of link local addresses and subset of prefixes in 
RA messages
        Suggested solutions:
                 Confirmation of existing configuration based on 
received RA with current prefix and/or current router address.
                  CPL - Complete Prefix list
                  Confirmation of Neighbor cache entry for a global 
address (SHOULD). Use confirmation - DO NOT initiate this for validation 
test.
        Recommendations
                  We have most of them as SHOULDs. May be that is too 
conservative. Please look at section 5.3 in the draft

2) Reachability detection
       Partial reachability confirmation with the current default router 
is REQUIRED, while bi-directional is RECOMMENDED for wireless environments.
       Issues:
                Dependence on long timeouts
       Suggested solutions:
                 Neighbor discovery test (NS-NA message exchange)
                 Router discovery test (RS-RA message exchange)
                 Hybrid - both NS and RS parallely ???
                 Require authorization of the router.
       Recommendations:
                 Again, please comment on the SHOULDs and MAYs. Section 6.3

Please post comments.

-Sathya