Subject: RE: [DNA] question on draft-ietf-dna-link-information-01.txt

From: NJEDJOU Eric RD-RESA-REN <[email-masked]>
Date: Mon, 07 Mar 2005 23:27:20 +0100

Hi John and thanx for feedback,
Responses in line 

> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de 
> [email-masked]
> Envoyé : samedi 5 mars 2005 13:30
> À : [email-masked]
> Objet : [DNA] question on draft-ietf-dna-link-information-01.txt
> 
> Hi all,
> 
> This may have been discussed before, but in reading 
> draft-ietf-dna-link-information-01.txt,
> I had some questions / comments.
> 
> In Section 2.1  GPRS/3GPP, it is not clear if you are talking 
> about GSM, UMTS or what.
> GPRS can be applied to both the GSM & UMTS air interfaces, as 
> GPRS is more of a networking technology.  It might make more 
> sense to discuss GSM/UMTS when discussing the air interface 
> and GPRS when discussing the networking technology (SGSN, 
> GGSN).  Also, its not clear if the section is talking about 
> IPv4 or IPv6.
> If it is talking about IPv4, then I think there are a number 
> of inaccuracies, such as: 
> 
>    ... It is only after the
>    PDP Context has been established, address autoconfiguration and
>    tunneling mechanism have taken place that the MT's IP 
> packets can be
>    forwarded to and from its remote IP peers.  
> 
> Address autoconfiguration doesn't apply to IPv4.  

The document specifically address IPv6...

> Also, there 
> are some other issues with IPv6.

Could you be more explicit about these issues? The new revision of the document was meant so fix inaccuracies that remained from the document originally presenting the IPv4 PDP contex activation process.

> 
> In general, I think the main points of the section should be:
> 
>    The successful establishment of a PDP Context on a GPRS indicates a
>    link-up event. A PDP Context deactivation indicates a link 
> down event
>    notification.

I think we all agree on this, but further explanantions were required as to why the establishment of a PDP contextx could be an indication of link-up

> 
> Section 2.2 covers 3GPP2 air interfaces & networks somewhat 
> better, but I think a more rigorous seperation between the 
> air interface and network side would be good.
> 
> Also, just to confuse things, both 3GPP and 3GPP2 networks 
> are supporting WLAN access, so ultimately, we may like to 
> restrict these sections more to the air interface than the SDO.
> 
> Is there any consideration about mentioning 802.21? This is, 
> of course, a work in progress, but I would suggest that it at 
> least be metioned, as it is relevant here.
> 

The document aims at cataloguing events from various link layer technologues. 802.21 is not a link layer technology. It is intending at optimizing and facilitating handovers across link layer technologies. In that respect, 802.21 is not to be listed along GPRS, CDMA1x-EVDVO or 802.11. However there are definitely links between the aim of the document and the scope of 802.21

> Finally, I find section 4.  Security Considerations rather 
> inadequate.  I would prefer a concise mention about the DoS 
> attacks possible based upon link-events, and perhaps state 
> that any link indication should not necessarily be considered 
> authorative by itself.  A mobile node should probably make 
> the final decision about whether a link is down or up.  There 
> may be additional indications that the mobile terminal would 
> include before marking a link as up or down.
> 
> thanks,
> John
> 

Hope this helps
Eric
Regards

---

From: [email-masked]
Date: Tue, 08 Mar 2005 00:47:55 +0200

Hi Eric,

> >    tunneling mechanism have taken place that the MT's IP packets can be
> Could you be more explicit about these issues? The new 
> revision of the document was meant so fix inaccuracies that 
> remained from the document originally presenting the IPv4 PDP 
> contex activation process.

Let me re-read the text and see if I have some text to suggest.

> I think we all agree on this, but further explanantions were 
> required as to why the establishment of a PDP contextx could 
> be an indication of link-up

OK, but the current explanations are not accurate.

> The document aims at cataloguing events from various link 
> layer technologues. 802.21 is not a link layer technology. It 
> is intending at optimizing and facilitating handovers across 
> link layer technologies. In that respect, 802.21 is not to be 
> listed along GPRS, CDMA1x-EVDVO or 802.11. However there are 
> definitely links between the aim of the document and the 
> scope of 802.21

I was not thinking that there should anything other than a mention
that 802.21 is working on some of the same issues, maybe that is 
enough.

John