Subject: Re: [DNA] Question regarding prefix assignment

From: Sathya Narayanan <[email-masked]>
Date: Tue, 08 Mar 2005 12:25:34 -0500

JinHyeock -

I guess the issue is with the on-link flag setting, right? The cpl draft assumes either 'on-link' or 'addrconf' flag or both MUST be set for cpl to work. 

But is it possible for a PIO with the 'on-link' flag NOT set (A - bit set) to be advertised on two separate links? The X in Tero's diagram will be the router that advertises prefix A on both the links without setting the on-link flag, and there will be another router on the left link that advertises prefix B with on-link flag set. Is that a feasible scenario? If yes, how often is it really done?

thanks,
Sathya 
----- Original Message -----
From: "Tero Kauppinen (JO/LMF)" <[email-masked]>
Date: Tuesday, March 8, 2005 11:52 am
Subject: Re: [DNA] Question regarding prefix assignment

> Hi JinHyeock,
> 
> JinHyeock Choi wrote:
> 
> > Let me clarify the above
> > 
> > When the routers send an RA advertising both A & B, the RA 
> > will be forwarded both through AP1 and AP2. Right?
> > 
> > If so, that means that AP2 advertise the prefix B which is not 
> > supported in that (L2) link. I don't think that is valid.
> 
> That is what I would think also, but because I'm not sure I'm asking.
> 
> However, I guess the above scenario is possible if X is some sort 
> of a 
> firewall. Please, don't ask whether it makes any sense to have 
> such a 
> scenario nor who would use such a configuration because I don't 
> have a 
> clue. :)
> 
> Br,
> 
> Tero
> 
> > 
> > Best Regards
> > 
> > JinHyeock
> 
>

---

From: Greg Daley <[email-masked]>
Date: Wed, 09 Mar 2005 04:36:58 +0000 (GMT)

----- Original Message -----
From: Brett Pentland <[email-masked]>
Date: Wednesday, March 9, 2005 2:39 am
Subject: Re: [DNA] Question regarding prefix assignment

> > I believe this scenario *could* be possible but I'm not sure any 
> sane> administrator would do this. If X is a vlan switch and the 
> switch allows
> > vlan tags to be switched to multiple ports, then you could have a 
> scenario> such as
> > 
> > vlan x = prefix A
> > vlan y = prefix B
> > 
> > and
> > 
> > vlan x switched to AP2 and AP1
> > vlan y switched to AP1 (thus only AP1 gets RAs for prefix B)
> > 
> > The only reason I can think of why anyone would do this is if 
> there is some
> > administrative reason why only AP1 should see prefix B. Perhaps 
> this would
> > be a restricted prefix that equates to an SSID for a 'top secret' 
> meeting> room.
> 
> I think that in this case, we would detect attachment to the VLANs. 
> If
> we attach to AP2, vlan x, we receive prefix A.  If we move to AP1, 
> vlanx, we see prefix A, and should through some means decide that 
> we have 
> not moved (logically) and our configuration is still valid.
> 
> If we move to AP1, vlan y, we see prefix B and through some means 
> should 
> decide that we have moved and need to reconfigure.
> 
> If we move to AP1 and can receive packets from both vlans x and y 
> at the 
> same time, then things get messy.  If we can abstract connections 
> to 
> vlans as virtual interfaces, then we can probably treat them 
> separately 
> and apply DNA on a per-virtual-interface basis.  If not, then I'm 
> not 
> sure how best to deal with the situation.
> 
> Any thoughts?

Logical tunnel interfaces or connection identifiers
are fairly common.

Greg
> Brett.