Subject: Re: [DNA] No FastRA unless Landmark?(draft-pentland-dna-protocol-00)

From: Sathya Narayanan <[email-masked]>
Date: Wed, 01 Jun 2005 21:43:34 -0400

Greg -

> 
> The question wasn't about completeRA, it was about FastRA.
Yes - I understand (understood) this, but I was thinking without a completeRA the hosts will not be able to really answer the 'Link change question' - please see below.

> Non-DNA hosts aren't going to benefit from the RA's DNA content,
> but they are going to benefit from a fast response.
I guess, here is the problem in my understanding - do the non-DNA hosts  really benefit from receiving fastRA that is NOT complete. What would you like to include in these RA messages? 

Including all PIOs may help - atleast if there was no link change, because the host will see a prefix it is using in one of the RA messages. If there was a link change, the non-DNA host will still have to wait for MAX_RA_DELAY_TIME before they decide that they have moved, which is still better than waiting for the multicast. This is a cost-benefit question, is it worth the extra messages to support non-DNA hosts? I don't have an opinion on this.

<snip> 
> (Now visiting the CompleteRA without Landmark solicitation issue).
<snip>
> 
> Why doesn't it know? because without the landmark you can't tell that it's DNA capable.
> 
> Fortunately, there are plenty of bits left in the RS header (32)
> which could be used to identify a DNA solicitation without divulging
> the last attached prefix of the host in a landmark option.

Yeah - we can do this. We just need to be aware that sending unicast-completeRA at fastRA rate from all routers for every received RS message makes the amplification effect more deadly.

> 
> Please be aware that I personally consider location privacy to be a 'big issue'.

I don't understand this concern. When a IPv6 hosts transmits IPv6 packets on the network wouldn't its IPv6 address become public immediately - or when it responds to NS message for that matter - what information are you trying to protect by not including a landmark option in the RS message. Please explain.

- Sathya

---

From: Greg Daley <[email-masked]>
Date: Thu, 02 Jun 2005 12:00:12 +1000

Hi Sathya,

> Greg -
[cut]
> 
> Including all PIOs may help - atleast if there was no link change, because the
 > host will see a prefix it is using in one of the RA messages. If 
there was a
 > link change, the non-DNA host will still have to wait for 
MAX_RA_DELAY_TIME
 > before they decide that they have moved, which is still better than 
waiting
 > for the multicast. This is a cost-benefit question, is it worth the extra
 > messages to support non-DNA hosts? I don't have an opinion on this.

I think you're assuming that they employ lazy cell switching.

There are various heuristics already available in the research
and implementation spaces (MIPv6 is a PS...).

Additionally, the host may have other reasons to believe link
change is required, even if it was implemented before DNA
is standardized (such as it uses FMIPv6, or is on a particular
access technology).

We don't need to force devices to change (O/S) code in order to
provide them with a useful service.

> Yeah - we can do this. We just need to be aware that sending unicast-completeRA
 > at fastRA rate from all routers for every received RS message makes the
 > amplification effect more deadly.

It really depends on the tokens and how they're used.  If a token
provides ABC (appropriate byte counting), then the transmission of
a message with completeRA would diminish the number of RA messages to
be sent.

This in effect would mean that peak FastRA bandwidth would be
prescribed.

> I don't understand this concern. When a IPv6 hosts transmits IPv6 packets on
 > the network wouldn't its IPv6 address become public immediately - or 
when it
 > responds to NS message for that matter - what information are you 
trying to
 > protect by not including a landmark option in the RS message. Please 
explain.

How about if I used a different MAC address and IPv6 address (+key?)
to do DNA every time I got a link up indication?

If I was on the same link, I could go back to my existing identity.

This temporary identity couldn't be tied back to my existing identity.

Greg