Subject: Re: [DNA] Re: Flash renumbering

From: Sathya Narayanan <[email-masked]>
Date: Thu, 28 Jul 2005 21:04:05 -0400

Erik -

I have a question and a comment.

What is your take on the likelihood of the number of  prefixes on the link being large so that they cannot fit in a single CompleteRA?

<snip>
> > So, let me bring #prefixes back instead of the complete bit, here is
> > what I propose when the prefixes don't fit in one RA:
> > 1) Divide the prefixes into groups with atleast one common prefix so
> > that each group will fit in a single RA.
> > 2) Set the #prefixes field in the DNAO to the total number of prefixes
> > (The semantics for this is "This is the number of prefixes on the link *I* know of").
> 
> I don't think #2 can work in a robust manner unless we apply normal 
> fragmentation/reassembly to such large RAs. And I don't think we need this complexity.

I think I know why you say this. Anyway, #1 is still needed in the draft - we should include this in the issues list.

thanks,
Sathya

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 29 Jul 2005 07:52:51 -0700

Sathya Narayanan wrote:
> What is your take on the likelihood of the number of  prefixes on the
> link being large so that they cannot fit in a single CompleteRA?

Two different answers:
I guess the probability is 1.0 that somebody somewhere will configure
such a link.

I guess that this will be very unlikely in common operations, thus the
probability of a link selected at random will have such a large number
of prefixes could be very small. (As we understand it today, multiple
prefixes help with graceful renumbering, and are used in scalable
multihoming, but I don't today see an argument for this resulting in
more than a handful of prefixes.)

> I think I know why you say this. Anyway, #1 is still needed in the
> draft - we should include this in the issues list.

ok

    Erik