Subject: RE: [DNA] [Issue X] LinkID v.s. Landmark Prefix

From: "Tero Kauppinen (JO/LMF)" <[email-masked]>
Date: Tue, 26 Jul 2005 14:28:00 +0200

Hello Subba,

> > > Assume a link with two routers R1 and R2 and a host H.
> > > R1 advertises Prefix1 and R2 Prefix2.
> > >
> > > R2 stops advertising Prefix2 and starts advertising Prefix3.
> > > R2 announces the prefix change by sending an RA but
> > > both R1 and H don't receive it.
> > >
> > > Then H happens to change its AP in the same link
> > > and send an RS with landmark Prefix2. It also happens that
> > > R2 replies first and sends an RA with NO and Prefix3.
> > > H falsely assumes a link change.
> >
> > But isn't it actually so that in this case the host shouldn't use an
> > address based on Prefix2 and thus reconfiguration is required (i.e.
link
> > change from host H point of view)? After all, Prefix2 is not anymore
> > valid.
> 
> I think, host can not assume link change, if one of the prefixes is
> invalid.
> In the case of link change, host deletes all its addresses, prefix
table
> and
> NC entries,
> which is not the exact case if prefix changes.
> 
> In the above example, entries with Prefix1 are still valid.

True. Still, as in the mail I sent earlier, I started wondering how the
node knows to "switch" to use an address based on Prefix1?

/Tero

---

From: Subba Reddy <[email-masked]>
Date: Tue, 26 Jul 2005 18:12:22 +0530

Hi Tero,

<cut>

> node knows to "switch" to use an address based on Prefix1?

I think, after some time, H may get RA with Prefix2 lifetimes
set to 0 from R2.