Subject: Re: [DNA] DNA proposal issue 19 - was [IssueX]LinkIDv.s.LandmarkPrefix

From: Sathya Narayanan <[email-masked]>
Date: Fri, 22 Jul 2005 09:29:09 -0400

----- Original Message -----
From: JinHyeock Choi <[email-masked]>
Date: Friday, July 22, 2005 1:53 am
Subject: Re: [DNA] DNA proposal issue 19 - was [Issue	X]LinkIDv.s.LandmarkPrefix

> Dear Sathya
> 
> > So, in conclusion, the synchronization requirement and
> > complexity for Landmark, CompleteRA and LinkID are the same - 
> all three
> > of them require that all the routers on the link know about all the
> > prefixes on the link within a reasonable time - the difference 
> is only
> > in the content of the RS/RA messages. Do you agree?
> 
> No. Linkid draft deals with synchronization problem by taking 
> extra 
> care of linkid prefix with such schemes as "linkid prefix list" or 
> "linkid 
> prefix lifetime". It's my guess that, for CompleteRA or Landamrk, 
> such 
> extra cares need to be be applied to all the prefixes. 
> 
If the LinkID is being chosen based on some rule (the smallest prefix in the Complete Prefix List) applied to the complete prefix list, then LinkID solution must also make sure that all the routers have the same list. I understand that the hosts maintain a LinkID list, but that doesn't make it OK to have routers in the same link to be advertising different LinkID.  (as an aside, it is more accurate to refer to this solution as LinkIDList - because AFAIK, the host, the router and the RA will contain a LinkIDList - the list may contain one or more entries - right?).

Sathya

---

From: JinHyeock Choi <[email-masked]>
Date: Sat, 23 Jul 2005 14:43:49 +0900

Dear Sathya

> If the LinkID is being chosen based on some rule (the smallest prefix in the Complete 
> Prefix List) applied to the complete prefix list, then LinkID solution must also make sure 
> that all the routers have the same list. I understand that the hosts maintain a LinkID list, 
> but that doesn't make it OK to have routers in the same link to be advertising different LinkID.  

Actually it's ok. I designed Linkid such that hosts make a correct decision 
even under such a temporary asynchornization.   

> (as an aside, it is more accurate to refer to this solution as LinkIDList - 
> because AFAIK, the host, the router and the RA will contain a LinkIDList - 
> the list may contain one or more entries - right?).

No, the routers use a single linkid prefix at any given time, 
but due to the possibility that the linkid prefix changing, 
the hosts track the set of linkid prefixes. You may check 
"Comments on linkid draft" thread in DT ML. (Actually this 
is the confusion I was afraid when Erik suggested the 
Linkid List idea. :-( )

Thanks in advance for your kind consideration. 

Best Regards

JinHyeock

---

From: Subba Reddy <[email-masked]>
Date: Sat, 23 Jul 2005 11:33:02 +0530

Hi Satya,

> If the LinkID is being chosen based on some rule
> (the smallest prefix in the Complete Prefix List) applied to the complete
prefix list,
> then LinkID solution must also make sure that all the routers have the
same list.

The prefix list can differ for sometime (1.5 hrs) because of additiion or
change in
prefix life time (i.e, if lifetime goes less than 3 hrs).

> I understand that the hosts maintain a LinkID list, but that doesn't make
it OK
> to have routers in the same link to be advertising different LinkID.

Routers can be advertising different LinkIDs at a given point of time.
But hosts will not make wrong decision because of LinkID list maintained at
hostFrom [email-masked] Sun Jul 24 23:36:06 2005
Date: Sun, 24 Jul 2005 23:50:52 +0200
From: Christian Vogt <[email-masked]>
Subject: Re: [DNA] New I-D: draft-vogt-dna-relocation-00.txt
Sender: [email-masked]
To: Erik Nordmark <[email-masked]>
Cc: Brett Pentland <[email-masked]>,
        DNA <[email-masked]>, TM-RO2 <[email-masked]>

Hi Erik.

 >> - Host sends RS with optimistic unicast source address and TSLLAO
 >> - Router replies with unicast RA (using LLA from TSLLAO)
 >> - Host only then sends MLD report (after delay)
 >> - Host send NS for oDAD
 >
 > Looks good to me.
 >
 > Presumably the last step isn't needed if the host didn't move to a
 > different link. (One might think the same thing applies to the third
 > item, but due to MLD/IGMP snooping L2 devices, that wouldn't be safe
 > when the host has changed its L2 attachment point.)

Right, ODAD can be canceled when the mobile node learns from the RA that 
it is still on the same IP link.

 >> [...]                                               I guess this
 >> might come up if the host is a mobile node and tries to perform
 >> route optimization with a node that just happens to be connected
 >> to the same link as itself.
 >
 > But in that ca143])
	by moe.its.monash.edu.au (Postfix) with ESMTP id 7DEF84FB02; Mon,
 25 Jul 2005 13:31:58 +1000 (EST)
Date: Sat, 23 Jul 2005 11:33:02 +0530
From: Subba Reddy <[email-masked]>
Subject: Re: [DNA] DNA proposal issue 19 - was	[IssueX]LinkIDv.s.LandmarkPrefix
Sender: [email-masked]
To: Sathya Narayanan <[email-masked]>,
        JinHyeock Choi <[email-masked]>
Cc: Syam Madanapalli <[email-masked]>,
        Syam Madanapalli <[email-masked]>,
        [email-masked],
        Brett Pentland <[email-masked]>,
        James Kempf <[email-masked]>, Dna <[email-masked]>

Hi Satya,

> If the LinkID is being chosen based on some rule
> (the smallest prefix in the Complete Prefix List) applied to the complete
prefix list,
> then LinkID solution must also make sure that all the routers have the
same list.

The prefix list can differ for sometime (1.5 hrs) because of additiion or
change in
prefix life time (i.e, if lifetime goes less than 3 hrs).

> I understand that the hosts maintain a LinkID list, but that doesn't make
it OK
> to have routers in the same link to be advertising different LinkID.

Routers can be advertising different LinkIDs at a given point of time.
But hosts will not make wrong decision because of LinkID list maintained at
host side.

>the list may contain one or more entries - right?).

This may not be correct. Most of the time only one LinkID will be there in
the LinkID
list. If the prefix list changes, which causes change in LinkID, only then
more than
one prefix will present in LinkID list. And this is a very rare case.

> Sathya

Thanks & Regards,
Subba Reddy

se wouldn't the new host send a NS as part of
 > communicating with the CoA of the peer? I guess it depends on the
 > details of any MIPv6 RO procedure.

The mobile node should be fine when it uses a TSLLAO in the NS (and the 
peer understands the TSLLAO).

- Christian

-- 
Christian Vogt, Institute of Telematics, University of Karlsruhe
www.tm.uka.de/~chvogt/pubkey/

Erik Nordmark wrote:
> Brett Pentland wrote:
> 
>> Regarding the potential solution in section 4.2, I gather you are
>> talking about something like:
>>
>> - Host sends RS with optimistic unicast source address and TSLLAO
>> - Router replies with unicast RA (using LLA from TSLLAO)
>> - Host only then sends MLD report (after delay)
>> - Host send NS for oDAD
> 
> 
> Looks good to me.
> 
> Presumably the last step isn't needed if the host didn't move to a 
> different link. (One might think the same thing applies to the third 
> item, but due to MLD/IGMP snooping L2 devices, that wouldn't be safe 
> when the host has changed its L2 attachment point.)
> 
>   > This sounds good for most communications (assuming that most
> 
>> communications with the host go through the router).  There
>> might still be a bit of a problem if an on-link device (other
>> than the router) tries to send a packet to the optimistic
>> address before the MLD report goes out since the host won't
>> receive the resulting NS from this on-link node.  I guess this
>> might come up if the host is a mobile node and tries to perform
>> route optimization with a node that just happens to be connected
>> to the same link as itself.
> 
> 
> But in that case wouldn't the new host send a NS as part of 
> communicating with the CoA of the peer? I guess it depends on the 
> details of any MIPv6 RO procedure.
> 
>    Erik
>

---

From: Subba Reddy <[email-masked]>
Date: Sat, 23 Jul 2005 11:33:02 +0530

Hi Satya,

prefix list,
same list.

it OK

Thanks & Regards,
Subba Reddy