Subject: [DNA] Re: LinkID v.s. Landmark Prefix

From: Greg Daley <[email-masked]>
Date: Wed, 27 Jul 2005 15:15:29 -0400

Hi JinHyeock, 

Please don't be shocked, I may agree with
you in this e-mail.

----- Original Message -----
[cut]
> > I haven't thought through all the details, but the fact that 
> landmark 
> > falls back on prefix comparisons, and linkID handles routers 
> that 
> > temporarily disagree on the linkID, might imply that these 
> schemes could 
> > be confused when the link up is missing. If that's the case we 
> can't 
> > make the solution robust against a missing link up.
> 
> We intended Linkid scheme not to depend on Link UP and the 
> scheme is supposed to work rubustly even without any Link UP 
> notificaiton.

I'd prefer something which could work even if the host's
driver wasn't able to provide Link Up indications.

While my host implementation basically assumes them, 
not all drivers and operating systems do (or even will)
support them.

In some media (for example, CDMA-like media) it may be
difficult to distinguish when one base station is "UP"
or not, since multiple base-stations are visible.

So understanding if the schemes would work without
indications is useful, if this is a goal.

> We can't deny the possibility of confusion (even Titanic
> sank in its maiden voyage :-)) but can't find the example yet. 

I've got a case where all 3 (CompleteRA, Landmark, LinkID)
schemes fail, and I've written it out 3 times, with just
the names of the schemes changed (It is a corner case though).

At the moment I'm not able to connect my own computer to 
my visited network, but will post it for everyone, when able.
It's not meant to prove any scheme is better than another,
just that all the schemes are fallible.

Some of the simple safety measures proposed would recover
any of the solutions (Aim #2 from the other thread), and some
would limit the possibility of it occurring (Recommendations
for flash renumbering).

These may be sufficient, with or without advertisement of 
the old LinkID.

Greg

---

From: JinHyeock Choi <[email-masked]>
Date: Thu, 28 Jul 2005 08:25:23 +0900

Dear Greg

> Please don't be shocked, I may agree with

What a nice shock! I hope to have such a surprise many many 
more times that it won't be a surprise any longer. :-)

> indications is useful, if this is a goal.

ok. 

> my visited network, but will post it for everyone, when able.

ok. We'd like to see the case. It may show us the way for 
improvement. 

Thanks for your kind consideration. 

Best Regards

JinHyeock