Subject: RE: [DNA] [Issue X] LinkID v.s. Landmark Prefix

From: "Tero Kauppinen (JO/LMF)" <[email-masked]>
Date: Tue, 26 Jul 2005 14:45:50 +0200

> This is the host problem and is same problem if the router suddenly
> stops advertising prefix 2. I looked into 2462bis and found the
following
> text:
> 
> 5.5.3  Router Advertisement Processing
> 
> ---
> 
> d) If the prefix advertised is not equal to the prefix of an address
>       configured by stateless autoconfiguration already in the list of
>       addresses associated with the interface (where "equal" means the
>       two prefix lengths are the same and the first prefix-length bits
>       of the prefixes are identical), and the Valid Lifetime is not 0,
>       form an address (and add it to the list) by combining the
>       advertised prefix with the link's interface identifier
> 
> If the node did not configure the address based on prefix 1 then
> it should either wait till the prefix 2 life time expiry or if the
router
> does not support forwarding for the prefix 2, an intelligent host can
> configure new address using prefix 1 based on packet loss. I am
> not sure about choosing new address based on packet loss.

True. In the middle of this confusion I didn't think that the node could
indeed configure itself multiple addresses. It's then up to the source
address selection logic to decide which one to use.
 
Thanks,
Tero

---

From: Greg Daley <[email-masked]>
Date: Sat, 30 Jul 2005 09:06:25 +1000

Hi JinHyeock, 

----- Original Message -----
[cut]
> 
> ok. Also I wish we make it clear how Landmark/ CompleteRA 
> checks for link change. For example, Erik proposed that 
> a known prefix in an RA would overrule the NO in Landmark
> option. But that is not reflected in the draft. 

The issue and resolution was raised after the draft cut-off.

I think Brett is travelling now, but I'll ask him to make
a new issue to track this at:

http://ctieware.eng.monash.edu.au/twiki/bin/view/DNA/DNASolution1

Greg.

---

From: Sathya Narayanan <[email-masked]>
Date: Sat, 30 Jul 2005 15:27:42 -0400

Erik -

> So it seems like until every link in the Internet supports DNA (it isn't 
> clear to me whether all routers on every link needs to support DNA, or 
> whether it is sufficient to have one per link support it),
It isn't clear to me either. But, IMHO, we should select a solution which works well in a link with both DNA and non-DNA routers.

> then the hosts MUST rely on a reliable link up notification in order to always be 
> able to detect movement. Is that correct?
We discussed this when the comparison slide sent by Greg was prepared. A CompleteRA message from the DNA router can tie all the prefixes on the link together and hence the host need not depend on link-up notification. Also, with prefix-landmark, if the host sends an RS with a prefix advertised by a non-DNA router, a DNA router will still confirm the prefix's presence on the link.

- Sathya