Subject: [DNA] Linkid Draft Implementation and Test Results

From: Syam Madanapalli <[email-masked]>
Date: Tue, 12 Jul 2005 12:31:39 +0530

Dear DNA WG,

We have implemented the following Linkid draft  

DNA Solution: Link Identifier based approach 
http://www.diffeo.com/drafts/draft-jinchoi-dna-protocol2-01.txt

and set up a test bed to conducted a few experiments. 

We are glad to say that everything worked fine and you 
can find the result in 

http://www.diffeo.com/test/Linkid_Implementation.ppt

In brief, the code is not so complex to write (390 line for a router 
and 160 lines for a host.) and our testbed consists of 2 links having 
3 router interfaces respectively (as described in slide 3). 

We have tested the cases of "Initialization", "Linkid change (Linkid 
prefix addition & deletion)" and "Link change" and the results were
as expected. Routers agreed on the same linkid in a second and 
a host correctly checked for the link change. 
- When a linkid is changed without link change, the host simply 
  changed its linkid prefix without falsely assuming a link change. 
- When the host moved to a different link, the host correctly 
  detected a link change  and changed its linkid prefix. 

Your feedback will be appreciated. 

Regards,
Syam

---

From: Brett Pentland <[email-masked]>
Date: Tue, 12 Jul 2005 17:34:46 +1000

Hi Syam,

Good work!  It's nice to see some real-world results.  I just
have a few quick questions about your test setup.  Is it possible
to add any imparements?  It's excellent to see it all working
properly, but it would be good to also be able to see what
happens in some less common situations like when packet loss
occurs, or when handover takes place during a renumbering
event.  It might be tricky to coordinate a handover to happen
during a renumbering event, but packet loss mightn't be too
hard.

Also, what does your host do with it's address configuration,
neighbour cache, etc. when it does detect change?  Greg has
been working here on an implementation of landmark-based link
identification, and I believe that so far the DNA process is able
to make decisions correctly, but at this point it doesn't
actually modify the address configuration (correct me if I'm
wrong Greg).  Have you managed to tie it all together?

One last question: how are the RAs received by the host?  Are
they solicited or unsolicited?

Cheers,
Brett.

Syam Madanapalli wrote:
> We are glad to say that everything worked fine and you can find the 
> result in
> In brief, the code is not so complex to write (390 line for a router and 
> 160 lines for a host.) and our testbed consists of 2 links having 3 
> router interfaces respectively (as described in slide 3).
> as expected. Routers agreed on the same linkid in a second and a host 
> correctly checked for the link change. - When a linkid is changed 
> without link change, the host simply  changed its linkid prefix without 
> falsely assuming a link change. - When the host moved to a different 
> link, the host correctly  detected a link change  and changed its linkid 
> prefix.

---

From: Syam Madanapalli <[email-masked]>
Date: Tue, 12 Jul 2005 14:51:21 +0530

Hi Brett,

> during a renumbering event, but packet loss mightn't be too

We did not simulate any packet loss in our testbed. Also we have
not tested with flash renumbering. We tested with graceful
renumbering without any problems.

> wrong Greg).

Our status is almost same.
We were just testing the behavior of linkid based approach
under various cirumstances.
Currently, in case of link change we are just deleting the existing
addresses and NC, and configuring new address using
new prefix on the new link.

> Have you managed to tie it all together?
>

We are using the unsolicited RAs. so hosts don't
have to send an RS to check for link change but
it may delay the link change decision if we do
not get quick RA. But depending on unsolicited RAs
may be good for host that do not support L2 hint.

We are also thinking to implement L2 hint to
trigger RS.

>
> Cheers,
> Brett.
>
> Syam Madanapalli wrote:
>> Dear DNA WG,
>>
>> We have implemented the following Linkid draft DNA Solution: Link 
>> Identifier based approach 
>> correctly checked for the link change. - When a linkid is changed without 
>> link change, the host simply  changed its linkid prefix without falsely 
>> assuming a link change. - When the host moved to a different link, the 
>> host correctly  detected a link change  and changed its linkid prefix.