Subject: RE: [DNA] draft-koodli-dna-fmip-00.txt

From: Junghoon Jee <[email-masked]>
Date: Sat, 16 Jul 2005 22:40:53 +0900

Hi Syam,
It's an interesting work. 
After reviewing this I-D, I've come up with a following question.

About the role of HI/HACK in this reactive FMIPv6-DNA :
I thought that these messages are required to confirm the MN's prospective NCoA in predictive mode. 
In the FMIPv6-DNA, MN configures the NCoA by optimistic DAD in the reactive mode, 
so why do those messages needed to be transferred and what's their roles ? 
Just to prepare for future optional behavior the same as specified in the draft-ietf-mipshop-fast-mipv6-03 ? 
I guess that my question may also apply to the reactive mode of draft-ietf-mipshop-fast-mipv6-03.

Regards, 
Junghoon

> -----Original Message----- 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> Syam Madanapalli 
> Sent: Saturday, July 16, 2005 8:02 PM 
> To: [email-masked] 
> Cc: Rajeev Koodli 
> Subject: [DNA] draft-koodli-dna-fmip-00.txt 
> 
> 
> Dear DNA WG, 
> 
> We have published a new draft on FMIPv6 Usage with DNA Protocol. 
> 
>       Title           : FMIPv6 Usage with DNA Protocol 
>       Author(s)       : R. Koodli, S. Madanapalli 
>       Filename        : draft-koodli-dna-fmip-00.txt 
>       Pages           : 7 
>       Date            : 2005-7-15 
>      
>    In this document, we describe how the Fast Mobile IPv6 Handovers 
>    (FMIPv6) protocol can work where DNA protocol support is available, 
>    but the neighborhood information, which is part of the FMIPv6 
>    operation, is not available. 
> 
> A URL for this Internet-Draft is: 
> http://www.ietf.org/internet-drafts/draft-koodli-dna-fmip-00.txt 
> 
> Please provide your comments. 
> 
> Thank you, 
> Syam

---

From: Syam Madanapalli <[email-masked]>
Date: Mon, 18 Jul 2005 14:03:32 +0530

Hello Junghoon,

Thanks for reviewing the draft.

> draft-ietf-mipshop-fast-mipv6-03.

As you mentioned, currently there is no new use of HI/HACK other than
what is mentioned in FMIPv6 RFC.  That is, NAR can make use of the
knowledge that its trusted peer (i.e., PAR) has a trust relationship with 
the
MN.