Subject: [DNA] Merger: Unmodified Messages/Modified Messages (3)

From: Greg Daley <[email-masked]>
Date: Fri, 12 May 2006 20:50:45 -0400

Hi,

Here's another proposal for merging the documents.
Essentially, this takes CPL and HOSTS and puts
them together (COMBO3A), while putting the other documents
which modify message formats together PROTO and Tentative
(COMBO3B).

As an aside, there's clearly a lot of overlap between Hosts
and CPL, which can be reduced.

Greg

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
COMBO3A:  Unmodified Messages.
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

1.   Introduction CPL-02
1.  Introduction  HOSTS-03
     1.1   Structure of this Document HOSTS-03

2.  Terms and Abbreviations  HOSTS-03

3.  Background & Motivation for DNA HOSTS-03
  3.1   Issues HOSTS-03
2.   Prefix list based approach CPL-02 
  2.1  Approach CPL-02 
  2.2  Assumptions CPL-02 
  2.3  Overview CPL-02 

4.  Detecting Network Attachment Steps HOSTS-03
  4.1   Making use of Prior Information HOSTS-03
  4.2   Link identification HOSTS-03
    4.2.1   Same link HOSTS-03
    4.2.2   Link change HOSTS-03
  4.3   IP Hosts Configuration HOSTS-03
  4.4   Duplicate Address Detection HOSTS-03
  4.5   Multicast Listener State HOSTS-03
  4.6   Reachability detection HOSTS-03

3.   DNA based on the Complete Prefix List CPL-02 
  3.1  Complete Prefix List generation CPL-02 
  3.2  Erroneous Prefix Lists CPL-02  
  3.3  Link identity detection CPL-02  
  3.4  Renumbering CPL-02  

4.   Protocol Specification CPL-02 
  4.1  Conceptual data structures CPL-02 
  4.2  Merging Candidate Link objects CPL-02 
  4.3  Timer handling and Garbage Collection CPL-02  
  4.4  Receiving link UP notifications CPL-02 
  4.5  Receiving valid Router Advertisements CPL-02 
  4.6  Changing the link in Neighbor Discovery CPL-02 

5.  Initiation of DNA Procedures HOSTS-03
  5.1   Actions Upon Hint Reception HOSTS-03
  5.2   Hints Due to Network Layer Messages HOSTS-03
  5.3   Handling Hints from Other Layers HOSTS-03
  5.4   Timer and Loss Based Hints HOSTS-03
  5.5   Simultaneous Hints HOSTS-03
  5.6   Hint Management for Inactive Hosts HOSTS-03

6.  Complications to Detecting Network Attachment HOSTS-03
  6.1   Packet Loss HOSTS-03
  6.2   Router Configurations HOSTS-03
  6.3   Overlapping Coverage HOSTS-03
  6.4   Multicast Snooping HOSTS-03
  6.5   Link Partition HOSTS-03
5.   CPL without a 'link UP' notification CPL-02 

6.   IANA Considerations CPL-02  

7.   Security Considerations CPL-02 
7.  Security Considerations HOSTS-03
  7.1   Authorization and Detecting Network Attachment HOSTS-03
  7.2   Addressing HOSTS-03

8.  Constants HOSTS-03
9.   Protocol Constants CPL-02

#
# Appendixes
#

8.   Examples CPL-02 
  8.1  Example CPL-02 
  8.2  Example CPL-02  

11.  Performance Analysis CPL-02

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
COMBO3B: Modified Messages
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

1.   Introduction PROTO-00
1.  Introduction TENT-00

2.   Terms and Abbreviations PROTO-00

3.   Overview PROTO-00
  3.1  Link Identification PROTO-00
  3.2  Fast Router Advertisement PROTO-00

4.   Message Formats PROTO-00
  4.1  Router Advertisement PROTO-00
  4.2  Prefix Information Option LinkID Bit PROTO-00
  4.3  Landmark Option PROTO-00
  4.4  Learned Prefix Option PROTO-00
  1.1   Tentative Option format TENT-00
  1.2   Tentative Option semantics TENT-00

5.   DNA Operation PROTO-00
  5.1  DNA Router Operation PROTO-00
    5.1.1  Data Structures PROTO-00
    5.1.2  Router Configuration Variables PROTO-00
    5.1.3  Bootstrapping DNA Data Structures PROTO-00
    5.1.4  Processing Router Advertisements PROTO-00
    5.1.5  Processing Router Solicitations PROTO-00
3.  Receiving Tentative Options TENT-00
  3.1   Handling Tentative Options TENT-00 
  3.3   Receiving Router Solicitations containing Tentative TENT-00
        Options TENT-00

    5.1.6  Complete Router Advertisements PROTO-00
    5.1.7  LinkID PROTO-00
    5.1.8  Scheduling Fast Router Advertisements PROTO-00
    5.1.9  Scheduling Unsolicited Router Advertisements PROTO-00
    5.1.10   Removing a Prefix from an Interface PROTO-00
    5.1.11   Prefix Reassignment PROTO-00
  5.2  DNA Host Operation PROTO-00
    5.2.1  Data Structures PROTO-00
    5.2.2  Host Configuration Variables PROTO-00
    5.2.3  Selection of a Landmark Prefix PROTO-00
    5.2.4  Sending Router Solicitations PROTO-00
2.  Sending solicitations containing Tentative Options TENT-00 
  2.2   Sending Router Solicitations with Tentative Options TENT-00

    5.2.5  Processing Router Advertisements PROTO-00
    5.2.6  DNA and Address Configuration PROTO-00

6.   Backward Compatibility PROTO-00
  6.1  Non-DNA Host with DNA Routers PROTO-00
  6.2  DNA Host with Non-DNA Routers PROTO-00

7.   Security Considerations PROTO-00
  7.1  Attacks on the Token Bucket PROTO-00
  7.2  Attacks on DNA Hosts PROTO-00
5.  Security Considerations TENT-00

8.   IANA Considerations PROTO-00
4.  IANA Considerations TENT-00 

A.   How the Goals are Met? PROTO-00

  2.1   Sending Neighbour Solicitations with Tentative Options TENT-00 
  3.2   Receiving Neighbour Solicitations containing Tentative TENT-00
        Options TENT-00

A.  Constraints imposed by IPv6 Neighbour Discovery TENT-00
  A.1   Constraints on Neighbour Solicitations TENT-00
  A.2   Constraints on Router Solicitations TENT-00

B.  Interactions with legacy nodes TENT-00
  B.1   Legacy Neighbour Solicitation processing TENT-00 
  B.2   Legacy Router Solicitation processing TENT-00 

C.  Sending directed advertisements without the neighbour cache TENT-00

---

From: [email-masked]
Date: Tue, 16 May 2006 17:06:18 -0700

Greg,

I would vote for this. I don't see any overlap in 3A and 3B
and hence COMBO2 (option of putting them all together) does
not make sense to me.

-mohan

>-----Original Message-----
>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of 
>ext Greg Daley
>Sent: Friday, May 12, 2006 5:51 PM
>To: [email-masked]
>Cc: [email-masked]
>Subject: [DNA] Merger: Unmodified Messages/Modified Messages (3)
>
>Hi,
>
>Essentially, this takes CPL and HOSTS and puts them together 
>(COMBO3A), while putting the other documents which modify 
>message formats together PROTO and Tentative (COMBO3B).
>
>    5.1.5  Processing Router Solicitations PROTO-00 3.  
>Receiving Tentative Options TENT-00
>    5.2.4  Sending Router Solicitations PROTO-00 2.  Sending 
>solicitations containing Tentative Options TENT-00

---

From: Sathya Narayanan <[email-masked]>
Date: Wed, 17 May 2006 11:42:11 -0400

Greg -

I like COMBO3 too. I agree with Mohan that COMBO2 doesn't necessarily
make that much sense. IMHO, the issue here is not only which combination
is the best but also which combination is doable in a reasonable time
frame. Ofcourse, I understand how much weight each should take is a
matter of opinion - I am concerned about the workload involved in
creating COMBO2 and the possible confusion that can result, while
providing very little or no benefit.

And as you mentioned, I think the merger of hosts and CPL can be done
with a significant reduction in the overall text.

- Sathya