Subject: [DNA] Merger: All Documents together (2)

From: Greg Daley <[email-masked]>
Date: Fri, 12 May 2006 20:46:54 -0400

Hi,

This is an amalgamation of the DNA documents together
in a form roughly inspired by RFC2461 Neighbor Discovery.

This embodies an example of option 2 for document merger.

Please note that there are duplicate section names, and
each actual section may cover overlapping topics with 
other protocols.  Please try to ignore this fact initially,
and concentrate on the overall structure of the document.

When Referring to this proposal, it may be useful to describe
it at COMBO2.

Greg

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
COMBO2: All combined
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

1.  Introduction HOSTS-03
1.  Introduction CPL-02
1.  Introduction PROTO-00
1.  Introduction TENT-00

     1.1   Structure of this Document HOSTS-03

2.  Terms and Abbreviations  HOSTS-03
2.   Terms and Abbreviations PROTO-00

3.  Background & Motivation for DNA HOSTS-03
  3.1   Issues HOSTS-03

#
# Conceptual Overview...???
#
#
3.   Overview PROTO-00
  3.1  Link Identification PROTO-00
  3.2  Fast Router Advertisement PROTO-00

#
# Procedural Overview...???
#
#
4.  Detecting Network Attachment Steps HOSTS-03
  4.1   Making use of Prior Information HOSTS-03
  4.2   Link identification HOSTS-03
    4.2.1   Same link HOSTS-03
    4.2.2   Link change HOSTS-03
  4.3   IP Hosts Configuration HOSTS-03
  4.4   Duplicate Address Detection HOSTS-03
  4.5   Multicast Listener State HOSTS-03
  4.6   Reachability detection HOSTS-03

#
# Link Identification
#
#
2.   Prefix list based approach CPL-02 
  2.1  Approach CPL-02 
  2.2  Assumptions CPL-02 
  2.3  Overview CPL-02 
#
#  Cut down on some protocol explanations if shift
#  conceptual text here.
#
#
#

#
# Message Formats
#
#
4.   Message Formats PROTO-00
  4.1  Router Advertisement PROTO-00
  4.2  Prefix Information Option LinkID Bit PROTO-00
  4.3  Landmark Option PROTO-00
  4.4  Learned Prefix Option PROTO-00

  1.1   Tentative Option format TENT-00
  1.2   Tentative Option semantics TENT-00

#
#   Host Operations
#
#
  5.2  DNA Host Operation PROTO-00
    5.2.1  Data Structures PROTO-00
    5.2.2  Host Configuration Variables PROTO-00
4.   Protocol Specification CPL-02 
  4.1  Conceptual data structures CPL-02 

5.  Initiation of DNA Procedures HOSTS-03
  4.4  Receiving link UP notifications CPL-02 
  5.1   Actions Upon Hint Reception HOSTS-03
  5.2   Hints Due to Network Layer Messages HOSTS-03
  5.3   Handling Hints from Other Layers HOSTS-03
  5.4   Timer and Loss Based Hints HOSTS-03
  5.5   Simultaneous Hints HOSTS-03
  5.6   Hint Management for Inactive Hosts HOSTS-03

# Sending RSs
    5.2.4  Sending Router Solicitations PROTO-00
    5.2.3  Selection of a Landmark Prefix PROTO-00
2.  Sending solicitations containing Tentative Options TENT-00 
  2.1   Sending Neighbour Solicitations with Tentative Options TENT-00 
  2.2   Sending Router Solicitations with Tentative Options TENT-00

# Receiving RAs.
  4.5  Receiving valid Router Advertisements CPL-02 
    5.2.5  Processing Router Advertisements PROTO-00
  3.3  Link identity detection CPL-02  
  3.   DNA based on the Complete Prefix List CPL-02 
  3.1  Complete Prefix List generation CPL-02 
  4.2  Merging Candidate Link objects CPL-02 

  4.6  Changing the link in Neighbor Discovery CPL-02 
    5.2.6  DNA and Address Configuration PROTO-00

# Timers?????
  3.2  Erroneous Prefix Lists CPL-02  
  3.4  Renumbering CPL-02  
  4.3  Timer handling and Garbage Collection CPL-02  

#
#  Router Operations
#
#
  5.1  DNA Router Operation PROTO-00
    5.1.1  Data Structures PROTO-00
    5.1.2  Router Configuration Variables PROTO-00
    5.1.3  Bootstrapping DNA Data Structures PROTO-00
    5.1.4  Processing Router Advertisements PROTO-00
    5.1.5  Processing Router Solicitations PROTO-00
    5.1.6  Complete Router Advertisements PROTO-00
    5.1.7  LinkID PROTO-00
    5.1.8  Scheduling Fast Router Advertisements PROTO-00
    5.1.9  Scheduling Unsolicited Router Advertisements PROTO-00
    5.1.10   Removing a Prefix from an Interface PROTO-00
    5.1.11   Prefix Reassignment PROTO-00
3.  Receiving Tentative Options TENT-00
  3.1   Handling Tentative Options TENT-00 
  3.2   Receiving Neighbour Solicitations containing Tentative TENT-00
        Options TENT-00
  3.3   Receiving Router Solicitations containing Tentative TENT-00
        Options TENT-00

#
# Limitations of DNA
#
#
6.  Complications to Detecting Network Attachment HOSTS-03
  6.1   Packet Loss HOSTS-03
  6.2   Router Configurations HOSTS-03
  6.3   Overlapping Coverage HOSTS-03
  6.4   Multicast Snooping HOSTS-03
  6.5   Link Partition HOSTS-03

#
# Backward compatability
#
6.   Backward Compatibility PROTO-00
  6.1  Non-DNA Host with DNA Routers PROTO-00
  6.2  DNA Host with Non-DNA Routers PROTO-00
5.   CPL without a 'link UP' notification CPL-02 
  #
# Constants
#
#
8.  Constants HOSTS-03
9.  Protocol Constants CPL-02

#
# IANA Considerations
#
#
6.   IANA Considerations CPL-02  
8.   IANA Considerations PROTO-00
4.   IANA Considerations TENT-00 

#
# Security Considerations
#
#
7.  Security Considerations CPL-02 
7.  Security Considerations HOSTS-03
7.  Security Considerations PROTO-00
5.  Security Considerations TENT-00
  7.1  Attacks on the Token Bucket PROTO-00
  7.2  Attacks on DNA Hosts PROTO-00
  7.1   Authorization and Detecting Network Attachment HOSTS-03
  7.2   Addressing HOSTS-03

#
# Appendices
#
#
A.   How the Goals are Met? PROTO-00

11.  Performance Analysis CPL-02

8.   Examples CPL-02 
  8.1  Example CPL-02 
  8.2  Example CPL-02  

A.  Constraints imposed by IPv6 Neighbour Discovery TENT-00
  A.1   Constraints on Neighbour Solicitations TENT-00
  A.2   Constraints on Router Solicitations TENT-00

B.  Interactions with legacy nodes TENT-00
  B.1   Legacy Neighbour Solicitation processing TENT-00 
  B.2   Legacy Router Solicitation processing TENT-00 

C.  Sending directed advertisements without the neighbour cache TENT-00

---

From: James Kempf <[email-masked]>
Date: Sat, 13 May 2006 12:45:00 -0700

I like COMBO2. As I've said in the past, I believe having seperate documents 
that deal with micro-pieces of a protocol make it more difficult for 
implementors to follow given the primitive state of IETF's documentation 
technology.

            jak

---

From: Brett Pentland <[email-masked]>
Date: Tue, 16 May 2006 14:16:28 +1000

I like COMBO2.

The PROTO document is already dependent on both TENT and CPL and there
are synergies with what's in HOSTS as well.  If they were simple self
contained ideas (TENT is) then it might be good to keep them separate
but I don't think they are and the array of documents at the minute is
probably more confusing than helpful.

Combining them won't be trivial, and will require a really good
introduction to make it clear how the pieces go together, but it's
probably worth the effort.

One difficulty I see is that PROTO describes router behaviour, as well
as host behaviour, and I don't think it makes sense to separate them as
the protocol modifications only make sense when both sides are considered.

So do we pull the ROUTERS document in as well?  That I'm not sure about.
 Any thoughts, anyone?

Brett.

---

From: Greg Daley <[email-masked]>
Date: Tue, 16 May 2006 11:01:49 -0400

Hi Brett,

I guess the idea with leaving the 'routers' document
(which is being renamed network considerations) is that
it is solely a configuration guide for deployers
of existing equipment.

As it has a separate audience, perhaps it would be
best separate?

Greg

----- Original Message -----
From: Brett Pentland <[email-masked]>
Date: Tuesday, May 16, 2006 0:20 am
Subject: Re: [DNA] Merger: All Documents together (2)
To: Greg Daley <[email-masked]>
Cc: [email-masked], [email-masked]

> So do we pull the ROUTERS document in as well?  That I'm not sure 
> about. Any thoughts, anyone?
> 
> Brett.
> 
> >  2.1   Sending Neighbour Solicitations with Tentative Options 
> TENT-
> > 00

---

From: Nicolas Montavont <[email-masked]>
Date: Tue, 16 May 2006 18:59:27 +0200

Hi,

I also prefer combo02, it makes more sense to have all options for hosts 
into a single document.

About the router document, we could add a section on network 
configuration / consideration into the combo02, but I would prefer to 
keep it separate. As you said, it is really about network configuration 
only, and it would be better to have a short narrowed document.

Nicolas

Greg Daley wrote:

>>> 3.2   Receiving Neighbour Solicitations containing Tentative 
>>>      
>>>
>>TENT-00
>>    
>>
>>>       Options TENT-00

---

From: Brett Pentland <[email-masked]>
Date: Wed, 17 May 2006 09:51:50 +1000

Yes, that sounds reasonable.

Brett.

----- Original Message -----
From: Greg Daley <[email-masked]>
Date: Wednesday, May 17, 2006 1:04 am
Subject: Re: [DNA] Merger: All Documents together (2)
To: Brett Pentland <[email-masked]>
Cc: [email-masked], [email-masked]

> > The PROTO document is already dependent on both TENT and CPL and 
> there> are synergies with what's in HOSTS as well.  If they were 
> simple self
> > contained ideas (TENT is) then it might be good to keep them 
> separate> but I don't think they are and the array of documents at 
> the minute is
> > One difficulty I see is that PROTO describes router behaviour, as 
> well> as host behaviour, and I don't think it makes sense to 
> separate 
> > them as