Subject: [DNA] QUESTION: Remove Link Down information in draft-ietf-dna-link-information-03

From: Suresh Krishnan <[email-masked]>
Date: Mon, 17 Jul 2006 18:57:48 -0400

Hi Folks,
   In its current form draft-ietf-dna-link-information-03 provides 
information about both link up and link down events. There were some 
concerns raised about the presence of link down events in this document, 
since DNA does not necessarily use the link down event. So instead of 
spending time to understand how to treat this event in this WG, one 
proposed solution was to remove link down related info from this 
document and let other wgs(perhaps future ones) work on it. If you have 
any opposition to this solution please respond to the mailing list by 
the 24th of July 2006 stating your objection.

Cheers
Suresh and Greg

---

From: James Kempf <[email-masked]>
Date: Tue, 18 Jul 2006 09:18:49 -0700

I'm fine with this. The history of Link Down in IETF is that nobody has ever 
figured out a way to allow it to be done securely. I hope that we can record 
this somewhere (maybe an RFC "Link Down Considered Harmful"? from the IAB) 
so people stop wasting time on it.

            jak

----- Original Message ----- 
From: "Suresh Krishnan" <[email-masked]>
To: "Dna" <[email-masked]>
Cc: "greg Daley" <[email-masked]>; "Bernard Aboba" 
<[email-masked]>; "Jari Arkko (JO/LMF)" <[email-masked]>; 
"Alper Yegin" <[email-masked]>
Sent: Monday, July 17, 2006 3:57 PM
Subject: [DNA] QUESTION: Remove Link Down information in 
draft-ietf-dna-link-information-03

> proposed solution was to remove link down related info from this document 
> and let other wgs(perhaps future ones) work on it. If you have any 
> opposition to this solution please respond to the mailing list by the 24th 
> of July 2006 stating your objection.
>
> Cheers
> Suresh and Greg
>

---

From: Alper Yegin <[email-masked]>
Date: Tue, 18 Jul 2006 15:52:01 -0700

Hi James,

Can you expand on that a bit more? It sounds like you are suggesting there
are L2 technologies and architectures that can secure link up but not link
down? Otherwise link up would be as harmful as link down is.

Alper

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: Tuesday, July 18, 2006 9:19 AM
> To: [email-masked]; Dna
> Cc: greg Daley; Bernard Aboba; Jari Arkko (JO/LMF); Alper Yegin
> Subject: Re: [DNA] QUESTION: Remove Link Down information in draft-ietf-
> dna-link-information-03
> 
> document

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 19 Jul 2006 13:08:35 -0400

FYI, IEEE 802.21 defines link down indication, but with more detailed
information on why the indication has been generated.  Depending on
the detailed information the receiver of the indication is allowed to
take different actions including silent discarding the indication.  It
may be possible to define more sophisticated indications in a future.
My personal opinion is that it sounds premature to conclude that link
down indication is harmful in general.

Yoshihiro Ohba

On Tue, Jul 18, 2006 at 09:18:49AM -0700, James Kempf wrote:
> I'm fine with this. The history of Link Down in IETF is that nobody has 
> ever figured out a way to allow it to be done securely. I hope that we can 
> record this somewhere (maybe an RFC "Link Down Considered Harmful"? from 
> the IAB) so people stop wasting time on it.
> 
>            jak
>

---

From: Greg Daley <[email-masked]>
Date: Wed, 19 Jul 2006 16:04:18 -0400

Hi,

I think that this is a good point.  There's a mix
of protocols which have different properties
regarding Link-Down indications.

802.21 is one of those which is potentially better behaved,
while PPP (LCP) and existing 802.11 are poorly behaved,
as anyone may forge a packet to tear down the connection.

In the PPP case it was because the protocol was designed
when people trusted the physical layer to be under the
MAC, in 802.11, I guess it was an oversight.

The better behaved protocols may potentially
be used to send indications up the stack to control
packet queuing and vertical handovers.

We haven't described 802.21 here though, because of
the simultaneous development of the specifications.

Greg

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 19 Jul 2006 16:39:26 -0400

Security of link layer indications would heavily depend on the link
layer security characteristics.  I'd say that any link-layer
indication generated as a result of receipt of unprotected link-layer
frames is an issue even if IEEE 802.21 is used.  On the other hand, if
indications are generated as a result of receipt of protected
link-layer frames, then the indications can be useful even if 802.21
is not used.  

802.21 also supports remote delivery of link layer indications using
MIHF (Medie-Independent Handover Function) protocol.  This remote
delivery needs to be proteced by MIHF protocol transport.

BTW, there was a tutorial on IEEE 802.21 in IEEE 802 plenary yesterday
and the slides are available at:

http://www.ieee802.org/21/doctree/2006-07_meeting_docs/802%2021-IEEE-Tutorial.ppt

Hope this helps,
Yoshihiro Ohba

On Wed, Jul 19, 2006 at 12:53:57PM -0700, James Kempf wrote:
> Yoshi,
> 
> What kind of security is on this?
> 
>            jak
> 
> From: "Yoshihiro Ohba" <[email-masked]>
> To: "James Kempf" <[email-masked]>
> Cc: <[email-masked]>; "Dna" <[email-masked]>; "greg 
> Daley" <[email-masked]>; "Bernard Aboba" 
> Sent: Wednesday, July 19, 2006 10:08 AM
> Subject: Re: [DNA] QUESTION: Remove Link Down information in