Subject: [dns-dir] FW: Requesting IAB help on E2MD BOF

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 17 Mar 2010 21:16:22 +0100

DNS-DIR,

I think that the DNS-DIR folks can help with this request from the RAI
AD. 

Regards,

Dan

....

the E2MD BOF, which is a RAI BOF that will take place on Wednesday,
deals with the use of the DNS for resolving E.164 numbers into metadata
when ENUM cannot be used.

http://www.ietf.org/proceedings/10mar/agenda/e2md.txt

... if people with DNS expertise could attend the BOF, that would be
great. Given that this BOF deals with uses of the DNS that may differ
from its traditional use, we would like to get feedback from DNS people.

Thanks,
Cullen

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 17 Mar 2010 14:51:30 -0600

To provide a bit more info, this BOF *might* be proposing some of the following type of changes to DNS:

* different answer depending on who makes the query 
* assumed support for large responses for certain queries
* assumption that  data will be will not leak from private DNS space to public DNS space 
* when used in walled garden, it will store data requiring significant privacy relating to people 

I'm not 100% sure what the BOF will be proposing but I do know these type of changes to DNS are in the range of things being discussed. Obviously the IESG would want to hear from DNS experts on this and the BOF is the right place to get the conversation going. If anyone from the DNS Directorate wanted agenda time at the BOF, please contact the chairs ASAP. 

I'd also appreciate input on what Area this should be in. The requirements driving it came out of RAI use cases but it is not at all obvious to me which area it best fits in.

Thank, Cullen

> from its traditional use, we would like to get feedback from DNS people.

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Patrik Fältström <[email-masked]>
Date: Wed, 17 Mar 2010 22:07:03 +0100

Ok, given a DNS and ENUM person, I take the token on being there.

   Patrik

On 17 mar 2010, at 21.16, Romascanu, Dan (Dan) wrote:

> _______________________________________________
> dns-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-dir

---

From: Peter Koch <[email-masked]>
Date: Fri, 19 Mar 2010 13:45:18 +0100

> > from its traditional use, we would like to get feedback from DNS people.

will also attend.

-Peter

---

From: Olaf Kolkman <[email-masked]>
Date: Fri, 19 Mar 2010 06:41:40 -0700

> Ok, given a DNS and ENUM person, I take the token on being there.

I've read the drafts and my main question is why stick to DDNS?

It seems we are at a point where DDNS lost its lightweightness. 

Has it been considered to device a new service/protocol where all this metadata can be found. Where DDNS is used to locate those services? (more or less along the idea of draft-faltstrom-uri but maybe even more direct).

It seems to me that the devices that need to know of these services are not leightweight devices and can deal with a bit of extra protocol stack.

But then again, I am not following this all to closely.

--Olaf 
(I have blocked time to get to the BOF, but interrupts during IETF are unpredictable)

________________________________________________________ 

Olaf M. Kolkman                        NLnet Labs
                                       Science Park 140, 
http://www.nlnetlabs.nl/               1098 XG Amsterdam

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 20 Mar 2010 07:37:02 -0400

> Has it been considered to device a new service/protocol where all this metadata can be found. Where DDNS is used to locate those services? (more or less along the idea of draft-faltstrom-uri but ma…

While talking about it.

I would like to have more people reading draft-faltstrom-uri. Some people ask for those features, so I am on my way at this IETF push it forward.

Just so you all know.

   Patrik