Subject: [dns-privacy] I-D Action: draft-ietf-dprive-dtls-and-tls-profiles-07.txt

From: [email-masked]
Date: Fri, 28 Oct 2016 08:54:06 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DNS PRIVate Exchange of the IETF.

        Title           : Authentication and (D)TLS Profile for DNS-over-(D)TLS
        Authors         : Sara Dickinson
                          Daniel Kahn Gillmor
                          Tirumaleswar Reddy
	Filename        : draft-ietf-dprive-dtls-and-tls-profiles-07.txt
	Pages           : 23
	Date            : 2016-10-28

Abstract:
   This document discusses Usage Profiles, based on one or more
   authentication mechanisms, which can be used for DNS over Transport
   Layer Security (TLS) or Datagram TLS (DTLS).  This document also
   specifies new authentication mechanisms - it describes several ways a
   DNS client can use an authentication domain name to authenticate a
   DNS server.  Additionally, it defines (D)TLS profiles for DNS clients
   and servers implementing DNS-over-(D)TLS.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dprive-dtls-and-tls-profiles/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-dprive-dtls-and-tls-profiles-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dprive-dtls-and-tls-profiles-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Sara Dickinson <[email-masked]>
Date: Fri, 28 Oct 2016 16:57:33 +0100

Hi All, 

This version includes the following changes motivated by the discussion on SPKI pinsets

- Re-work of the Abstract and Introduction to better describe the contents in this version
- Terminology: New definition of “authentication information"
- Scope: Changes to the Scope section
- Moved discussion of combining authentication mechanism earlier
- Changes to the section headings and groupings to make the presentation more logical

This was mostly moving things around but there is some new text, particularly in the Introduction and it does slightly change the flow of the document. Paul - I haven’t moved the ‘source of domain names’ earlier as I think it is in better context where it is in this version but please let me know what you think.

I hope this improves the overall readability but another round of reviews would be most welcome. 

It doesn’t contain any changes to the description of Opportunistic Security which is still under discussion on the list.

Sara.  

> On 28 Oct 2016, at 16:54, [email-masked] wrote:
> 
> 
> _______________________________________________
> dns-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-privacy