Subject: [dns-privacy] I-D Action: draft-ietf-dprive-dtls-and-tls-profiles-06.txt

From: [email-masked]
Date: Fri, 28 Oct 2016 04:01:00 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DNS PRIVate Exchange of the IETF.

        Title           : Authentication and (D)TLS Profile for DNS-over-(D)TLS
        Authors         : Sara Dickinson
                          Daniel Kahn Gillmor
                          Tirumaleswar Reddy
	Filename        : draft-ietf-dprive-dtls-and-tls-profiles-06.txt
	Pages           : 22
	Date            : 2016-10-28

Abstract:
   This document describes how a DNS client can use a domain name to
   authenticate a DNS server that uses Transport Layer Security (TLS)
   and Datagram TLS (DTLS).  Additionally, it defines (D)TLS profiles
   for DNS clients and servers implementing DNS-over-TLS and DNS-over-
   DTLS.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dprive-dtls-and-tls-profiles/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-dprive-dtls-and-tls-profiles-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dprive-dtls-and-tls-profiles-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Sara Dickinson <[email-masked]>
Date: Fri, 28 Oct 2016 12:02:40 +0100

Hi All, 

I wanted to break the current set of updates into two so I didn’t miss anything this time. 

This -06 version corrects the minor issues raised in the recent reviews along with adding improved text at the end of section 4.2 and introducing the term ‘Authentication domain name’:

 *  Introduction: Re-word discussion of Working group charter.
 *  Introduction: Re-word first and third bullet point about ‘obtaining'  a domain name and IP address.
 *  Introduction: Update reference to DNS-over-TLS draft.
 *  Terminology: Change forwarder/proxy to just forwarder
 *  Terminology: Add definition of 'Authentication domain name' and use this throughout
 *  Section 4.2: Remove parenthesis in the table.
 *  Section 4.2: Change the text after the table as agreed with Paul Hoffman.
 *  Section 4.3.1: Change title and remove brackets around last  statement.

The -07 version will be available shortly that will be re-structured to clarify Usage profiles vs authentication mechanisms and SPKI pinset scope/usage. 

Sara. 

> On 28 Oct 2016, at 12:01, [email-masked] wrote:
> 
> 
> _______________________________________________
> dns-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-privacy