Subject: [dns-privacy] [[email-masked]: I-D Action: draft-bortzmeyer-dprive-resolver-to-auth-00.txt]

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 2 Jan 2018 12:36:49 +0100

New Year Resolution for 2018: securing (privacy-wise) the
communication from the resolver to the authoritative name server.

draft-bortzmeyer-dprive-step-2 was not a big success probably because
it was too open, mentinong too many possibilities. Here, I propose
just one method. Comments and criticisms welcome.

Subject: I-D Action: draft-bortzmeyer-dprive-resolver-to-auth-00.txt
From: [email-masked]
To: <[email-masked]>
Date: Tue, 02 Jan 2018 03:30:15 -0800
List-Id: Internet Draft Announcements only <i-d-announce.ietf.org>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Encryption and authentication of the DNS resolver-to-authoritative communication
        Author          : Stephane Bortzmeyer
	Filename        : draft-bortzmeyer-dprive-resolver-to-auth-00.txt
	Pages           : 7
	Date            : 2018-01-02

Abstract:
   This document proposes a mechanism for securing (privacy-wise) the
   communication between the DNS resolver and the authoritative name
   server.

   REMOVE BEFORE PUBLICATION: this document should be discussed in the
   IETF DPRIVE group, through its mailing list.  The source of the
   document, as well as a list of open issues, is currently kept at
   Github [1].

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-bortzmeyer-dprive-resolver-to-auth/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-bortzmeyer-dprive-resolver-to-auth-00
https://datatracker.ietf.org/doc/html/draft-bortzmeyer-dprive-resolver-to-auth-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 2 Jan 2018 19:58:23 +0000

Hiya,

> just one method. Comments and criticisms welcome.

Thanks for writing that.

I think I'd argue to postpone definition of the strict mode
entirely, as I can't see anything like that being used for a
long time yet, which means there'd be plenty of time to see
if DANE and/or some specific flavour of TLS1.3 is the right
thing to use.

Other than that, I like it and would love to see the WG refer
to this as part of a re-chartering effort.

S.

> dns-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-privacy
> 

-- 
PGP key change time for me.
New-ID 7B172BEA; old-ID 805F8DA2 expires Jan 24 2018.
NewWithOld sigs in keyservers.
Sorry if that mucks something up;-)

---

From: "A. Schulze" <[email-masked]>
Date: Wed, 3 Jan 2018 13:17:34 +0100

> just one method. Comments and criticisms welcome.

Hello all,

I like the idea to use existing technology. The only new stuff is
I-D.ietf-tls-dnssec-chain-extension...

I just prepared my own DNS servers to be accessible via port 853 (but the chain-extension is missing)

Andreas

---

From: Sara Dickinson <[email-masked]>
Date: Mon, 8 Jan 2018 17:55:53 +0000

> On 2 Jan 2018, at 11:36, Stephane Bortzmeyer <[email-masked]> wrote:
> 

Hi Stephane, 

Many thanks for writing this - I also support this as the best starting point for the recursive to authoritative problem and a good basis for re-chartering. 

Sara. 

> Date: 2 January 2018 at 11:30:15 GMT
> Reply-To: [email-masked]
> 
> 
>

---

From: Sara Dickinson <[email-masked]>
Date: Mon, 8 Jan 2018 17:55:54 +0000

> On 2 Jan 2018, at 11:36, Stephane Bortzmeyer <[email-masked] <mailto:[email-masked]>> wrote:
> 

Hi Stephane, 

Sara. 

> From: [email-masked] <mailto:[email-masked]>
> To: <[email-masked] <mailto:[email-masked]>>
> Reply-To: [email-masked] <mailto:[email-masked]>
> 
> 
> 
> https://datatracker.ietf.org/doc/draft-bortzmeyer-dprive-resolver-to-auth/ <https://datatracker.ietf.org/doc/draft-bortzmeyer-dprive-resolver-to-auth/>
>