Subject: Re: [dnsext] Re: [DNSOP] Priming query transport selection

From: Alfred Hönes <[email-masked]>
Date: Thu, 14 Jan 2010 21:05:02 +0100 (MEZ)

Paul Hoffman wrote:

> At 9:58 PM +0100 1/13/10, Alfred Hönes wrote:
>>
>> Did you read the News these days?
>
> Yes.
>
>> An international team lead by the BSI (the "German NSA") and others
>> has solved the RSA-768 challenge, and experts reportedly expect, due
>> to significant progresses, that RSA-1024 will be solved in a rather
>> short time, likely by the end of this year or so!
>
> I would be quite interested in seeing articles that said that.  The
> research was lead, I believe, by people in Switzerland, many of whom
> are Dutch.  Also, their paper did not say "likely by the end of this
> year or so"; the first page says "well within the next decade".
> Seriously:  I'm interested in any articles that say what you said
> above, even if they are in German.
>
> --Paul Hoffman, Director
> --VPN Consortium

As I said, it was in the News here (Radio and Newspapers).

Therefore, admittedly, the details of the content are to be taken
with a grain of salt, as always; but I explicitly said "in the News",
so I expected readers being warned.  :-)
But you are right, perhaps I'd better searched for the origin, ... :-(

Thanks to Paul and Jim Reid for pointing to the "serious" paper
on the IACR eprint server.

However, the important points from my message that used that notice
as an eye-catcher IMO still are valid:

o   If we stay with RSA keys and signatures, specific signed
    DNS responses will grow significantly in the foreseeable
    future, so that handwaving arguments trying to squeeze
    reported 5k priming query responses (etc.) into "industry
    standard" 4k EDNS0 buffer space do not provide a realistic
    solution for the mid-term future (lifecycle of RFCs and
    products).

o   Therefore, the existing support for DNS over TCP should be
    used in appropriate cases immediately, and vendors still not
    providing it should hurry up to support DNS over TCP in their
    boxes.  (Same for EDNS0, of course!)

o   DNSEXT should resume work to leverage ECC for DNSSEC in order
    to allow gaining the benefits of much shorter keys and
    signatures than in the traditional RSA case.

Kind regards,
  Alfred.

-- 

+------------------------+--------------------------------------------+
| TR-Sys Alfred Hoenes   |  Alfred Hoenes   Dipl.-Math., Dipl.-Phys.  |
| Gerlinger Strasse 12   |  Phone: (+49)7156/9635-0, Fax: -18         |
| D-71254  Ditzingen     |  E-Mail:  [email-masked]                     |
+------------------------+--------------------------------------------+

---

From: [email-masked]
Date: Thu, 14 Jan 2010 21:01:17 +0000

>     signatures than in the traditional RSA case.

	ECC really needs more work inside this group.

--bill

---

From: David Conrad <[email-masked]>
Date: Thu, 14 Jan 2010 14:21:40 -0800

> 	ECC really needs more work inside this group.

Wow.  I actually agree with the inimitable Mr. Manning.  This always worries me when this happens.  :-)

Regards,
-drc