Subject: [dnsext] Question on NAPTR text format

From: [email-masked]
Date: Tue, 2 Feb 2010 12:05:42 +0000

Hi - 

I'm hoping somebody can please help me understand how to treat the 
following text in a NAPTR/TXT record  : 

"blah\2blah" 

We have from RFC 1035 : 

\X              where X is any character other than a digit (0-9), is
               used to quote that character so that its special meaning
               does not apply.  For example, "\." can be used to place
               a dot character in a label. 

and 

\DDD            where each D is a digit is the octet corresponding to
               the decimal number described by DDD.  The resulting
               octet is assumed to be text and is not checked for
               special meaning.

So what happens if there is only one digit, instead of three? (i.e. \D) 

Should this be taken as : 

1) a one digit decimal number specifying an octet between 0 and 9 (e.g. 
\002) 
2) the number character itself (e.g. '2') 
3) an error? 

I've noticed that different libraries take different views on this, and 
thought it would be nice to have more common behaviour. 

Thanks in advance for your help! 

Alex.

---

From: Mark Andrews <[email-masked]>
Date: Wed, 03 Feb 2010 08:33:25 +1100

In message <[email-masked]
> 2) the number character itself (e.g. '2') 

It's a error because it is undefined.
 
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 2 Feb 2010 18:10:40 -0500

Right, see RFC 4343:
"A back-slash followed by only one or two decimal digits is undefined"

Donald
=============================
Donald E. Eastlake 3rd   +1-508-634-2066 (home)
155 Beaver Street
Milford, MA 01757 USA
[email-masked]

On Tue, Feb 2, 2010 at 4:33 PM, Mark Andrews <[email-masked]> wrote:

>
> In message
> <[email-masked]