Subject: [dnsext] Fwd: I-D Action:draft-jabley-dnssec-trust-anchor-00.txt

From: Joe Abley <[email-masked]>
Date: Wed, 29 Sep 2010 12:47:33 +0000

FYI

Begin forwarded message:

> From: [email-masked]
> Date: 29 September 2010 12:45:03 GMT
> To: [email-masked]
> Subject: I-D Action:draft-jabley-dnssec-trust-anchor-00.txt 
> Reply-To: [email-masked]
> list-id: Internet Draft Announcements only <i-d-announce.ietf.org>
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : DNSSEC Trust Anchor Publication for the Root Zone
> 	Author(s)       : J. Abley, J. Schlyter
> 	Filename        : draft-jabley-dnssec-trust-anchor-00.txt
> 	Pages           : 16
> 	Date            : 2010-09-29
> 
> The root zone of the Domain Name System (DNS) has been
> cryptographically signed using DNS Security Extensions (DNSSEC).
> 
> In order to obtain secure answers from the root zone of the DNS using
> DNSSEC a client must configure a suitable trust anchor.  This
> document describes how such trust anchors are published.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-jabley-dnssec-trust-anchor-00.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: John Dickinson <[email-masked]>
Date: Thu, 30 Sep 2010 14:12:43 +0100

Hi,

Would it be useful for the xml to be able to provide information on the intentions of the zone operator. For example, at the moment a validator operator has no information about which of the 4 possible sections of an unbound conf to put this TA in.

Some hint like <RollMethod>RFC5011</RollMethod> would be useful IMHO.

John

On Sep 29, 2010, at 1:47 PM, Joe Abley wrote:

> <Mail Attachment>

---

From: Joe Abley <[email-masked]>
Date: Thu, 30 Sep 2010 13:20:53 +0000

> Some hint like <RollMethod>RFC5011</RollMethod> would be useful IMHO.

If we were to include such machine-parseable tokens then I imagine we'd do it with XML elements that were specified in the schema, e.g.

  <RollMethod><rfc5011/></RollMethod>

However, I'm not convinced I understand the use case to which you refer. Can you explain further?

Joe