Subject: [dnsext] [Technical Errata Reported] RFC6605 (6341)

From: RFC Errata System <[email-masked]>
Date: Sun, 22 Nov 2020 01:53:16 -0800 (PST)

The following errata report has been submitted for RFC6605,
"Elliptic Curve Digital Signature Algorithm (DSA) for DNSSEC".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6341

--------------------------------------
Type: Technical
Reported by: Mattia Bencivenga <[email-masked]>

Section: 1

Original Text
-------------
For example, in a signature that uses RSA with 2048-bit keys and SHA-256, the signing portion is significantly weaker than the hash portion, whereas the two algorithms here are balanced.

Corrected Text
--------------
For example, in a signature that uses RSA with 2048-bit keys and SHA-256, the hash portion is significantly weaker than the signing portion, whereas the two algorithms here are balanced.

Notes
-----
The signing portion should be RSA with 2048 bits so, the overall security is 1024 bits while the hash portion is SHA-256 that has an overall security of 128 bits. Therefore the hash portion is weaker than the signing portion.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6605 (draft-ietf-dnsext-ecdsa-07)
--------------------------------------
Title               : Elliptic Curve Digital Signature Algorithm (DSA) for DNSSEC
Publication Date    : April 2012
Author(s)           : P. Hoffman, W.C.A. Wijngaards
Category            : PROPOSED STANDARD
Source              : DNS Extensions
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: "Paul Hoffman" <[email-masked]>
Date: Sun, 22 Nov 2020 09:56:52 -0800

On 22 Nov 2020, at 1:58, Mattia Bencivenga wrote:

> Do not verify this report, just reject it. The original version is 
> correct.

Agree. In fact, if it can just be removed from the errata dataset, that 
would be best.

--Paul Hoffman

---

From: Megan Ferguson <[email-masked]>
Date: Tue, 24 Nov 2020 08:55:35 -0500

Hi Paul and Mattia,

We have deleted this errata report as requested.

Thank you.

RFC Editor/mf

On Nov 22, 2020, at 12:56 PM, Paul Hoffman <[email-masked]> wrote:

>> Do not verify this report, just reject it. The original version is correct.
> 
> Agree. In fact, if it can just be removed from the errata dataset, that would be best.
> 
> --Paul Hoffman
>