Subject: Re: I-D ACTION:draft-ietf-dnsind-rfc2052bis-00.txt

From: Andy Barclay <[email-masked]>
Date: Wed, 9 Sep 1998 14:42:31 -0700 (PDT)

>     Date:        Tue, 08 Sep 1998 06:54:57 +1000
>     From:        [email-masked]
>     Message-ID:  <[email-masked]>
> 
>     A name use to identify a machine.
> 
> That's OK, in which case all of the names in the DNS which are not
> to identify machines (all the virtual domain names, all the names of
> services, like "www...." "ftp..." etc) are not subject to those
> restrictions.
> 
> Then, since you have no way to tell what is one of those and what is
> the name of a machine, you can't really object to any name you see.

I could just as easily say here that since you have no way to tell which
is a hostname and which isn't, that the hostname restrictions should apply
to ALL dns names....

--
Regards,
Andy W. Barclay.        [email-masked]
Always a UNIX Evangelist (and sometimes a system and network architect)

Defeat isn't bitter if you don't swallow it.

---

From: Robert Elz <[email-masked]>
Date: Thu, 10 Sep 1998 10:55:30 +1000

Date:        Wed, 9 Sep 1998 14:42:31 -0700 (PDT)
    From:        Andy Barclay <[email-masked]>
    Message-ID:  <[email-masked]>

You could, but you'd be wrong.   The DNS spec has always been very
clear that anything at all is legal as a DNS name.

kre

---

From: "Randall S. Winchester" <[email-masked]>
Date: Wed, 9 Sep 1998 23:16:50 -0400 (EDT)

On Wed, 9 Sep 1998, Andy Barclay wrote:
: >     Date:        Tue, 08 Sep 1998 06:54:57 +1000
: >     From:        [email-masked]
: >     Message-ID:  <[email-masked]>
: > 
: >     A name use to identify a machine.
: > 
: > That's OK, in which case all of the names in the DNS which are not
: > to identify machines (all the virtual domain names, all the names of
: > services, like "www...." "ftp..." etc) are not subject to those
: > restrictions.
: > 
: > Then, since you have no way to tell what is one of those and what is
: > the name of a machine, you can't really object to any name you see.
: 
: 
: I could just as easily say here that since you have no way to tell which
: is a hostname and which isn't, that the hostname restrictions should apply
: to ALL dns names....

That is not a correct statement! DNS name, of certain "types" MUST allow for
characters beyond what is allowed in a "hostname".

% nslookup -type=txt ee_dept.aliases.ns.glue.umd.edu | grep text

ee_dept.aliases.ns.glue.umd.edu       text ="[email-masked]"

% nslookup -type=txt Randall_Winchester.aliases.ns.glue.umd.edu | grep text

Randall_Winchester.aliases.ns.glue.umd.edu       text ="[email-masked]"

The DNS is very much a networked database of variable length text records.
(Support for data will probably be added soon.) Different CLASSES and TYPES
can have their own individual restrictions, as with any database. The only
global restrictions are those that are on the database its self.

The "_" is not a sacred character in DNS, just the most common TYPE.

Randall

---

From: Slidge <[email-masked]>
Date: Thu, 10 Sep 1998 12:59:26 -0400 (EDT)

> clear that anything at all is legal as a DNS name.

You mean like www.yahoo!.com?

---

From: Robert Elz <[email-masked]>
Date: Fri, 11 Sep 1998 04:55:14 +1000

Date:        Thu, 10 Sep 1998 12:59:26 -0400 (EDT)
    From:        Slidge <[email-masked]>
    Message-ID:  <[email-masked]>

    You mean like www.yahoo!.com

As far as the DNS is concerne, yes, of course, that is 100% perfect.
The internic might not let you register "yahoo!" in .com, that's
their choice, but if they do, the DNS will handle it just fine.

Whether HTTP will allow that or not I don't know, never having read
the HTTP spec - if it doesn't, it isn't likely to be very useful.
And of course, nothing@yahoo!.com is going to work for e-mail.

kre