Subject: Re: TXT records and what not to use them for

From: Paul A Vixie <[email-masked]>
Date: Wed, 30 Jun 1999 20:23:18 -0700

> General question: my sense has been that putting stuff in TXT records
> is OK if the intent is for humans to read it.

no.  TXT RR's are segmented, and the record boundaries have no human value.
they are also 8-bit clean on the wire, if not nec'ily in zone file parsers.

i would like to see a protocol (RFCXXXX) specifying multiple application use
of the same TXT RRset.  it would look like:

vix.com.	IN TXT	RFCXXXX YYYY application specific data

that is, XXXX and YYYY get filled in by IANA, and applications which have
to fetch a whole RRset will know which parts are "for them."  iirc, the
original harvest system had something like this recommended.

---

From: Bill Manning <[email-masked]>
Date: Thu, 1 Jul 1999 10:07:24 -0700 (PDT)

> original harvest system had something like this recommended.

	There should be something forthcoming on this after Oslo.

-- 
--bill

---

From: "Ryan Moats" <[email-masked]>
Date: Thu, 1 Jul 1999 14:36:07 -0500

| >> General question: my sense has been that putting stuff in TXT records
| >> is OK if the intent is for humans to read it.
| > 
| > no.  TXT RR's are segmented, and the record boundaries have no 
| human value.
| > they are also 8-bit clean on the wire, if not nec'ily in zone 
| file parsers.
| > 
| > i would like to see a protocol (RFCXXXX) specifying multiple 
| application use
| > of the same TXT RRset.  it would look like:
| > 
| > vix.com.	IN TXT	RFCXXXX YYYY application specific data
| > 
| > that is, XXXX and YYYY get filled in by IANA, and applications 
| which have
| > to fetch a whole RRset will know which parts are "for them."  iirc, the
| > original harvest system had something like this recommended.
| > 

FYI, the recommendation predates harvest: it goes back to
Netfind "wp-urls".  Further there have been internet drafts that I have
co-authored talking about extending this concept (I believe they
have expired by now).

Ryan Moats