Subject: Re: IPv6 and Dynamic DNS

From: Masataka Ohta <[email-masked]>
Date: Wed, 11 Aug 99 6:32:32 JST

Shane Karr;

>> This is a nice pie-in-the-sky sentiment which assumes that people are
>> willing (or even able) to deploy DHCP servers (presumably US$7000+ NT
>> systems) at dentist's offices. 
> 
> $250 will get you a PC fully capable of running Linux or FreeBSD with a

There is a >$200 box of a DHCP server.

Or, for example, your router can have default installation of DHCP
server which randomly assignes IP addresses from lower half address
ranges of subnets served by each interface, which, in practice, as
good as stateless autoconfiguration.

However, without configuration, there is no security.

> Having said that, I agree with this.  :)  Ease of use kicks ass.  Hell,
> *I* don't want to configure a DHCP server, even if it only takes 5 minutes
> to do so.  In my home, safely ensconced behind my firewall, I'd rather
> just plug and chug.

Or, for example, your firewall can have default installation of DHCP
server which randomly assignes IP addresses from lower half address
ranges of subnets served by each interface, which, in practice, as
good as stateless autoconfiguration.

However, without configuration, not even 5 minutes of it, your firewall
offer no security.

No security implies no security for DNS dynamic update, of course.

							Masataka Ohta

---

From: Terry Lambert <[email-masked]>
Date: Tue, 10 Aug 1999 15:31:26 -0700

Shane Kerr wrote:
> 
> On Tue, 10 Aug 1999, Terry Lambert wrote:
> 
> > This is a nice pie-in-the-sky sentiment which assumes that
> > people are willing (or even able) to deploy DHCP servers
> > (presumably US$7000+ NT systems) at dentist's offices.
> 
> $250 will get you a PC fully capable of running Linux or
> FreeBSD with a DHCP server (and a WWW server, a SENDMAIL
> server, a FTP server, Samba, an NFS server, a DNS server,
> a POP3 server, an IMAP server, and an SQL server).  Make
> that $275 with a network card and modem.  This is a
> dentist's office we're talking about after all, not
> Amazon.com!

As the person who wrote the orignal 386BSD FAQ and 386BSD
patchkit, which later resulted in FreeBSD, among other
significant BSD contributions, such as loadable kernel modules,
and as a Senior Software Engineer at a company that has been
shipping an embedded system product based on FreeBSD to do
exactly what you describe for over 3 years and 10's of
thousands of units, I am well aware of this.  8-).

Unimpressed, my dentist still says "Free what?".  8-(.

We are in the realm of people who buy their computer
equipment at OfficeMax, or, on a good day and if they
are in the right region of the US, from Fry's.

They either buy what they see advertised, or they buy
what their computer guy tells them to buy (probably based
on how much margin he gets from the deal).

These people are buying service, and they are buying
what they are told to buy.

If you are contributing to an IETF group discussion at
all, you are the road crew.  The average driver really
doesn't care what you do, so long as you don't close
too many lanes at once, they don't get rock chips on
their windshield, and the bridges don't collapse.  This
is for whom you are building.

The point of this posting is to support the idea that
people are going to do what's easy, not what's right,
and if you offer them a choice between easy+wrong and
hard+right, they are going to pick easy+wrong almost
every time (c.v. PAP/CHAP, the Windows 95 "remember this
password for next time" checkbox, etc., etc.).

So I think it's not a good idea to offer an option which
is labelled as "wrong" (or, conversely, to label as
"wrong" an option which is offered).

[ ... ]

> > People do not want to configure DHCP servers.  Neither do
> > they want to configure client machines, nor printers.  In
> > order to expand into the available market, e.g. the small
> > business, branch office, SOHO market, [read: no MIS
> > department] vendors must accept this as a reality.
> 
> Having said that, I agree with this.  :)  Ease of use kicks
> ass.  Hell, *I* don't want to configure a DHCP server, even
> if it only takes 5 minutes to do so.  In my home, safely
> ensconced behind my firewall, I'd rather just plug and chug.

And you are educated on what it takes to do this; consider
my poor dentist, who is confused when the Windows 98 box he
just bought at OfficeMax asks where his LDAP server lives
(I told him he can just ignore it -- before that he was afraid
to hit "Enter", and afraid to turn the machine off).

IMO, any requirement that gets in the way of spontaneous
networking by non-computer professional end users is by
definition a bad thing.

-- Terry Lambert
-- Whistle Communications, Inc., an I.B.M. Company
-- [email-masked]
-------------------------------------------------------------------
This is formal notice under California Assembly Bill 1629, enacted
9/26/98 that any UCE sent to my email address will be billed $50
per incident to the legally allowed maximum of $25,000.