Subject: Re: Should a nameserver know about itself?

From: [email-masked]
Date: Wed, 09 May 2001 17:54:54 +1000

> 	The assumption is incorrect.  The only time it has to be able to
> 	retrieve its own address is when it lives within a domain it
> 	serves.  It never needs to know its own name.
> 
> 	Mark

	On further reflection it only needs to know it own address
	if it is a root-server (this in not a DNS protocol requirement
	but a practical limitation imposed by BIND 4 and 8, need
	to check if we have fixed this in BIND 9, the priming query
	need the A records to be return).  The other case is when
	it is serving the zone the address records reside in.

	Mark
--
Mark Andrews, Nominum Inc.
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Sam Trenholme <[email-masked]>
Date: Thu, 10 May 2001 09:43:06 -0700 (PDT)

>     Mark> 	Send it a non-recursive query.  A nameserver should
>     Mark> always answer even if it is just a header containing
>     Mark> refused, servfail or notimp.
>
> Yes, but there is one notorious DNS implementation that doesn't do
> that. It fails to return any answer -- not even a referral for . -- if
> it's asked for a name that it isn't authoritative for.

Fortunatly, his other suggestion about sending a status opcode will get a
"not implemented" response from the "nortorious implementation" in
question.

The only DNS server I know about that has version out there that don't
correctly handle the "status" opcode is my own implentation of a DNS
server.  It used to handle a status query like a normal query.  In fact,
Mark's posting made me realize that my implementation had this problem.
In light of his posting, I just released a new bugfix release because of
this issue.

- Sam