Subject: another iesg comment on draft-ietf-dnsop-hardie-shared-root-server-06.txt

From: Randy Bush <[email-masked]>
Date: Thu, 20 Dec 2001 08:02:27 -0800

The document doesn't seem to say anything about path MTU
discovery (and potentially other ICMP error issues) for
packets sent with an anycast source address.

Since an ICMP "packet too big" will be sent back by a router to the anycast
address it might not be delivered to the anycast member that actually
sent the packet which might cause retransmissions with persistent
packet loss.

This fix is simply to point out that the responses from an anycast
address must not use path MTU discovery i.e. must not have the DF bit set.

I don't know of other ICMP errors that have similar issues.

---

From: Ted Hardie <[email-masked]>
Date: Thu, 20 Dec 2001 09:56:25 -0800 (PST)

I'll add this to the document.  

To be honest, I have never seen an implementation that
would do this after getting a udp DNS request, but
I so no harm in including the advice.

			regards,
				Ted

---

From: Alain Durand <[email-masked]>
Date: Fri, 21 Dec 2001 18:50:30 -0800

>I don't know of other ICMP errors that have similar issues.

I know this draft specificaly applies to IPv4 and not IPv6, but
in v6, the DF bit is gone, routers are not doing fragmentation
and pMTU discovery is always on....

If one day we could get IPv6 to relax the rules on anycast,
It would be nice to be able to re-use this document without too
many changes.

         - Alain.