Subject: RE: DNS discovery

From: <[email-masked]>
Date: Thu, 13 Nov 2003 19:34:17 +0200

> I already said that avoiding unnecessary RTTs is a Good Thing. However
> I think you overlooked the point I was making. Presumably at the point
> when a phone opens a connection to some web proxy or joins a network
> or whatever there will be some sort of authentication and verification
> taking place. For instance to assure the operator that the customer is
> authorised to use the service. Locating a suitable DNS server could be
> part of that authentication dance and the RTT for the "find me a name
> server" request would be lost in the noise of the telco infrastructure
> deciding what to do about the connection request, who/what to invoice
> and log, etc, etc.

I suppose I indeed overlooked your point, sorry. 

The wasted time is not much for one user. Perhaps it is not much even for an operator. One point I wish to make is that when the wasted time is multiplied by possibly hundreds of millions of users worldwide - even daily perhaps - isn't it worth of serius consideration in system/protocol desing? 

I see that point as one reasoning to vote for cheaper IPv6 DNS discovery mechanism than DHCPv6(-lite) with RTT cost and I wished to share the reasoning with the group.

I'd also like to see more discussion about user experience, as these kind of issues do affect end users. Or am I out of scope here? I think that reasonable(?) extra effort for network configuration can be justified if user time and cost can be saved.

Actually 3GPP has standardized a mechanism for providing IPv6 DNS addresses in GPRS PDP context activation.

And then one comment from (host) stack implementor point of view. I'd like to do the (host) stack implementation as independent as possible from the lower layers for portability, testing, quality, and interworking reasons (with different underlying network technologies) and thus I wish to have a cheap, general solution for DNS discovery. For that "requirement" a specific 3GPP solution is not good enough. Furthermore I do not think that DHCPv6(-lite) is good for that purpose either (even if it would be implemented to stack for obtaining other possible configuration parameters). 

So please do not consider one stack implementation to be used only in one kind of networks. Even if the implementation may be used in cellular phone, and thus in that case can be provided with configuration information from cellular network, it does not mean that the same implementation is used _only_ in a cellular network (and there are many different cellular network technologies with different characteristics). It is a bugger to implement support into the same stack for obtaining DNS addresses by 3GPP methods in one case, DHCP in one, RA in one, preconfigured in some and so forth..

Regards,

      Teemu

#----------------------------------------------------------------------
# To unsubscribe, send a message to <[email-masked]>.

---

From: Ted Lemon <[email-masked]>
Date: Thu, 13 Nov 2003 12:57:19 -0600

On Nov 13, 2003, at 11:34 AM, <[email-masked]> wrote:
> I see that point as one reasoning to vote for cheaper IPv6 DNS 
> discovery mechanism than DHCPv6(-lite) with RTT cost and I wished to 
> share the reasoning with the group.

Perhaps someone will correct me if I am wrong, but I don't think 
anybody is saying you shouldn't use a cheaper mechanism in a specific 
environment like this.   That certainly wasn't what I meant when I said 
we should pick one implementation and standardize on that.

All some of us are saying is that the fallback mechanism should be 
DHCPv6-lite, and that should always be available.   If you want to 
provide RA, and the clients on your network support it, I think that's 
fine, and that cuts your round-trips down to one.   But the minimal 
correct implementation should be minimal, and there are advantages, in 
the general case, to having DHCPv6-lite be the minimal correct 
implementation.

I may be mistaken about this impression, though - some folks seem to be 
saying that we shouldn't even *allow* RA.   That is certainly not my 
position.   That *was* my position, before Tim pointed out that there's 
a bit for this in the RA, so I can understand why there might be some 
confusion.   :'}

---

From: Alain Durand <[email-masked]>
Date: Thu, 13 Nov 2003 14:23:24 -0800

>The wasted time is not much for one user. Perhaps it is not much even for an operator. One point I wish to make is that when the wasted time is multiplied by possibly hundreds of millions of users w…

I've been trying to understand better this line of reasoning, but I honestly
have a hard time to reconcile the desire to spare one packet exchange
with the opinion that some Mobile IPv6 people expressed that
RA should be send very frequently to ease movement detection....

    - Alain.