Subject: RE: How IPv6 host gets DNS address

From: <[email-masked]>
Date: Wed, 5 Nov 2003 19:31:23 -0000

> dhcpv6-stateless-01 is a reasonable compromise.  I don't 
> think the fact the current shape of the specification is not 
> ideal (IMO) can be a reason to take DHCPv6 as "the" method 
> for DNS recursing sever discovery.

I guess there should be a 'not' in there somewhere ;-) Double negatives
can be confusing! :-)

FWIW I agree with Ralph and Jinmei here. I have not seen any sensible
argument as to why DHCPv6 is not the solution here.

-----
Mat

#----------------------------------------------------------------------
# To unsubscribe, send a message to <[email-masked]>.

---

From: "BELOEIL Luc FTRD/DMI/CAE" <[email-masked]>
Date: Thu, 6 Nov 2003 09:16:45 +0100

> -----Message d'origine-----
> De : Ralph Droms [mailto:[email-masked]]
> 
> Ohta-san,
> 
> 
> I believe there are some sites who have come to the 
> conclusion that DHCPv6
> address assignment is the right deployment model, exactly 
> because it avoids
> the PTR record problem as well as giving network 
> administrators reliable
> information about mappings between devices and IPv6 addresses.
> 
> - Ralph
> 
I agree with Ralph, in some deployement model, DHCPv6 is the right
solution to be deployed. But I also believe that some other deployment
models would prefer other solution like a ND model + a simple way to
discover DNS resolvers addresses (DHCPv6-lite, well-known addresses or
RA-based solution).

Luc

---

From: <[email-masked]>
Date: Thu, 6 Nov 2003 08:27:50 -0000

> -----Original Message-----
> From: BELOEIL Luc FTRD/DMI/CAE [mailto:[email-masked]] 
> Sent: 06 November 2003 08:10

> > Of course, this is just a subjective impression, but I believe the 
> > implementation complexity should be measured by implementors, not 
> > (mainly) by protocol designers who do not implement it.
> 
> Yes I agree with you, and the complexity measurement should 
> also be done by users ;+)

I don't understand this at all. If by 'users' you mean end-users of the
network, then any solution here has to 'Just Work (tm)'. If by 'users'
you mean operators of the network, then I don't see any difference
between plugging recursive name server parameters into a DHCPv6(lite)
server or into a router for advertisement in an RA.

Mat

---

From: <[email-masked]>
Date: Thu, 6 Nov 2003 08:35:19 -0000

> Sent: 06 November 2003 08:17

> I agree with Ralph, in some deployement model, DHCPv6 is the 
> right solution to be deployed. But I also believe that some 
> other deployment models would prefer other solution like a ND 
> model + a simple way to discover DNS resolvers addresses 
> (DHCPv6-lite, well-known addresses or RA-based solution).

Let's not confuse matters. Ralph's statement was referring to the use of
DHCPv6 for address assignment. The discussion about
appropriate/desirable solutions for recursive name server discovery is
unrelated to that.

Mat

---

From: "BELOEIL Luc FTRD/DMI/CAE" <[email-masked]>
Date: Thu, 6 Nov 2003 13:49:22 +0100

ok Matt, thanks for the clarification.

> De : [email-masked] [mailto:[email-masked]]
> Envoye : jeudi 6 novembre 2003 09:35
> A : BELOEIL Luc FTRD/DMI/CAE; [email-masked];
> [email-masked]
> Cc : [email-masked]
> Objet : RE: How IPv6 host gets DNS address
> 
>