Subject: RE: How IPv6 host gets DNS address

From: "BELOEIL Luc FTRD/DMI/CAE" <[email-masked]>
Date: Thu, 6 Nov 2003 09:10:07 +0100

Hi,

> -----Message d'origine-----
> De?: [email-masked] 
> 
> >>>>> On Thu, 06 Nov 2003 03:32:25 +0900, 
> >>>>> JINMEI Tatuya <[email-masked]> said:
> 
> >> Please see draft-ietf-dhc-.txt, which is
> >> in IETF last call.  It gives the subset of DHCPv6 that 
> must be implemented
> >> for host configuration without address assignment.
> 
> >> "another process on the server side" is an implementation 
> detail.  Because
> >> the DHCPv6 function for host configuration maintains no 
> dynamic per-client
> >> state, the code can, in fact, be implemented as code that 
> is executed in
> >> the same way as router solicitation code.  I strongly 
> believe, based on
> >> implementation experience, that the implementation 
> complexity of DHCPv6
> >> for host configuration is *not* prohibitive.
> 
> (I forgot to mention one important thing in my previous response)
> 
> I also strongly believe, *based on my implementation experience*, that
> the implementation complexity of DHCPv6 for host configuration is
> *not* prohibitive. 

Sorry, my opinion on complexity of DHCPv6 may be a bit subjective and not objective. :+(

> Of course, this is just a subjective impression,
> but I believe the implementation complexity should be measured by
> implementors, not (mainly) by protocol designers who do not implement
> it.

Yes I agree with you, and the complexity measurement should also be done by users ;+)

Regards
Luc

> 
> 					JINMEI, Tatuya
> 					Communication Platform Lab.
> 					Corporate R&D Center, 
> Toshiba Corp.
> 					[email-masked]
> #-------------------------------------------------------------
> ---------
> # To unsubscribe, send a message to <[email-masked]>.
> 
#----------------------------------------------------------------------
# To unsubscribe, send a message to <[email-masked]>.

---

From: Randy Bush <[email-masked]>
Date: Thu, 6 Nov 2003 07:46:19 -0800

</ad>

>> but I believe the implementation complexity should be measured
>> by implementors, not (mainly) by protocol designers who do not
>> implement it.

as i user, of course i agree.  problem is, the way we _measure_ it
is by software failure rates in the field, very far down the
implementation path.  the architectural decision process is more
profitably aided by earlier feedback.

randy