Subject: [dnsop] software distribution snapshot

From: bill <[email-masked]>
Date: Mon, 8 Dec 2003 09:51:28 -0800 (PST)

This might be of marginal operational interest:

4q2003 DNS audit ::  Software Distribution/Authoritative Servers
	-----------------

BIND 4 (all versions)		2,349 	  
BIND 8 (all versions)  		28,450	 
BIND 9 (all versions)		45,273	  
Microsoft (all versions)	11,340
DJBdns				3,438
Others				9,731

Total:				100,581

Split another way:

Non-Recursive (or not checked)	35,941
Recursive                       64,640

your trivia for the day... :)

--bill
.
dnsop resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/dnsop.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/dnsop/index.html

---

From: Miek Gieben <[email-masked]>
Date: Mon, 8 Dec 2003 19:26:39 +0100

[On 08 Dec, @18:51, Bill wrote in "[dnsop] software distribution  ..."]
> 4q2003 DNS audit ::  Software Distribution/Authoritative Servers

what did you test? .com, .net? Random selection of Internet servers?

grtz Miek
.

---

From: bill <[email-masked]>
Date: Mon, 8 Dec 2003 12:55:00 -0800 (PST)

> what did you test? .com, .net? Random selection of Internet servers?

	the quarterly DNS audit trys to hit every delegation in the
	whole tree.  the list of targets here is about 60% of the total
	server list.  It does not contain com/net, does have org,nl, and
	all of arpa.  

--bill
.

---

From: bill <[email-masked]>
Date: Mon, 8 Dec 2003 14:11:05 -0800 (PST)

> bill wrote:
> 
> >It does not contain com/net, 
> >
> Just curious, how well do you think those numbers map to .com/.net?
> Do you think we can extrapolate or is there any reason to believe the 
> situation
> is very different there?
> 
>     - Alain.

	I have not mapped the swd per delegation so I don't
	(yet) have those numbers.  When adding in all the delegations,
	the percentages do shift.

--bill
.

---

From: Alain Durand <[email-masked]>
Date: Mon, 08 Dec 2003 13:59:47 -0800

- Alain.

.

---

From: "D. J. Bernstein" <[email-masked]>
Date: 12 Dec 2003 19:04:47 -0000

Bill Manning writes:
> the quarterly DNS audit trys to hit every delegation

But it fails to do so. You have an undisclosed number of AXFR rejections
leading to an unknown number of servers. What you're surveying are DNS
servers whose parents allow promiscuous AXFR---basically, whose parents
are old, badly managed sites. You're missing a huge number of 3LDs.

My survey a year ago (http://cr.yp.to/djbdns/dns1.html) located 487828
different IP addresses for 599366 DNS server names. This is far more
than the 100581 found by your broken survey mechanism.

---D. J. Bernstein, Associate Professor, Department of Mathematics,
Statistics, and Computer Science, University of Illinois at Chicago
.
dnsop resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/dnsop.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/dnsop/index.html

---

From: bill <[email-masked]>
Date: Fri, 12 Dec 2003 16:56:27 -0800 (PST)

> ---D. J. Bernstein, Associate Professor, Department of Mathematics,

	Your survey is published as a .COM survey.  The preliminary
	numbers I used was selected to most closely match 100,000
	servers from a variety of zones, most outside the US, making 
	percentage estimates painfully obvious. 

	I expect to have the full suite finished, including .COM
	early in the week...  We'll take the .COM data independently
	and, allowances for the disparity of a year, we should see
	some useful trends emerge.  

--bill 
	
.

---

From: Alain Durand <[email-masked]>
Date: Mon, 15 Dec 2003 11:01:17 -0800

>My survey a year ago (http://cr.yp.to/djbdns/dns1.html) located 487828
I tried it, error meaage: file does not exist

    - Alain.

.

---

From: "D. J. Bernstein" <[email-masked]>
Date: 16 Dec 2003 02:56:53 -0000

Sorry, here's the right URL: http://cr.yp.to/surveys/dns1.html