Subject: RE: [dnsop] ipv6-dns-configuration-02 comments

From: <[email-masked]>
Date: Wed, 4 Aug 2004 03:41:20 +0300

Pekka and others,

-----Original Message-----

>>  4) 3GPP still needs to explain whether RA's are being used at all at the
>>moment -- that is, some have at least stated that e.g., addresses/prefixes
>>are configured as part of PDP context activation, which would seem to hint
>>at the fact that even if RA's would be possible, they might not be used that
>>much..

Usage of RA in 3GPP nw is no problem, i.e. it can be and is used. I can provide some clarifying text on that in the 3GPP section. RA is a part of the 3GPP UE IPv6 addressing:

From 3GPP TS 23.060, section 9.2.1.1:
----clip----
...
1)	The MS sends an Activate PDP Context Request message to the SGSN as defined in clause "PDP Context Activation Procedure". The MS shall leave PDP Address empty and set PDP Type to IPv6.

2)	Upon reception of the Create PDP Context Request, the GGSN creates an IPv6 address composed of the prefix allocated to the PDP context and an interface identifier generated by the GGSN. This address is then returned in the PDP Address information element in the Create PDP Context Response message. The processing of the Create PDP Context Request and Create PDP Context Response, in both the SGSN and the GGSN, is otherwise as specified in clause "PDP Context Activation Procedure".

NOTE: 	Since the MS is considered to be alone on its link towards the GGSN, the interface identifier does not need to be unique across all PDP contexts on any APN.

3)	The MS receives the IPv6 address produced by the GGSN in the Activate PDP Context Accept. The MS extracts the interface identifier from the address received and stores it. The MS shall use this interface identifier to build its link-local address and may also use it for building its full IPv6 address, as describe in step 5. The MS shall ignore the prefix contained in the address received in the Activate PDP Context Accept. The processing of the Activate PDP Context Accept is otherwise as specified in clause "PDP Context Activation Procedure".

4)	The MS may send a Router Solicitation message to the GGSN to activate the sending of the Router Advertisement message.

5)	The GGSN sends a Router Advertisement message. The Router Advertisement messages shall contain the same prefix as the one provided in step 2. A given prefix shall not be advertised on more than one PDP context on a given APN, or set of APNs, within the same addressing scope. The GGSN shall be configured to advertise only one prefix per PDP context.

	After the MS has received the Router Advertisement message, it constructs its full IPv6 address by concatenating the interface identifier received in step 3, or a locally generated interface identifier, and the prefix received in the Router Advertisement. If the Router Advertisement contains more than one prefix option, the MS shall only consider the first one and silently discard the others.
...
----clip----

Cheers,
	 -Juha-

.
dnsop resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/dnsop.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/dnsop/index.html

---

From: "S. Daniel Park" <[email-masked]>
Date: Wed, 11 Aug 2004 08:07:36 +0900

Good indication and thanks Juha.

As one of IPv6-enabled mobile device manufacturer, 
I strongly second the usage of RA option for configuring 
recursive DNS Server. It's one of our business aspect
toward IPv6...

Regards.

- Daniel (Soohong Daniel Park)
- Mobile Platform Lab. Samsung Electronics.

> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of [email-masked]
> Sent: Wednesday, August 04, 2004 9:41 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [dnsop] ipv6-dns-configuration-02 comments
> 
> 
> 
> Pekka and others,
> 
> Usage of RA in 3GPP nw is no problem, i.e. it can be and is used. 
> I can provide some clarifying text on that in the 3GPP section. 
> RA is a part of the 3GPP UE IPv6 addressing:
> 
> 1)	The MS sends an Activate PDP Context Request message to the 
> SGSN as defined in clause "PDP Context Activation Procedure". The 
> MS shall leave PDP Address empty and set PDP Type to IPv6.
> 
> 2)	Upon reception of the Create PDP Context Request, the GGSN 
> creates an IPv6 address composed of the prefix allocated to the 
> PDP context and an interface identifier generated by the GGSN. 
> This address is then returned in the PDP Address information 
> element in the Create PDP Context Response message. The 
> processing of the Create PDP Context Request and Create PDP 
> Context Response, in both the SGSN and the GGSN, is otherwise as 
> specified in clause "PDP Context Activation Procedure".
> 
> NOTE: 	Since the MS is considered to be alone on its link 
> towards the GGSN, the interface identifier does not need to be 
> unique across all PDP contexts on any APN.
> 
> 3)	The MS receives the IPv6 address produced by the GGSN in 
> the Activate PDP Context Accept. The MS extracts the interface 
> identifier from the address received and stores it. The MS shall 
> use this interface identifier to build its link-local address and 
> may also use it for building its full IPv6 address, as describe 
> in step 5. The MS shall ignore the prefix contained in the 
> address received in the Activate PDP Context Accept. The 
> processing of the Activate PDP Context Accept is otherwise as 
> specified in clause "PDP Context Activation Procedure".
> 
> 4)	The MS may send a Router Solicitation message to the GGSN 
> to activate the sending of the Router Advertisement message.
> 
> 5)	The GGSN sends a Router Advertisement message. The Router 
> Advertisement messages shall contain the same prefix as the one 
> provided in step 2. A given prefix shall not be advertised on 
> more than one PDP context on a given APN, or set of APNs, within 
> the same addressing scope. The GGSN shall be configured to 
> advertise only one prefix per PDP context.
> 
> 	After the MS has received the Router Advertisement message, 
> it constructs its full IPv6 address by concatenating the 
> interface identifier received in step 3, or a locally generated 
> interface identifier, and the prefix received in the Router 
> Advertisement. If the Router Advertisement contains more than one 
> prefix option, the MS shall only consider the first one and 
> silently discard the others.
> ...
> ----clip----
> 
> Cheers,
> 	 -Juha-
> 
> .
.