Subject: Re: [dnsop] Re: Root Anycast (fwd)

From: Dean Anderson <[email-masked]>
Date: Mon, 28 Mar 2005 15:29:41 -0500 (EST)

---------- Forwarded message ----------
Date: Thu, 30 Sep 2004 20:48:37 -0400 (EDT)
From: Dean Anderson <[email-masked]>
To: Iljitsch van Beijnum <[email-masked]>
Cc: [email-masked], [email-masked]
Subject: Re: [dnsop] Re: Root Anycast (fwd)

On Thu, 30 Sep 2004, Iljitsch van Beijnum wrote:

> Note though that it's *very* hard to create a setup where packets are  
> delivered to different multicast instances, as it's hard to imagine how  
> any real-world anycast setup could match the criteria in

Its quite easy for anycast: (real names used, but not real relationships)

                Av8
              /   \
          sprint   att
              \   /
              F-root              

If Av8 turns on PPLB, traffic to F-root will go through both sprint and
att on a per-packet basis. However F-root is really anycasted, so it looks
really like this:

                              Av8

                          /           \
                  sprint                 att
                   |  |                  |  |
              ,----+--+--.            ,--+--+----.
              | router 1 |            | router 2 |  ...
              `--+-------'            `-------+--'
                 |                            |
              ,--+-------.            ,-------+--.
              | switch 1 +------------+ switch 2 |  ...
              `-+------+-'            `-+------+-'
                |      |                |      |
         ,------+-.  ,-+------.  ,------+-.  ,-+------.
         | f-root1|  | host 2 |  | f-root3|  | host 4 |  ...
         `--------'  `--------'  `--------'  `--------'
     
So, we see that some packets will go to f-root1 and some packets will go
to f-root3, on a per-packet basis. TCP will not work to an anycasted root
IF anyone on the internet uses PPLB and has the same peers/transit
providers as an anycasted root.

It might well be that packets from f-root1 and f-root3 both go through att
to Av8, assuming that f-root's operator doesn't use PPLB, but that doesn't
matter. The TCP connection can't be made or kept established.

-- 
Av8 Internet   Prepared to pay a premium for better service?
www.av8.net         faster, more reliable, better service
617 344 9000   

.
dnsop resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/dnsop.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/dnsop/index.html

---

From: "Elmar K. Bins" <[email-masked]>
Date: Tue, 29 Mar 2005 08:57:44 +0200

Dean,

[email-masked] (Dean Anderson) wrote:

> to f-root3, on a per-packet basis.

This would mean an overly simple setup at the F-Root site, and would
sacrifice stability and consistency for availability. It will work
for most situations in the Internet, but not for all. Without a real
load-balancing solution, you're in deep sh*t, certainly. To get the
setup consistent in host-server associations, you need a clustered
or SPOF (with hot-standby of course) solution.

YMMV,
	Elmar.

--

"Begehe nur nicht den Fehler, Meinung durch Sachverstand zu substituieren."
                          (PLemken, <[email-masked]>)

--------------------------------------------------------------[ ELMI-RIPE ]---

.