Subject: [DNSOP] draft-licanhuang-dnsop-urnresolution-00

From: Joe Abley <[email-masked]>
Date: Mon, 3 Dec 2007 10:37:26 -0800

Hi,

I have read your draft, draft-licanhuang-dnsop-urnresolution-00.

The question was raised just now in the dnsop working group meeting in  
Vancouver as to whether the content of this draft was suitable for  
adoption as a working group item. The question was triggered by the  
presence of "dnsop" in the draft name.

I have read your document. I do not believe it is a suitable basis for  
a dnsop working group item. Specifically:

1. The document describes a namespace which is substantially different  
form what is available in the DNS today. The existing DNS namespace is  
not addressed at all.

2. The document seems to address an extension to (or an application  
for) the protocol described in draft-licanhuang-dnsop-distributeddns,  
which (to this reader) seems clearly not to be "the DNS", at least any  
conventional meaning of that term.

Joe

_______________________________________________
DNSOP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dnsop

---

From: Mohsen Souissi <[email-masked]>
Date: Mon, 3 Dec 2007 21:44:59 +0100

I have read the I-D as well and I second Joe's point of view and his arguments below.

Mohsen.

 On 03 Dec, Joe Abley wrote:
 | Hi,
 | 
 | I have read your draft, draft-licanhuang-dnsop-urnresolution-00.
 | 
 | The question was raised just now in the dnsop working group meeting in  
 | Vancouver as to whether the content of this draft was suitable for  
 | adoption as a working group item. The question was triggered by the  
 | presence of "dnsop" in the draft name.
 | 
 | I have read your document. I do not believe it is a suitable basis for  
 | a dnsop working group item. Specifically:
 | 
 | 1. The document describes a namespace which is substantially different  
 | form what is available in the DNS today. The existing DNS namespace is  
 | not addressed at all.
 | 
 | 2. The document seems to address an extension to (or an application  
 | for) the protocol described in draft-licanhuang-dnsop-distributeddns,  
 | which (to this reader) seems clearly not to be "the DNS", at least any  
 | conventional meaning of that term.

---

From: Mohsen Souissi <[email-masked]>
Date: Mon, 3 Dec 2007 21:44:59 +0100

Mohsen.

---

From: Brian Dickson <[email-masked]>
Date: Mon, 03 Dec 2007 12:57:56 -0800

> I have read the I-D as well and I second Joe's point of view and his arguments below.
+1.
Brian

---

From: Brian Dickson <[email-masked]>
Date: Mon, 03 Dec 2007 12:57:56 -0800

+1.
Brian

---

From: Lican Huang <[email-masked]>
Date: Tue, 4 Dec 2007 04:27:06 +0000 (GMT)

When Ipv4 addresses will be Exhausted in the near future and the next generation Intenert( Ipv6) will take over,  DNS names will also be exhausted soon with the increase of  hosts and users.     Lenny Foner  has pointed other disadvantage in the today's DNS.
  Please see the section of "What's broken?" in the article of Lenny Foner in 
  http://www.cfp2000.org/workshop/materials/projects-dns.html.
   
  Domain Names in DNS must have some human-understanding meaning it,  otherwise, we can just use IP addresses or numerials for the names.  In other words, if we use     human-not-understanding  Names in DNS, the DNS system can be throwed away.
   
  The draft namespace is different with the today's DNS namespace. But,  due to the exhaustion of Names in DNS in the near future, The DNS will add new domains.
  Why adding new domain names with semantic meaning in the future?
   
  This draft can be used for search the locatons of the resources if the DNS using classified hierarchical  Domain Names. 
   
  Mohsen Souissi <[email-masked]> wrote:
  I have read the I-D as well and I second Joe's point of view and his arguments below.

Mohsen.

       
---------------------------------
 Support the World Aids Awareness campaign this month with Yahoo! for Good

---

From: Lican Huang <[email-masked]>
Date: Tue, 4 Dec 2007 04:27:06 +0000 (GMT)

Mohsen.

---

From: [email-masked]
Date: Tue, 4 Dec 2007 05:16:31 +0000

>   http://www.cfp2000.org/workshop/materials/projects-dns.html.

	Full IPv4 utilization and increasing use of IPv6 is completely
	orthonginal to DNS label exaustion.  Some have argued that all
	the "good" names are taken; e.g. the DNS is exausted.  This was
	first proposed in 1996 (to my memory) yet more than a decade later,
	we see that the domain name system is robust and growing.
	With the inherent hierarchical structure of the DNS lable, the 
	mathmatical upper bound is pretty high and we are no where near 
	DNS name exaustion.  If you have actual data indicating otherwise,
	I'd love to see the studies.

>   Why adding new domain names with semantic meaning in the future?

	DNS names do not -HAVE- to have human understandable components.
	In many cases, this is highly desired -BUT- is not required for
	use.  And yes, numeric literals have been used in the past. 
	Use of the IP address instead of the name is one of the failures
	of application design.  The IP address indicates WHERE a node is 
	in the Internet topology, not the identity of the node.  The
	Name is the indicator of the node IDENTITY.  the DNS maps names to
	addresses and makes no assurance as to the human friendliness of the
	name or the reachability of the address.  Your assertion that the
	"DNS system can be thowed away" is vacuously true.  If you find it
	non-useful, there is no requirement for you to use it.  Many people
	use the DNS to get a lable, memorable or not, and then use other
	tools to map that lable into something meaningful... e.g. SEARCH.
	It does not invalidate the use of the DNS in any way.

>   This draft can be used for search the locatons of the resources if the DNS using classified hierarchical  Domain Names. 

	I think I prefer SEARCH to be outside the DNS (having actually
	built a varient of the DNS which supported regular expression
	expansion of the "?" and "*" characters...)

	Your milage will vary.

--bill

---

From: [email-masked]
Date: Tue, 4 Dec 2007 05:16:31 +0000

Your milage will vary.

--bill

---

From: Niall O'Reilly <[email-masked]>
Date: Tue, 04 Dec 2007 10:56:26 +0000

> On 3 Dec 2007, at 20:44, Mohsen Souissi wrote:
>> I have read the I-D as well and I second Joe's point of view and  
>> his arguments [...]

	+1

On 4 Dec 2007, at 05:16, [email-masked] wrote:

> orthonginal to DNS label exaustion.

	Enough people (and I'm one of them) are convinced of this that
	any claim to the contrary needs to be persuasively argued, rather
	than just baldly stated.

> [...] we are no where near

	+1

	/Niall

---

From: Niall O'Reilly <[email-masked]>
Date: Tue, 04 Dec 2007 10:56:26 +0000

+1

	+1

	/Niall

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 4 Dec 2007 17:25:47 +0100

On Tue, Dec 04, 2007 at 04:27:06AM +0000,
 Lican Huang <[email-masked]> wrote 
 a message of 77 lines which said:

> DNS names will also be exhausted soon with the increase of  hosts
> and users. 

Sorry, but that's pure crap. The only issue is the lack of "good"
names in ".com". But there are hundreds of millions of free domain
names in ".fr", ".uk" or ".cn".

>   Domain Names in DNS must have some human-understanding meaning it,
>   otherwise, we can just use IP addresses or numerials for the
>   names. 

No, domain names' big service is STABILITY (not human-friendliness,
after all, people remember telephone numbers). If I switch from
Slicehost to another hoster, I change the IP address but I keep
http://www.bortzmeyer.org/. That's the important thing.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 4 Dec 2007 17:25:47 +0100

---

From: Lican Huang <[email-masked]>
Date: Wed, 5 Dec 2007 02:10:52 +0000 (GMT)

If  SEARCH outside DNS were full power, then  DNS would disappear soon.  And all DNS registrar companies would broken out.

  What is the difference between www.microsoft.com and www.jksdfjsdfdfsdf.com  if they represent for the same address of  http page?  We can browser the micorsoft's web page through the link of the SEARCH output easily.  But if microsoft company used www.jksdfjsdfdfsdf.com  for its domain name,   then what useful this kind of  DNS  would exist? 
   
  My opion is that in the future if DNS would survive, DNS must have some reform.
  
[email-masked] wrote:

Your milage will vary.

--bill

       
---------------------------------
 Sent from Yahoo! &#45; the World&#39;s favourite mail.

---

From: Lican Huang <[email-masked]>
Date: Wed, 5 Dec 2007 02:10:52 +0000 (GMT)

Your milage will vary.

--bill

---

From: [email-masked]
Date: Wed, 5 Dec 2007 05:23:23 +0000

> If  SEARCH outside DNS were full power, then  DNS would disappear soon.  And all DNS registrar companies would broken out.

	perhaps you are right.  at this point we don't have enough data.

>   What is the difference between www.microsoft.com and www.jksdfjsdfdfsdf.com  if they represent for the same address of  http page?  We can browser the micorsoft's web page through the link of the…

	at what poiint in time did the string "microsoft" gain any sort
	of human memorable meaning?  what would have been the result if
	Bill Gates named his new company "jksdfjsdfdfsdf"?  25 years
	later, it would be a globally recognizable mark and you would 	
	be arguing over other strings.

>   My opion is that in the future if DNS would survive, DNS must have some reform.

	you are entitled to your opinion.  others are entitled to thier
	opinions as well.  you seem to have failed, this time, to persuade
	people that adding search to the DNS is a wise & prudent thing for
	the evolution of the protocol.  im my own case, having implemented
	rudimentary search in the DNS - i can't recommend it for anyting
	other than as an interesting academic exercise.  the pieces
	you have written drafts about fail to include a key, critical 
	component of a DNS with Search capability.  Still, an interesting
	stab at a perceived problem.  It might make more sense if you actually
	had all the required peices documented.

--bill

---

From: [email-masked]
Date: Wed, 5 Dec 2007 05:23:23 +0000

--bill

---

From: Lican Huang <[email-masked]>
Date: Thu, 6 Dec 2007 15:22:04 +0000 (GMT)

My draft is about to handle possible problems when huge amount of domain names when Internet is in Ipv6 stage.  Because of  unlimited amount of  Ipv6 addresses,   unlimited amount of hosts ( servers, PC, even mobile phones, etc ) will  have static Ip addresses in the Internet.  So,  these hosts may  require  domain names  if we use Domain Name Systems as the way today. 
   
       One problem is how to implement the DNS with huge amount domain names.   I don't  think today's  DNS  implementation  can handle successively  with  huge amount domain names in the future.  That is why I wrote a distributed-dns-implementation draft to try to solve this problem.     
   
      Another question is when there are so huge amount domain names in the future,  why we don't give these domain names semantic meaning?    Can you figure out what's the meaning about "www.u8erbjsdhdfdsdf.com " from bilions of domain names?   You may say we can use SEARCH by  the key words and get the link of www.u8erbjsdhdfdsdf.com.  But, in this way, domain names are useless , because we can totally use IP address or any other handle to represent www.u8erbjsdhdfdsdf.com.  You may say we use domain names as stable name because Ip address may be changed.  But , why use these ugly domain names? Why not semantic domain names?
   
       How to name semantic domain names?  We can let specific virtual organizations ( or registrar comanies ) to do.  That is,   ICANN controls top level domains. Lower level domain names is controlled by virtual organizations ( or registrar comanies) according to the clasification of contents.  In this way, we can figure out hieararchical classification of contents  very easily by trace down the heararchical domain names.
  If domain names are named as this way , we can easily  add SEARCH power in DNS just like my draft.
   
       Semantic domain names does not  takeover the current domain names in the first stage.  We can use  new TLDs to manage semantic domain names, and let the old TLDs to be managed as the way today.  
   
  Lican  

   

--bill

> Sent from Yahoo! - the World's favourite mail.

---

From: Lican Huang <[email-masked]>
Date: Thu, 6 Dec 2007 15:22:04 +0000 (GMT)

Lican  

   

--bill

---

From: Phil Regnauld <[email-masked]>
Date: Thu, 6 Dec 2007 16:27:38 +0100

Lican Huang (huang_lican) writes:
>
>        One problem is how to implement the DNS with huge amount
>    domain names.

	Define huge -- it's already pretty huge today.

>    I don't think today's DNS implementation can handle
>    successively with huge amount domain names in the future.

	Why ?

>       Another question is when there are so huge amount domain
>    names in the future, why we don't give these domain names
>    semantic meaning? Can you figure out what's the meaning about
>    "www.u8erbjsdhdfdsdf.com " from bilions of domain names?

	DNS is a labelling mechanism, as has been pointed out before.
	I don't think people care about assigning meaning to
	"www.u8erbjsdhdfdsdf.com".

>    You
>    may say we can use SEARCH by the key words and get the link of
>    www.u8erbjsdhdfdsdf.com. But, in this way, domain names are useless
>    , because we can totally use IP address or any other handle to
>    represent www.u8erbjsdhdfdsdf.com.

	And we don't because the idea was to have a labelling mechanism
	that was distinct from the addressing mechanisme.  Nothing more.

>     You may say we use domain names
>    as stable name because Ip address may be changed. But , why use
>    these ugly domain names? Why not semantic domain names?

	Because it's not DNS anymore ?

>        How to name semantic domain names? We can let specific virtual
>    organizations ( or registrar comanies ) to do. That is, ICANN
>    controls top level domains. Lower level domain names is controlled
>    by virtual organizations ( or registrar comanies) according to
>    the clasification of contents. In this way, we can figure out
>    hieararchical classification of contents very easily by trace down
>    the heararchical domain names.

	But it's not the same protocol and architecture is it ?

>        Semantic domain names does not takeover the current domain
>    names in the first stage. We can use new TLDs to manage semantic
>    domain names, and let the old TLDs to be managed as the way today.

	The second part may be interesting, but I still fail to see how
	the existing DNS architecture will not be adequate for IPv6.

---

From: Phil Regnauld <[email-masked]>
Date: Thu, 6 Dec 2007 16:27:38 +0100

Why ?

---

From: Mark Andrews <[email-masked]>
Date: Fri, 07 Dec 2007 03:31:22 +1100

The basic premise that name use is tied to potential addresses
	is false.

	Also that fact that the address space is 2^128 in IPv6 in
	no way means that we will get 2^128 addresses assigned on
	the net.

	A more realistic estimate of address usage would be 100 *
	earth's population.   Even that is a guess, but it will
	only be a relatively small multiplier.  The number however
	is larger than 4 billion which ment that we needed a bigger
	address scheme that we have with IPv4.

	The DNS will handle whatever naming requirements humans
	need for the forseeable future.  We really don't name things
	fast enough for it to be a problem.

	Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Mark Andrews <[email-masked]>
Date: Fri, 07 Dec 2007 03:31:22 +1100

Mark

---

From: [email-masked]
Date: Thu, 6 Dec 2007 21:24:16 +0000

>      My draft is about to handle possible problems when huge amount of domain names when Internet is in Ipv6 stage.  Because of  unlimited amount of  Ipv6 addresses,   unlimited amount of hosts ( s…

	not unlimited.  there is an upper bound to the number of 
	IP addresses as well as an upper bound on the number of
	domain names.  these bounds are mathmatically fixed.

	and potentially, yes. each IP address might have a unique
	DNS domain name attached.  Or there may be more than 
	one name attached to an IP address.  Or there may be many
	IP addresses attached to one DNS domain name.

>        One problem is how to implement the DNS with huge amount domain names.   I don't  think today's  DNS  implementation  can handle successively  with  huge amount domain names in the future.…

	Your thinking here seems to be flawed.  Why do you think the DNS
	can not handle the potentially large numbers of new domain names
	which might be registered?  Please show the math.

>       Another question is when there are so huge amount domain names in the future,  why we don't give these domain names semantic meaning?    Can you figure out what's the meaning about "www.u8erb…

	dealing with larger numbers of names is a different question
	than the one of semantic meaning.   your concerns about semantic
	meaning are understandable, but flawed.  the flaws are along two
	axis...  a) that the lable www.example.com MEANS there is an HTTP
	server.   there is no such requirement or even implied assumption 
	that it is the case.  you ask the question; "what's the meaning i
	about "www.u8erbjsdhdfdsdf.com " from bilions of domain names?" to 
	which I reply - the meaning is that is the site where I can download
	my favorite licorice recipies.  It means something to ME.  Just 
	because it is not apparent to you, does not divorce it from meaning 
	to others.  this leads to the second (and perhaps fatal) flaw; 
	b) that you seem to assume ASCII encoded labels. In todays DNS,
	there are many places that do not use ASCII encoding.  DNS lables
	take the form xn-?????.xn-????.xn-???.  which in and of themselves
	have no semantic meaning whatsoever.  The beauty of the encoding
	is that when the DNS lable is handed to an application, it is able
	to decode the lable into a script that is understandable to the 
	target user... so folks who only read Mandarin can actually have
	DNS lables encoded so that they are parsed/displayed as Mandarin.
	And the same can be done for Hindi, Farsi, Korean, and even English.

>   If domain names are named as this way , we can easily  add SEARCH power in DNS just like my draft.

	Perhaps that could be made to work. I remain dubious of the 
	value, particularly in light of alternate encoding methods and
	the ambiguity on the semantic equivalence of various strings
	encoded differently.   You have not persuaded me of the value
	of proceding down this development path.

>        Semantic domain names does not  takeover the current domain names in the first stage.  We can use  new TLDs to manage semantic domain names, and let the old TLDs to be managed as the way tod…

	Show me where/how you will get enough traction to get this started
	and what real problems it solves for people that are not already 
	solved in other ways.

---

From: [email-masked]
Date: Thu, 6 Dec 2007 21:24:16 +0000

---

From: Lican Huang <[email-masked]>
Date: Fri, 7 Dec 2007 01:39:33 +0000 (GMT)

2^128 addresses may be not used all.  But I  am doubtful of  " A more realistic estimate of address usage would be 100 * earth's population. " . There are many public equipments with IP addresses in the future, may be in the street, or any public spaces. 
  However, this is not problem.  If domain names is just combinations of characters, the domain names may never exhausted forever.  My argue is "giving a new registered domain name some social meaning known by lots of other people other than just by the owner himself would be better, because domain name needs some additional value  for the corresponding IP address".     

Mark Andrews <[email-masked]> wrote:

Mark

---

From: Lican Huang <[email-masked]>
Date: Fri, 7 Dec 2007 01:39:33 +0000 (GMT)

Mark

---

From: Brian Dickson <[email-masked]>
Date: Thu, 06 Dec 2007 19:39:20 -0800

Lican Huang wrote:
> 2^128 addresses may be not used all.  But I  am doubtful of  " A more 
> realistic estimate of address usage would be 100 * earth's population. 
> " . There are many public equipments with IP addresses in the future, 
> may be in the street, or any public spaces.
> However, this is not problem.  If domain names is just combinations of 
> characters, the domain names may never exhausted forever.  My argue is 
> "giving a new registered domain name some social meaning known by lots 
> of other people other than just by the owner himself would be better, 
> because domain name needs some additional value  for the corresponding 
> IP address".    
You are overlooking one important fact:
The domain name system is hierarchical, with for all practical terms, no 
hard limit on the depth of the tree.

Your argument seems to be constructed on the incorrect assumption of a 
flat namespace.

For example, there exists today, instances of geographic naming schemes 
in some geographic areas, such as:
.ca (canada)
.on.ca (ontario)
<cityname>.on.ca

And for each of these, it is possible to get a domain name of 
appropriate scope. This way large companies get .ca, while small local 
businesses get per-city names.
This is also done under the ".gov" domain.

This ability is limited only by the willingness of local communities to 
build similar trees in their portion of the domain space, and to 
administer the tree through whatever means they choose.

So, the problem you are trying to describe, has already been solved, and 
indeed was solved by the first RFC for DNS.

Brian Dickson

---

From: Brian Dickson <[email-masked]>
Date: Thu, 06 Dec 2007 19:39:20 -0800

Brian Dickson

---

From: [email-masked]
Date: Fri, 7 Dec 2007 03:55:40 +0000

>   However, this is not problem.  If domain names is just combinations of characters, the domain names may never exhausted forever.  My argue is "giving a new registered domain name some social mean…

	and just HOW are "lots of other people" going to aquire 
	"some social meaning"?  by looking for the registry named
	"us8rjdfspiiqqbgztr3f" and then finding a link that 
	maps   "xn-feedG.cog.xn-B04s.la.ca.us." to a site that has
	the best licorice recipies in the known solar system?

	or are you going to outlaw strings that have no meaning for you
	and some arbitary group of "other people"?  a domain name has no
	-NEED- to have any additional value beyond a unique mapping to
	one or more IP addresses.

--bill

---

From: [email-masked]
Date: Fri, 7 Dec 2007 03:55:40 +0000

--bill

---

From: Måns Nilsson <[email-masked]>
Date: Fri, 07 Dec 2007 15:28:11 +0100

>> I have read the I-D as well and I second Joe's point of view and his

++;

/Måns
-- 
Måns Nilsson                     Systems Specialist
+46 70 681 7204   cell                       KTHNOC
+46 8 790 6518  office                  MN1334-RIPE

does your DRESSING ROOM have enough ASPARAGUS?
_______________________________________________
DNSOP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dnsop

---

From: Måns Nilsson <[email-masked]>
Date: Fri, 07 Dec 2007 15:28:11 +0100

++;

/Måns